(potential) work-around for Playstore authentication issue
#25
(06-16-2016, 05:49 AM)the stilton helmet Wrote: Hello Everyone.
I too have had some issues with the playstore, receiving" DL5-" and "auth error" messages even though my profile is logged into google.
I will state at this point that I`m using android 5.1 and i have a twin AA clock battery pack fitted.
However, I have noticed that my device registers the correct time about 6 seconds after bootup. The time zone I had to change manually. This was before I fitted the battery pack.

I followed the "add account" instructions (settings/accounts/ +add account/ google)
I then entered my existing account email and clicked next.
the page refreshes and a little line of type in red says "account already exists". Below this is a blue link that says "having trouble finding your account?". I clicked it.  
It then asked for my country and mobile (cell phone ) number. I typed it in. clicked next. The screen then asked for my name - first and last. This entered, I clicked next.  A white box appeared - "google will send a code to .(your number) to verify your account". I clicked verify.  A few seconds later the screen brought up a G -code verication box. An sms message arrived a moment later on my phone and I entered the code. Validated.

I have switched the device off and on twice now and it continues to work. longer trials may yield different results.
If this works for you, then all credit should go to those have posted in this area before myself.
Keex, luke, NexusDude and anyone else I have overlooked.
All I did was blunder into this. I would not have arrived at it without following their instructions.
If it fails, blame me.

Firstly, I never have had any problems with system time with no battery after changing the time zone.

Secondly, I had this DF-DLA-15 problem a lot.  Go to setting, then the Applications Manager and select "Google Play Services", stop the application and clear the cache which will reset to 12K then clear ALL DATA (the button above the cache) and to 0 bytes and REBOOT or it will still fail.  When the system is started again Google Play will work again.  You have to do this every time it occurs.  I had to do it a lot at first.  Also, install GMail first it will for an much need update to another application to occur or you can not run many Amazon applications.  I have fixed the DF-DLA-15 many times and doing those 6 steps has always fixed it.


Next, If you have a GMail account log into it.  You will have automatic access to Google Play.

Finally, some application may be block because you have regional issues.  Go to https://apkpure.com/ and download and run the .apk file for those few applications.

(07-13-2016, 02:22 PM)cantcode Wrote:
(07-12-2016, 03:58 PM)tllim Wrote: Try out pas s two days seems works well, I will upload the build tonight. We are currently working with one third party Android developer on document his progress of build the Android OS from scratch. I will post when he release the document.

Hello, can you tell me where I can find the latest Android image/build that includes the new Play Store code? 

I am having the same issue: I cannot install any apps from the play store. (Error DF-DLA-15)

Go to setting, then the Applications Manager and select "Google Play Services", stop the application and clear the cache which will reset to 12K then clear ALL DATA (the button above the cache) and to 0 bytes and REBOOT or it will still fail.  When the system is started again Google Play will work again.  You have to do this every time it occurs.  I had to do it a lot at first.  Also, install GMail first it will for an much need update to another application to occur or you can not run many Amazon applications.  I have fixed the DF-DLA-15 many times and doing those 6 steps has always fixed it.

(07-14-2016, 01:21 PM)cantcode Wrote: Hi, I wanted to reply back for anyone who might read this and who had the same problem.

I re-flashed the SD card with the 'current' Android image: http://files.pine64.org/os/android/andro...4-64GB.zip  and it seems that the Play Store is now working. I can install apps.

I tried 2 ways: 1) with a personal gmail account and 2) with a work-related account which has Google Apps for Work device policy limitations (the IT admin at work can limit which apps to install, require a password, etc.) It works both ways.

So I hope it continues to work. I don't know which Android image shipped with the Pine64, but that is the image I tried first, and had the Play Store issues.

Besides re-flashing with the current image, I made sure to download the image for HDMI Video Output. My Pine64+ came with the 7" touchscreen display, so I am assuming the Android image on the SD card was for the LCD touch screen. I have my Pine 64+ hooked up to a LED computer monitor via HDMI. So now the menu buttons are in the right place. I don't know if this made the Play Store work or not.

I hope this helps someone out there.

How do I burn to a 128 GB card?

(06-26-2016, 09:57 PM)CypherColt Wrote: My solution was to uncheck the Sync for apps and check it again, without even exiting the Google Play app. Worked right away for me.
Hope this helps!

Edit: (to specify)
I went into Settings, Accounts, Google, my email, i disabled App Data sync, and then enabled it again.

That did not work for me but ...

Go to setting, then the Applications Manager and select "Google Play Services", stop the application and clear the cache which will reset to 12K then clear ALL DATA (the button above the cache) and to 0 bytes and REBOOT or it will still fail.  When the system is started again Google Play will work again.  You have to do this every time it occurs.  I had to do it a lot at first.  Also, install GMail first it will for an much need update to another application to occur or you can not run many Amazon applications.  I have fixed the DF-DLA-15 many times and doing those 6 steps has always fixed it.

(06-30-2016, 12:45 AM)NexusDude Wrote: This continues to be an issue for my Pine64.

For my Pine64, it occurs consistently, sort of.
  • Affects all Android images -- rooted, so-called "un-rooted", RemixOS
  • GP Store will always work, initially, upon booting for the first time
  • GP Store will eventually stop permitting app downloads and app rating submissions. Even if it's working now,  give it time...
  • Once it fails, it continues to fail, until you apply a work-around fix, or re-image.
  • Once a workaround fix stops working, it continues to fail. You must try a different fix, or re-image.
(The DD images of Android all test as rooted.)

What varies:
  • The length of time that GP Store works. When you boot for the first time, or succesfully apply a workaround fix, it will work... but eventually it stops. You may get downloads & rating submissions working for hours, or only seconds. Typically, you can get in a few installs, while it's working, before it quits again. You many only get 1 install in, though, or none at all. In a one hour session of Android, you may apply fixes several times, without rebooting.
  • Sometimes, workaround fixes stop working. 
  • Pop-up vs. Notification. How the app informs the user of failure varies. A pop-up error message likely mentions DF-DLA-15. An Android notification always mentions authentication failure.
  • Multiple notifications vs. 1 notification maximum -- sometimes, you must clear the notification to be informed of future errors; other times, you can get multiple notifications
  • Various fixes, sorted by speed:
  1. Settings / Accounts / Add New Account / Google
  2. Settings / Accounts / Add New Account / Google / enter gmail of existing Google account
  3. Settings / Accounts / select account / Remove Account / Add New Account / Google / enter gmail of account you just removed
  4. Clearing GP Store and GP services caches, rebooting
  5. Wiping the Dalvik partition, rebooting
  6. Reimaging your microSD card, booting
Other things I've tried, that never helped or seem unrelated to this issue:
  • Gmail accounts with 2-step verification, vs. those without
  • Using only a single Gmail account, vs. using multiple Gmail accounts
  • Using Gmail accounts with Play Store credit, vs. those without a payment method
  • Rebooting
  • Using other images of Android
  • Using a time app to document time clock differences
  • Turning account syncing off/on
  • Various power adapters
What I have not yet tried:
  • Heat sinks / fans / cooling my house more
  • RTC battery
  • Shorter Cat6
What I've had trouble trying:
  • Wi-fi dongle
  • Mock Location -- there doesn't seem to be a way to set this
  • Using a time app to reset the time from NTP
Few have voiced their frustration on pine64.pro, which seems odd, considering the various threads on this issue. Maybe they didn't want to bother registering a new ID there?

Clearing the Cache along does NOT work, you MUST also click the clear all data button and reboot.


Messages In This Thread
RE: (potential) work-around for Playstore authentication issue - by Toriless - 07-16-2016, 03:07 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  USB GPS dongles that work with Android on Pine64+ ? trondkj 2 4,650 11-16-2017, 02:14 PM
Last Post: Skivholme
  Playstore Selections Limited in 7.1 TV CharlieB 2 3,682 10-19-2017, 12:24 PM
Last Post: Luke
  Does snapchat work on pine64 with android? user875545 1 4,422 08-29-2017, 12:05 AM
Last Post: tllim
  VPN issue on Pine64 pinea64.edison 4 6,751 06-27-2017, 12:25 PM
Last Post: milkaca
  No Intenet Access Need Help Diagnosing Underlying Issue Bob123456789 10 11,722 06-02-2017, 01:32 PM
Last Post: Bob123456789
  anyone make pine64 lcd hdmi work simultaneously bokeer 4 7,251 12-11-2016, 05:57 PM
Last Post: Luke
  ethernet does not work with Android 5.1.1 Image Release 20160711 (Known Problem) mathiraj 18 24,885 10-29-2016, 04:31 AM
Last Post: joe
  pine64 a piece of work water 4 6,185 10-28-2016, 07:41 AM
Last Post: jkmooney
  buring image with 'dd' on linux doesn't work (Solved) mathiraj 2 5,813 10-17-2016, 11:42 AM
Last Post: mathiraj
Sad Airmouse doesn't work on any Android ameth 0 2,696 09-11-2016, 06:29 AM
Last Post: ameth

Forum Jump:


Users browsing this thread: 3 Guest(s)