PBP won't boot from eMMC or SD card: a saga
#11
Most Linux distributions issue a reboot when you press ctrl-alt-del on the text console.

Regarding whether this a u-boot problem: No, if the OS is booting u-boot is fine (at least to some degree). However, if the OS is not working and you want to reinstall it or switch to another, you need either an u-boot version that priorizes sd over eMMC or one of the described approaches for booting from sd.
  Reply
#12
OP
If I try to boot from my bootable SD card, I get a red LED, then a green LED, but a black screen that just stays that way.
Maybe because it is also manjaro?
  Reply
#13
Okay, some seriously weird goings-on now.

I've been trying all manner of things with everyone's comments in mind, and wasn't really getting anywhere. I haven't been able to get consistent results with any method.

Using a ridiculous combo of my desktop, phone, and a USB microphone with an SD card reader, I made a bootable Debian microSD and tried to boot from that but couldn't reliably bypass the eMMC (if I used the hardware switch to disable the eMMC, it usually just wouldn't boot at all).

On the occasions I was able to boot from the Debian SD card, which I wasn't able to do consistently, I couldn't get it to flash an image to the eMMC. It gave an out-of-space error which I couldn't make sense of, so I'm still working with Manjaro on the eMMC and Debian on the SD. I tried to get into maskrom mode because I was afraid I'd accidentally tried to flash Debian to the SPI but neither of the two methods of entering maskrom worked.

I kept trying and re-trying things since some folks had mentioned having to power cycle up to a dozen times to get their PBPs to boot properly. I tried ctrl+alt+bksp and ctrl+alt+fn+bksp (which is to say, ctrl+alt+del) when the Manjaro boot logo appeared, but to no avail.

HOWEVER

On my most recent reboot it froze on the Manjaro boot logo again and I hit ctrl+alt+fn+bksp, and for no discernible reason it went to a Plasma KDE splash screen and then my login screen! Big thanks to whichever one of you did a blood sacrifice ritual for me, which is my best guess as to what happened.

I logged in successfully about twenty minutes ago and things are still running normally. No fires or explosions have occurred and Satan has not shown up to demand repayment. I would still like to factory reset pretty much everything just to make sure I'm not sitting on a time bomb, and the stability of Debian sure sounds appealing, but I'm afraid to turn the thing off again in case this was just a fluke. And god knows I'm sick of troubleshooting mysterious problems by now. Thoughts, anyone?
  Reply
#14
Is it possible to ask friends if they have a micro SD USB adapter or buy one?
That way you can write another distro on the card from another computer and see if that does boot.
  Reply
#15
Out of space error sounds like you were trying to write to the wrong device (or possibly reading from a device that puts out more data than the size of the eMMC). From where I sit though I cannot advise what the correct device name/path would be.

FWIW, probably has nothing to do with your situation, I've had KDE (on NetBSD) stall upon loading, only to successfully finish an absurd amount of time later.

Whilst it's booted, this is probably the time to switch to a different U-boot.
  Reply
#16
Alright, so I won't say I'm 100% out of the woods for fear of jinxing myself, but I managed to flash mrfixit's Debian onto my eMMC and my PBP has booted into it as expected. I haven't rebooted it yet, so I don't know if it's fiendishly trying to lull me into a false sense of security, but considering the Manjaro installation is gone and it's booting without the SD card, the situation seems promising. The only problem is a high-pitched sound it started making the other day during the troubleshooting, which other forums tell me probably has to do with the power supply and is definitely annoying, but not indicative of a serious problem.

For posterity, I'll try to go over my "solution", but honestly I bet 90% of this was my fault somehow, and I don't even know how I finally managed to boot to my SD card successfully - it was a real mess of mashing the power button and the reset/recovery buttons in whatever order felt right in the moment. But, for the record, I tried the previous advice from this thread and then some, and once I finally got booted into the SD with Debian, I did the following:

1. Downloaded mrfixit's Debian for PBP from https://github.com/mrfixit2001/debian_desktop/releases. This is also what I used to flash the image onto the SD card.

2. Because I had to have the eMMC switched off internally in order to boot from the SD, and switched it back on only after fully booting from the SD, the eMMC was not being properly recognized. Following the instructions at https://wiki.pine64.org/index.php?title=...le_Storage, I ran (as root):
Code:
# echo fe330000.sdhci >/sys/bus/platform/drivers/sdhci-arasan/unbind
# echo fe330000.sdhci >/sys/bus/platform/drivers/sdhci-arasan/bind
I don't understand what this did, but afterwards, when using $lsblk or $dh to list available devices, the eMMC would be included and could therefore be flashed to. I made sure to note my eMMC's number with $lsblk before flashing - for me it was mmcblk1 but I gather this can vary with different kernels, so don't take it for granted. I also went back to the normal user account after this but that probably doesn't make a difference.

3. Entered the directory with the Debian image and followed the instructions from https://forum.pine64.org/showthread.php?tid=8229 - but replacing the .img's filename with the one I downloaded. I unzipped the image, and AFTER DOUBLE CHECKING THE DEVICE NUMBER (seriously that part is stupid crazy important), flashed it to eMMC:
Code:
$ unxz pinebookpro-debian-desktop-mrfixit-191226.img.xz
$ sudo dd if=pinebookpro-debian-desktop-mrfixit-191226.img of=/dev/mmcblk1 status=progress
$ sync
Not sure what $sync did but it was attested at https://old.reddit.com/r/PINE64official/...u_on_emmc/

4. After the flash finished up, I powered down, removed the SD card, and powered on again to a glorious Debian login screen. I logged in with default credentials, and rejoiced.

Anyone else who's having the problems I had...well, best of luck to you. Thanks to everyone for the help! I'm off to explore Debian.
  Reply
#17
That's good. Don't forget the mrfixit update, (this is kernel and uboot)
If you don't specify otherwise, dd writes in 512 byte chunks, for a number of reasons not the best for flash
  Reply
#18
(01-10-2021, 07:15 PM)archaicmeander Wrote: Hey folks, noob here. I've done as much as I can to solve this on my own because I don't want to be the user whose question is answered with "uh, there's already a comprehensive guide for that, search the forum next time", but I'm really at a loss now. I have the US layout Pinebook Pro running Manjaro with Plasma KDE pretty much exactly how it came to me. Since I'm new to Linux (currently posting from a Windows 10 desktop) and I don't have a good idea of what's causing my problem, I'm going to describe everything here as thoroughly as possible, so this post will be long.

The current problem: when I try to turn on my PBP the power LED lights up red, then turns green, and then, if I'm trying to boot normally from the eMMC, the boot logo comes up with its little progress wheel, but after about two revolutions it hangs there indefinitely. Once it freezes, everything but the power button is unresponsive. If I try to boot from my bootable SD card, I get a red LED, then a green LED, but a black screen that just stays that way.

If I boot from eMMC and I hit the keyboard shortcut before the boot logo freezes, I can switch to a virtual console, and tty2-6 work as expected - I can even switch back to tty1, where my GUI should be, but the screen stays black, sometimes with a cursor (which can move, somehow, but there's nothing to click) and sometimes without. Once or twice the frozen logo has appeared on tty1 with a movable cursor - which still can't interact with anything - but I can't figure out why it only does that sometimes, or even whether that's important.

I had my PBP for a few months as my first Linux machine, and everything was great. Then I went without using it for several weeks (just coincidentally, nothing was wrong with it), during which I mostly left it plugged in, but I had the thought that that might be bad for the battery, so I unplugged it for a while. This cycle recurred several times, so over that period, I probably left it in both states for too long, overcharging and then dying entirely. Yes, I am an idiot, thank you for asking. When I finally opened it up to use again, it froze at the boot logo like I described above.

I went through as many wiki articles, forum posts, and Reddit threads as I could stomach and found some things to try, none of which fixed the problem. Unfortunately this happened a couple weeks ago so I don't remember all the details, but they included:

-fixing my locale (which had been wrong due to my own error)
-installing updates (someone had a similar issue caused by the battery dying mid-update) including refreshing mirrors
-rolling back drivers (apparently there were issues with a recent Nvidia driver causing black screen)
-opening up the case to check eMMC switch position (it was fine) and ribbon cables (they were also fine)
-troubleshooting X11, because $xinit and $startx had returned errors, but all I could parse was something about font folders - I think I ended up reinstalling X
-updating Plasma KDE packages specifically (I had this written down but I don't recall which packages or why)

I finally decided to just do a clean install of Manjaro. This was tricky since my PBP is the only device I have with an SD card reader, but I backed up my user data (so, for the record, there's nothing on it now that I need to save, so all solutions are viable) and then made a bootable SD card via virtual console (which, for me, was an achievement).

Everything seemed fine after a successful clean Manjaro installation - it powered on normally, the GUI functioned as expected, I got my settings dialed back in without issue.

I tried to run a system update but got an error about files that already existed. Unfortunately I can't remember what program was causing the issue, but the recommendation I found was to force an update as superuser, which I did, and things seemed resolved. But I had the bright idea to restart after the update, so I did, but instead of coming back on normally, it froze at the boot logo again. I tried more internet searching and fiddled with some things, trying to remember exactly what I'd done before. However, I was by then righteously pissed, so I decided, fuck it, I'll just re-re-install, but now it won't even boot from the SD card, which I haven't touched since the first reinstall.

The virtual consoles still work, but I still haven't been able to boot either from the SD or normally into the GUI and I can't find any advice I haven't already tried to follow. I tried $xinit and $startx again, which yields the same errors as before, and I tried powering on with the eMMC switched off and then switching it back on when the LED comes on, which also did not resolve anything.

To summarize, the timeline was, to the best of my recollection:

-Normal use
-Probably plugged in too long followed by allowing battery to die several times
-Freeze on boot
-Attempt software troubleshooting
  -Locale
  -Updates
  -Driver check
  -Try to address X11 issues in particular after $xinit and $startx fail
-Attempt hardware troubleshooting
  -All switches and cables in place
-Reinstall OS, boots normally
-Run software updates
  -One error, resolved by installing via CLI as superuser
-Restart after updates out of habit
-Freeze on boot again
-Try $xinit and $startx, same errors as before
-Try to clean install again but won't boot from SD at all, just green LED and black screen
-Try booting with SD and hotswitching eMMC (this struck me as odd but I found it at https://forum.pine64.org/showthread.php?...6#pid62426)
-Despair, weep openly, rage at unjust god, walk the dog for emotional cooldown
-Post on pine64 forum

So, do I need to resign myself to a virtual console-only PBP experience? Am I just taking something for granted that I shouldn't? Did I do this to myself? Is there any good in this world at all? I need to pare down some of my hobbies anyway, so let me know if it's a lost cause and I'll delete my account and go back to doing resin castings. Anyway, I tend to be a quick learner and I like digging into new things, but my Linux experience - and CLI knowledge - is limited to my time with my PBP and Manjaro, so responses on the level of "Baby's First Linux" would be entirely warranted. Thanks, everyone.
Like you, my own experience with the PineBook Pro and Manjaro were major disappointments.  Finally after almost a year of near total frustration, one of the leaders in this forum confirmed what I had thought: there was (or had been) a major problem with one of the Manjaro distros and that a few Linux users had compiled and tested other versions of Linux that would work within the memory limits of the PineBook Pro.  I followed one of the links that were provided and downloaded one of the versions offered.  That file was burned to a new micro USB card, the card put into the PBP slot and the PBP powered up.  For the first time in many, many months it went to the log-in screen then to the initial desktop.  My only wonders (problems, complaints, concerns) now are how to get the BlueTooth (BT), the internal camera, the microphone(s), and the speakers to work and become recognized by the new OS.  Overall, I and some of my friends that are working to help me learn Linux and Python are impressed with the way the PBP now seems to work.
  Reply
#19
>and I tried powering on with the eMMC switched off and then switching it back on when the LED comes on,
>which also did not resolve anything.
If you did this with a SD card inserted, this strongly suggests that the SD card is bad,
unless you switched really quick (try leaving 5 seconds)
Use the mrfixit distro, connect to wifi, mrfixit_update.sh (for your SD)
Since you have vt's (virtual terminals) , it is booted (you have 5, F2-F6)
I had a large update fail, due to sleep, tiny, almost invisible letters in vt2,, setfont -d,, (double, still faint),
no wifi, sudo ifconfig, yep no wifi, nmcli didn't work but nmtui did,, then pacmac failed,
a lock file I couldn't find,,, start<tab,tab>,, none worked,, su, startxfce4 worked, finished update
rebooted OK
You know, "usb to sd card adapter" even in amazon are not that expensive,,<10-$20,,, usb2 ones are 1/2 that
--edit--
One other thing you can try is a hard reset,, hold pwr button 20+ seconds (for SD boot problem)
--more--
I should explain this,, some (>1,<5) people with manjaro have had SD problems
My guess is uboot internal generic dtb has phase set wrong
So, if SD is good (too bad you can't test with h2testw, bad cards are NOT uncommon)) and you get no boot with emmc off
then with emmc off, SD inserted, do long press, then start press, maybe it will boot
To your original problem, no x (since you have vt's it is booted) check,,, sudo systemctl status sddm ,, maybe stop , start, status
x is on vt1, not the usual vt7
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian/unstable SD card rescue image vajak 1 183 10-16-2021, 01:39 PM
Last Post: vajak
  Blank screen after Armbian 20.04 install to emmc? psychoacoustic 2 90 10-14-2021, 03:11 PM
Last Post: psychoacoustic
Question Can't boot any operating system other than Fedora after following the nullr0ute guide TDC_PBP 1 371 10-09-2021, 07:35 PM
Last Post: TangoZuluTango
  Is the same DD command appropriate for writing EMMC and SD cards wpeckham 4 292 09-23-2021, 09:19 PM
Last Post: KC9UDX
  Kernel panic on boot with danielt's Debian installer hjalfi 11 2,331 07-09-2021, 08:52 AM
Last Post: moonwalkers
  Manjaro wont recognize eMMC after booting with it disabled peasant 1 490 06-27-2021, 02:39 AM
Last Post: Arwen
  PostmarketOS - Why swap file not on at boot? stozi 3 834 06-24-2021, 12:27 AM
Last Post: craftyguy
  Official openSUSE: U-Boot, dtb and graphics Jojonintendo 1 676 06-12-2021, 08:38 AM
Last Post: Jojonintendo
  Boot problems jessef 11 1,426 05-16-2021, 11:13 AM
Last Post: djhnsn
  eMMC frequently not found by Linux kernel (especially on low battery) v-man 14 6,959 05-14-2021, 01:18 PM
Last Post: djhnsn

Forum Jump:


Users browsing this thread: 1 Guest(s)