PineTime runs only with 3.3V via pogopin
#1
Question 
I have tried to update my pinetime with pinetime-updater and a raspbery pi. The script ended fast, without succes.

Now the watch is not starting or loading anymore. It only starts with pin 3 and 4 connected with the 3.3V pin and ground pin of the pi. Then it works fine (screen, bluetooth and gadgetbridge).

Ideas?
#2
@jvw1954 I am by no means an expert with this device, I'll try to get some persons in here that are.

A few things to try:

* Try flashing a known good image before doing anything else - I can personally say that JF's latest release works well.

* Hold down the power button for a long time - many of OSes recognize this as a request for reset.

* A battery disconnect and reconnect (you might need need to de-solder the battery from the pad). It's a pain, but this will ensure the device is fully reset.

I've just checked the PineTime schematic [1] for possibilities of reasons why you wouldn't get power from the battery, but unfortunately it's not so clear. You should test the following if you have a voltmeter and post the results (with and without pogo pin power applied):

* TP21 (5V) to TP22 (GND)

* TP23 (~3.3v to ~4.2V) to TP24 (GND)

* TP25 (3.3V) to TP26 (GND)

That should tell us if you're seeing battery power and whether the regulator is working correctly. If you've got a busted regulator, I would expect to see TP25 to read 0V when measuring just the battery is connected. That would in theory explain why bypassing it would bring the CPU up.

I would suggest to the circuit designer to make some modifications:

1. A diode on pogo pin inputs to prevent somebody accidentally connecting 5V to a 3.3V line, or vice versa. We're talking a few cents to save tonnes of potential headaches.

2. Throw a diode in front of the 5V input, USB can really vary as high as 6V (and as low as 4V) if you're unlucky. Depending on U14ME6206, you could even throw the 5V USB input through the same regulator as the batter (using some diodes to block battery and 5V from one another). The regulator would then be powered from the highest voltage source, which should be USB at ~5V.

3. Use a standard connector instead of pogo pins, it's much better than some temperamental connection. I believe they do JST connectors at the right size and with a some slight layout changes there will be enough space in there (bring it out away from the side of the watch wall).

[1] https://files.pine64.org/doc/PineTime/Pi...191103.pdf
#3
Now that your device has started with the pins connected to the pi, does it still runs if you disconnect them?
Maybe pinetime-updater failed for whatever reason, and the device was stuck in programming mode. I guess that connecting the pins to the pi issued a reset, and you should be good to go.

If it stops when it's not connected to the pi, maybe the battery is empty and that it works because the pi is feeding power to the pinetime? Have you tried to charge your device?

If you have a stlinkv2, you can try to follow these instructions to flash your device using openocd.
Working on InfiniTime, the FOSS firmware for the PineTime: https://github.com/InfiniTimeOrg/InfiniTime

Mastodon : https://mastodon.codingfield.com/@JF
Twitter : https://twitter.com/codingfield
Matrix : @JF002atrix.org


Possibly Related Threads…
Thread Author Replies Views Last Post
Star screen protector for pinetime? sal 0 66 01-15-2022, 01:03 PM
Last Post: sal
  PIneTime reconnect script kmsgli 0 111 01-01-2022, 08:16 PM
Last Post: kmsgli
  PineTime re-connect to PInephone kmsgli 8 349 01-01-2022, 08:05 PM
Last Post: kmsgli
  PineTime CE conformity pt1 0 149 12-25-2021, 08:43 AM
Last Post: pt1
  PineTime Sleep Tracking any_mouse 7 631 12-18-2021, 07:37 AM
Last Post: eFqLLnGo
Music Metronome on PineTime pinemike 1 251 12-07-2021, 05:06 PM
Last Post: kqlnut
  PineTime + PinePhone (Mobian/Siglo) battlegarden 1 422 11-30-2021, 10:40 AM
Last Post: tvall
  [SOLVED] Gadgetbridge not pairing with pinetime zoof 2 1,048 11-30-2021, 07:45 AM
Last Post: Schitzoflink
  PineTime touchscreen wakeup issue norfolk_uk 1 519 11-15-2021, 08:01 AM
Last Post: Codenul
  PineTime - Navigation ajack2001my 7 427 10-10-2021, 05:18 AM
Last Post: wibble

Forum Jump:


Users browsing this thread: 1 Guest(s)