Novice question: Pinebook Pro does boot (does it?) but black screen
#11
(12-22-2020, 06:12 AM)Gert V. Wrote: Back here faster then I expected.



I took a microSD-card from a phone I forgot I had lying around, so that solved one problem. Next I downloaded the Debian Desktop Community Build Image [microSD to eMMC] by mrfixit2001, flashed it to the microSD-card with Etcher using a USB-to-SD-adapter as well as a SD-to-microSD-adapter.



With the card inserted I powered the PBP on and it booted up.  At first a very scrambled image of the Debian logo was visible for a little while, then the device seemed to power off (orange led) and the on again (green led) but now with a also very scrambled image, this time 14 x the Pine64 logo. The green led did blink sometimes, mostly not.



I left it for about an hour, but no change so far.



I used CTRL Alt F1 and did seem tot get into a terminal, at least that´s what I think it was, it could not be read as there were only lines of white dots instead of text.


Typing sudo shutdown with password rock didn´t do much, so in the end I pushed the on/off button to power the PBP off.



So far its been a ´1 step forward, 2 steps back´ kind of story, but at least steps are being made.



Anyway, as always any help will be much appreciated.

if your emmc has Manjaro or another mainline OS/uboot on it, that would be the cause of the graphics issue. that often occurs when a minaline uboot is used with a BSP OS. If you shutdown your PBP, open up and flip the emmc switch to OFF, and reboot from the SD, you shouldn't see the graphics glitches.
  Reply
#12
Thanks again! The emmc indeed still has Manjaro on it.
That looks like a simple enough task I will probably do tomorrow.
  Reply
#13
This morning I opened  the PBP and flipped the emmc switch to off (away from the hinge). Then put in the microSD with Debian, but that didn´t make a differerence, unfortunately. The graphics are still scrambled. I even removed the emmc completely to see if that did make a difference, but as probably could be expected it didn´t.
Booting from USB tot Arch still works, though.

In the mean time, just to be prepared, I ordered the USB-to-emmc-adapter, although it will take about two weeks before delivery.

Are there more suggestions to try to solve this? Is it for instance usefull to try to boot from SD with another OS flashed to it or will it give me the same result? I can always try, but if that is a dead-end street for certain I would rather not.
Or is this the opportunity to learn how to use Arch linux. Things that are not mutually exclusive, off course.
  Reply
#14
Try NetBSD on the SD card and see what you get. Get the 9.0/9.1 (not "current") image from armbsd.org.
  Reply
#15
Or a different distro (with mainline uboot) ,, armbian
https://www.armbian.com/pinebook-pro/
I would pick focal, just tested, it seems OK except no s3 sleep
Do disable/remove emmc so uboot on emmc does not interfere
  Reply
#16
(12-23-2020, 05:03 AM)KC9UDX Wrote: Try NetBSD on the SD card and see what you get.  Get the 9.0/9.1 (not "current") image from armbsd.org.
I did try to boot NetBSD from SD but alas no glory. No display on the screen, not even scrambled this time.

Downloading Armbian at the moment. I will proceed with that tomorrow.
In the mean time I took my first dive into the depths of ArchLinux by reading and watching instruction-videos and really enjoying it.
  Reply
#17
And success this time! Booting Armbian from SD is working. So the PBP is in working order at the moment. I am curious for the reasons behind why is does work this time where it failed before, it is beyond my comprehension at the moment, but at least I can put my PBP to good use.

The next step is to get the PBP to boot from the emmc. Knowing that Armbian works my plan is to flash Armbian to the emmc with the USB-to-emmc-adapter when that arrives. If that is less reasonable than I think it is, please let me know.

Thanks to anyone who chimed in to help me out here, much appriciated.
  Reply
#18
I wonder what's different. The others should have worked! But it's great that the PBP proves to work.
  Reply
#19
>why is does work this time where it failed before
mrfixit debian is not at all the same as focal, also the uboots differ
  Reply
#20
So today, finally after about a month my usb-to-emmc-adapter arrived. In the mean time I've been using the PBP on a regular basis with Armbian as the OS running from SD. Works really great for me, the occasional freeze hasn't been a big problem so far. With Armbian working like a charm I left Arch, booting from USB, for what it was, still curious though.
And now, with a new toy to play with, which OS can you recommend to flash on the emmc? I still regard myself as a novice in the world of linux and the PBP, so don't go all hardcore commandline on me, yet.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Cube Desktop on Pinebook Pro decisivedove 1 667 04-15-2021, 01:12 PM
Last Post: wpeckham
  PBP won't boot (no amber or green LED) ian-s-mcb 46 7,361 04-15-2021, 09:58 AM
Last Post: SnowyMountainWeb
  Selling my Pinebook Pro brent.thierens 0 149 04-11-2021, 11:13 AM
Last Post: brent.thierens
  Pinebook Pro (ISO) for sale - Europe (NL) Unkn0wn 2 350 04-09-2021, 09:00 AM
Last Post: Unkn0wn
  Video Editing Is Possible On The PineBook Pro! ImmyChan 8 364 04-01-2021, 09:27 PM
Last Post: dsimic
  PIneBook Pro - Boot from SD mcdomx 12 8,790 03-29-2021, 01:13 AM
Last Post: 5825bc9762
  PineBook Pro kisangoli78 1 332 03-25-2021, 03:29 AM
Last Post: kisangoli78
  Selling Pinebook Pro 128GB version (w/ NVMe adaptor) due to lack of use VoT 3 687 03-19-2021, 03:11 AM
Last Post: jj282
  Will It Be Okay To Order The PineBook Pro US Version For Use In The UK? ImmyChan 7 618 03-15-2021, 10:24 PM
Last Post: dsimic
  Network connection question??? davehetfield 1 197 03-11-2021, 07:31 AM
Last Post: tkudog

Forum Jump:


Users browsing this thread: 1 Guest(s)