Pinephone 64 PostMarketOS edition Battery problem
#1
Hello everybody, first of all, nice to start in this amazing mobile project and say hello to the community.


I were trying to use PinePhone64 since I received it (more than 10 days), at the begging the battery where charging to 100%, but the mobile where losing the charge "fast". I supposed that it was about the PostMarketOS edition or updates; but right now the battery doest charge more than 30% and when I connect and disconnect the phone from charge, the OS shows me different percents of battery charge status. Anybody known what can happen and how to solve it?


Thanks in advance, thanks a million for your time.
#2
(11-08-2020, 08:10 PM)Alejandro.SU Wrote: Hello everybody, first of all, nice to start in this amazing mobile project and say hello to the community.


I were trying to use PinePhone64 since I received it (more than 10 days), at the begging the battery where charging to 100%, but the mobile where losing the charge "fast". I supposed that it was about the PostMarketOS edition or updates; but right now the battery doest charge more than 30% and when I connect and disconnect the phone from charge, the OS shows me different percents of battery charge status. Anybody known what can happen and how to solve it?


Thanks in advance, thanks a million for your time.
You may have a defective battery. The Samsung J7 battery, as listed in the wiki, is easy and cheap to obtain in most places locally.
#3
(11-09-2020, 12:25 AM)rocket2nfinity Wrote: You may have a defective battery.

+1. If you can get your hands on a J7 battery, see if the same symptoms manifest.

Regardless, try contacting Support for an RMA.
#4
(11-09-2020, 12:25 AM)rocket2nfinity Wrote: You may have a defective battery. The Samsung J7 battery, as listed in the wiki, is easy and cheap to obtain in most places locally.
It is impossible to decide whether it is the battery or the charging circuitry or the software.
#5
(11-09-2020, 02:36 AM)LinAdmin2 Wrote:
(11-09-2020, 12:25 AM)rocket2nfinity Wrote: You may have a defective battery. The Samsung J7 battery, as listed in the wiki, is easy and cheap to obtain in most places locally.
It is impossible to decide whether it is the battery or the charging circuitry or the software.
He can test the hardware by installing the postmarket factory test build on an SD card and booting it. But the fact he is able to run an OS, and the battery varies wildly, plus no charge over 30 when he was getting 100 indicates it's most likely the battery, not the hardware or OS.
#6
(11-09-2020, 04:32 AM)rocket2nfinity Wrote:
(11-09-2020, 02:36 AM)LinAdmin2 Wrote:
(11-09-2020, 12:25 AM)rocket2nfinity Wrote: You may have a defective battery. The Samsung J7 battery, as listed in the wiki, is easy and cheap to obtain in most places locally.
It is impossible to decide whether it is the battery or the charging circuitry or the software.
He can test the hardware by installing the postmarket factory test build on an SD card and booting it. But the fact he is able to run an OS, and the battery varies wildly, plus no charge over 30 when he was getting 100 indicates it's most likely the battery, not the hardware or OS.
Please explain to an engineer:
How should the factory test image allow to decide whether it is a defective battery or power management circuitry???
#7
I could observe that when I extract the charger from the mobile, after a considerably time charging (when is connected in the computer or by using usb or normal mobile charger on a plug) that the OS changes automatically the battery's percent up or down, so I think that the problem can be the battery or the connector... I am not sure. Thanks to everybody for your help.
#8
It's worth checking the connectors on the ribbon between the main board and the USB board are properly seated. One of mine wasn't, although it was working properly, and I think there was at least one report of someone finding that reseating one of the connectors sorted a battery problem. I'd trust 'cat /sys/class/power_supply/axp*/uevent' over the desktop indicator.
#9
Thanks for you answer! I will try to do it. Regards!
#10
I received few days ago a new battery and the problem persist, with this battery is even worst (j7 battery), I tryed the commands that @wibble posted and shoes everything ok.. I expended time and money on support this proyect.. my intention was code some software to manage the phone agend... it means that I dont have a waranty to can change the phone that works returning the defective one? In the moment that I bought this post market version I readed that waranty doesnt voer dead pixels on screen but its is not my case, I will be very grateful if I can change the phone.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinephone Keyboard Utilities on postmarketOS elof 1 479 03-19-2022, 02:24 PM
Last Post: ---
  no screen rotation on pinephone pro with postmarketOS + phosh elode 1 367 02-16-2022, 06:59 PM
Last Post: 33YN2
  Best Place To Learn PostmarketOS mw4jet 6 3,636 01-30-2022, 11:57 PM
Last Post: arcanemachine
  pinephone boots to green screen after running out of space costava 1 296 01-30-2022, 06:29 AM
Last Post: costava
  [PostmarketOS with Plasma Mobile] Angelfish adblock + wpa supplicant time out Egolep 0 1,191 03-23-2021, 10:25 AM
Last Post: Egolep
  Where is the original PM OS image for Pinephone? mw4jet 1 1,441 03-14-2021, 07:37 AM
Last Post: ludix
Wink Extremely fast pmOS build for the pinephone lucasanss 0 1,817 02-03-2021, 04:05 PM
Last Post: lucasanss
  Found Potential Fix For Pinephone/Verizon syrinx 2 2,925 01-26-2021, 02:34 PM
Last Post: syrinx
  No camera app on PinePhone Postmarket Edition / Phosh Noah222 3 2,814 12-02-2020, 03:38 PM
Last Post: jmorris
  Initial thoughts, PinePhone PostMarket edition. plainenough 28 19,603 11-18-2020, 03:43 AM
Last Post: eKeith

Forum Jump:


Users browsing this thread: 1 Guest(s)