PinePhone won't boot
#1
Hello everyone

I got my "Manjaro Community Edition with Convergence Package" a couple of days ago and tried to set the phone up yesterday.

The first time I tried to boot it, I just removed the battery seal, connected it to USB power and gave it a go with no SIM and no SD inserted. A red LED in the upper left corner of the phone started to light up, but the screen did not do anything. After maybe 15 seconds the red LED went off. I retried several times to power on the phone, but it would just not boot.
I assumed that maybe there is no OS on the internal memory, so I went ahead, downloaded beta1-20201104 of Manjaro Phosh and burned it to the SD with dd.

I then inserted the SD into the PinePhone and tried to start it up several times. All I ever got was the red LED. After maybe 10 attempts to boot the PinePhone, the screen was finally lid and I saw the Manjaro logo alongside a loading animation for about a minute before the device has switched itself off again. I was unable to make it boot ever since. All I ever see is the red LED.

I tried to find my way around the wiki, but couldn't find a useful starting point for my case.

Should I try to have a look at the logs on the SD?

Many thanks for your help in advance.

PD: I am new to Linux. Smile
#2
Perhaps try using Balena Etcher to flash your sd card ?

Good Luck
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#3
Somewhat the same issue here, it gets to the unlock screen, but when I try to unlock it I get a blinking cursor at the top left of the screen. I tried to run the latest Manjaro on SD, but it does the same. Switched to PostmarketOS on SD and that seems to work. But it's kind of strange that the stock OS doesn't even boot....
#4
I received Manjaro Community Edition Pinephone (Convergence Package) just today. The phone won't boot for me either. Very similar symptoms as for @amadeusp81. It tried to boot on the first power-on, but after a minute or so the phone was off. Now all I get is the red led. And in some cases when I try to power it on the screen would turn on (become grayish) for just a second or two. Then it's off again.

I would appreciate any advice now. Should I try to boot from SD? Please, anyone who had the same symptoms and have a fix, let us know.
#5
Here is the solution which worked for me:

1. Install https://www.balena.io/etcher/
2. Flash https://github.com/dreemurrs-embedded/Ju...one.img.xz to an SD card. Mine was 64GB.
3. Remove the battery. Insert the SD card. Keep the battery removed.
4. Plug the PinePhone through the (official) USB cord to the computer. The image boots in 2 seconds and "Jumpdrive is running" is seen.
5. Download https://osdn.net/projects/manjaro-arm/st...104.img.xz
6. Flush the Phosh image to the eMMC USB Device 31.3GB. The other one (microSD USB Device) was seen too, be carefull. Flushing speed was 14MB/s.
7. Insert the battery and power on the device. Now it works as expected.

Also, have a loot at the similar thread here: https://forum.pine64.org/showthread.php?tid=11993
#6
Hi cong-v,

Thank you for this procedure. I followed it an successfully updated the OS on the eMMC to the latest version of Manjaro. The issue remains the same after this. I get to the lockscreen, but it repeatingly enters a state with a cursor flashing in the top left corner. I've follow the same procedure but then with postmarketOS and this works as expected. It looks like there maybe some phones that are incompatible with the current version of Manjaro?
#7
Hello everyone,

https://gitlab.manjaro.org/manjaro-arm/i.../issues/52

^ It looks to me that the Manjaro with Phosh distribution has not been stabilized yet to be somehow usable at all. Please correct me, if I'm wrong.
#8
Today I installed UBPorts and that works really fine. Just flashed the latest Manjaro Beta 2 and it still has the same issue.

UBPorts works really nice actually (except that I'm not able to make calls though... texting works fine). But it really shows that the hardware is quite nice.
#9
Hmmm.... now Jumpdrive is not working anymore. Anybody any thoughts on that?
#10
(11-10-2020, 10:39 AM)martijnv Wrote: Hmmm.... now Jumpdrive is not working anymore. Anybody any thoughts on that?

How exactly is it failing? Blank screen on your PinePhone when you boot it? Can't connect your PinePhone to your PC?

Try reflashing the SD card you have installed JumpDrive on with a fresh install?
If it isn't broken, take it apart and fix it.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Poll 2: What is your favorite distro/interface for the PinePhone? amosbatto 2 709 Today, 08:56 AM
Last Post: AwHereWeGoAgain
  my broken pinephone, possible sale zetabeta 1 101 09-23-2021, 06:54 AM
Last Post: kqlnut
  Austrialians now have a better reason to use PinePhone KNERD 19 747 09-22-2021, 01:05 PM
Last Post: tophneal
  Add kill switches to the PinePhone realrichardsharpe@gmail.com 10 1,009 09-18-2021, 12:59 PM
Last Post: biketool
  Manjaro Edition Pinephone for sale mstevens 5 166 09-17-2021, 10:50 AM
Last Post: mstevens
  Are you using the Pinephone as your daily driver? jro 91 14,219 09-17-2021, 07:26 AM
Last Post: user641
  PinePhone is not a daily driver FOSSagent0 17 1,485 09-17-2021, 01:11 AM
Last Post: bogen85
  Pinephone app development drgr33n 23 2,915 09-16-2021, 02:16 PM
Last Post: ragreenburg
  New PinePhone user dachalife 4 280 09-15-2021, 12:01 PM
Last Post: dachalife
  UPDATED (June 2021): 17-distro multi-boot image for Pinephone (incl. 3GiB variant) megous 161 113,156 09-11-2021, 10:57 PM
Last Post: ryo

Forum Jump:


Users browsing this thread: 1 Guest(s)