unable to boot the phone with PM OS after battery has completely discharged
I post the above linked thread in the Hardware section as I first thought that my emmc is broken. But as I'm able to boot the factory image from May 17 and other distributions, I believe it could be a PM OS issue.

This is the thread from the hardware section and below my last thread with my "workaround":

This is the observed issue:

I have PM Os installed on the emmc, the sd card as an additional drive. It worked very well with the stable branch. Three days later it was dead. When pressing the power button it stucks with the 'led test' and makes a short 'click' (which seems to be specific to pm os) and restarts over and over again. that it quits at the "led test" reminds on the error bieps from bios, when something essential did go wrong. So: no boot screen, nothing.

What I already tried:
- completely charge the battery
- flash the sd card with jumpdrive:
The phone booted into the jumpdrive modus, but: lsblk did not show the emmc nor the sd card (which is strange). I can unplug the usb cable while it runs jumpdrive, so the battery works well.


I still struggle with this issue when my battery is empty. But I found a work around without flashing the emmc.

1) I was not able to boot the factory test images No. 49 or 55, only the image from 17.05.20 worked.

2) After I succesfully booted jumpdrive (see post above), it failed again and I couln't see the emmc or the sd card.

3) I then flashed my sd card with mobian which worked. I charged the battery while running mobian. Afterwards it succesfully booted pm os from the emmc again.

So, whenever my phones' battery is completely empty, I'm having the described issues. I then plug in my "spare" Mobian SD, charge the battery for a couple of minutes and restart the phone without the mobian image.

Could it be connected to the kernel? I find it interesting that the old factory image booted, but the newer ones did not. I will duplicate this post in the pm os section.

We know the problem, and it has been fixed recently (but no pre-built image with it has been created yet so you have to do that yourself or update your system and u-boot on an existing system). The problem was in Crust and only happened on 1.0 and 1.1 phones, CE editions were unaffected.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Fresh install pmos+phosh does not boot user641 1 472 10-08-2023, 04:04 AM
Last Post: user641
  Battery issues user641 3 1,174 07-17-2023, 10:43 AM
Last Post: alaraajavamma
  Boots To Shell After Dead Battery (PMOS) britelite 0 698 02-17-2023, 02:41 PM
Last Post: britelite
  Pinephone 64 PostMarketOS edition Battery Issues, Not Hardware Issue X0X0X0X0X0 1 1,342 02-11-2023, 08:19 AM
Last Post: acid andy
  Unable to set default apps Barugon 7 3,265 12-04-2022, 12:28 PM
Last Post: alaraajavamma
  Disable mobile data auto-enable on boot 64_Tesseract 3 2,253 08-11-2022, 02:48 AM
Last Post: 64_Tesseract
  phone won't boot from emmc with sdcard inserted ssilvi 3 3,595 06-06-2021, 02:47 AM
Last Post: ssilvi
  Cannot boot from SDCard cube 2 3,303 01-31-2021, 11:47 AM
Last Post: cube
  Pinephone 64 PostMarketOS edition Battery problem Alejandro.SU 9 8,496 12-22-2020, 04:33 PM
Last Post: Alejandro.SU
  No USB connection - phone not seen! --- 24 25,150 12-14-2020, 08:24 PM
Last Post: ---

Forum Jump:

Users browsing this thread: 1 Guest(s)