PBP not booting screen blank after SD card boot
(08-12-2020, 02:58 AM)Jakobp Wrote:
(07-28-2020, 01:23 PM)belfastraven Wrote:
(07-28-2020, 08:58 AM)Jakobp Wrote: Hey there. I hope I can get a bit of inspiration for further problem shooting for my seemingly dead pbp. LEDs turn red then green(solid) as expected but screen doesn’t turn on at all. All worked perfectly until I wanted to test Manjaro i3 from SD card. I have Manjaro KDE  on eMmc installed already. Ok booted Manjaro i3 from SD card all worked fine. I updated this distro installed a few things from repository and built Vivaldi browser from AUR using Parmac. Then when rebooting I got the issue above. I thought there was something wrong with SD card and ejected and re booted only to see same issue with my installed system - nothing boots. I tried to charge in full then let it go completely flat in case of some endless sleep cycle ( this took about 20 hours). Any suggestions why the screen is just completely black? I know very little about things like gpu etc. so don’t know if any faulty hardware is preventing something to start screen? I’m really at a loss - I haven’t touched the hardware inside I have only flashed a card. SD card 32 gb and worked fine when I had Debian and Manjaro KDE on card. Any ideas??
 If you are seeing the green light,  the machine may very well have booted,  but has some kind of display issue. As a first step have you tried re-writing the sd card with the Manjaro i3 that originally did boot and trying to boot from that?    IF that works you know it's a software problem...  

Also,  have you tried using the f2 key to turn up the brightness?  ..in case somehting in the update turned it down......

 I'm assuming you don't have a serial cable.  it's very helpful to have serial output at times like this.   You can watch the booting sequence and usually can see where the system is hanging or failing.  Often,  if its something like a software display problem, you can fix it....

Thanks for this - I tried both Manjaro i3 and Debian but same result. Will keep trying for a bit and then resort to console connection

I had a very similar issue.
  • Manjaro KDE installed on eMMC
  • Manjaro sway installed on SD card
  • Both worked fine for a while
  • Updated SD card installation
  • Rebooted and neither install would display anything
After much investigation I determined that the SD card installation had been mounting the boot partition from the eMMC. So when the SD card installation updated the kernel, the boot  partition the eMMC was messed up and the SD card boot partition was not actually updated. Both installs were failing to load any modules because neither could find the expected versions. This all happened because the filesystem labels were the same on the eMMC and the SD card (both had a BOOT_MNJRO and a ROOT_MNJRO).

I fixed it by booting from an SD card and then using chroot to fix the eMMC install (uninstall then reinstall the kernel). Then did the same for the SD card and changed the SD card filesystem labels, extlinux.conf and fstab.

I don't know why you haven't been able to boot Debian from SD card, but the default uboot used in Manjaro does not work with many of the older images. I would try different images (ubuntu focal fossa worked for me) or modify a freshly flashed Manjaro SD card so the filesystem labels are not default and the extlinux and fstab files point to the new labels.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Malfunction: horizontal white streak on the screen regivanx 0 160 06-23-2022, 12:59 AM
Last Post: regivanx
  Troubleshooting of pinebook Pro red light and black screen wangyukunshan 0 471 03-23-2022, 12:10 AM
Last Post: wangyukunshan
  I broke my screen :( espenbo 3 1,346 01-03-2022, 03:46 PM
Last Post: altacus
  Broken Screen vxzero 0 774 08-26-2021, 09:02 PM
Last Post: vxzero
  Write to an A1-rated Micro SD card failed dsimic 12 6,621 07-28-2021, 11:38 AM
Last Post: dsimic
Question Disassembling PineBook Pro Docking Deck (due to disappeared microSD card) gritibaenz 4 2,519 04-02-2021, 06:45 PM
Last Post: tkudog
  Minimum daughter boards/peripherals required for main board to boot cmicallef 5 2,342 03-12-2021, 10:10 PM
Last Post: cmicallef
  Screen offset nobodyinperson 7 6,251 01-26-2021, 04:55 PM
Last Post: KC9UDX
  Pinebook Pro screen failure? BBreeziN 1 1,950 01-08-2021, 03:21 PM
Last Post: member
  microSD card stuck charlesnorris 7 5,316 11-19-2020, 05:11 AM
Last Post: KC9UDX

Forum Jump:

Users browsing this thread: 1 Guest(s)