Not booting after latest update
#1
Hi, 

I issued an

Code:
apt update && apt upgrade

a few hours ago and since then it's not booting anymore. I just see the LED shining in white. The screen remains black.

I saw that it was installing the 5.7 kernel, so I guess it messed up u-boot. 

I had it installed to EMMC, so I hope I will be able to restore everything by booting from SD. Can I just reinstall u-boot? What are the commands to do so?
I'm also still on the old version where /boot was on the root partition. Maybe it is also because of that. I guess, when I'm already in the process of repairing I could also repartition.
#2
(06-25-2020, 03:13 PM)Boern Wrote: Hi, 

I issued an

Code:
apt update && apt upgrade

a few hours ago and since then it's not booting anymore. I just see the LED shining in white. The screen remains black.

I saw that it was installing the 5.7 kernel, so I guess it messed up u-boot. 

I had it installed to EMMC, so I hope I will be able to restore everything by booting from SD. Can I just reinstall u-boot? What are the commands to do so?
I'm also still on the old version where /boot was on the root partition. Maybe it is also because of that. I guess, when I'm already in the process of repairing I could also repartition.

ditto! Also on old single partition version. Have backed up my user directory and figure I will start from a new 2 partition download.

1 thing I have noticed - on my trial Mobian/jwm version the screen is flashing like a disco light after the 5.7 upgrade, virtually unusable. Hope the Mobian/phosh version is OK.

OK, installed 20200625 nightly and it seemed OK. Did the upgrade to 5.7 and after reboot have dark screen - can't find a way to get it legible.

Suspect for now avoid 5.7 kernel?
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (6.1 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/SXMO on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC
#3
Yep, should have checked here first Tongue
Have been updating daily for the last few weeks without too many issues.
After todays update noticed the same problem. Going to go back to testing the update on the sd card and doing the update to the emmc if the update goes well.
#4
OK - running 5.7 kernel OK.
Installed 20200625 nightly
Settings, Power, Disable automatic brightness and Disable Dim screen when inactive
Then upgrade to 5.7
:-)
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (6.1 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/SXMO on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC
#5
(06-25-2020, 03:13 PM)Boern Wrote: I had it installed to EMMC, so I hope I will be able to restore everything by booting from SD. Can I just reinstall u-boot? What are the commands to do so?

To reinstall u-boot to the eMMC, the command is:
Code:
sudo u-boot-install-sunxi64 /dev/mmcblk2

Please let me know if it solves your problem.

(06-25-2020, 04:51 PM)dukla2000 Wrote: Settings, Power, Disable automatic brightness and Disable Dim screen when inactive

Interesting, that means the brightness scale (changed in pine64's 5.7 kernel) does not work that well for all devices... I'll have a look
#6
I tried running
Code:
sudo u-boot-install-sunxi64 /dev/mmcblk2
from a chroot, that just made everything worse and it wouldn't boot at all. But running it from within a fresh mobian-pinephone-20200615.img.gz installation worked.

But now I have the problems with automatic brightness. But I do have ssh-access. Can I somehow do the necessary settings from the command line?
Edit: The screen lit up for about 2 seconds every time I put in a charging cable and so I was able to make the necessary changes.
#7
To disable auto-brightness:
Code:
gsettings set org.gnome.settings-daemon.plugins.power ambient-enabled false

To set a correct brightness value (as root)
Code:
echo 400 > /sys/class/backlight/backlight/brightness

I'm working on a new kernel version which should (hopefully) get the brightness scale right...

(06-26-2020, 08:33 AM)Boern Wrote: from a chroot, that just made everything worse and it wouldn't boot at all. But running it from within a fresh mobian-pinephone-20200615.img.gz installation worked.
yes, I wouldn't have tried that from a chroot, only from a running system (whether it runs from SD or eMMC doesn't matter)


Possibly Related Threads…
Thread Author Replies Views Last Post
Exclamation The latest update of eg25-manager seems to cause frequent disconnections anonymous 12 1,181 11-28-2022, 03:30 PM
Last Post: anonymous
  No volume control after latest updates Zebulon Walton 16 1,506 11-14-2022, 06:34 PM
Last Post: Zebulon Walton
  [Fixed] Phosh crashes frequently after latest updates arno_nuehm 20 3,446 10-14-2022, 05:38 PM
Last Post: Krafter
  Latest Reliable Mobian Build Confirmation Thread Katsujinken 5 1,034 09-27-2022, 08:41 AM
Last Post: Katsujinken
  Wifi issue since last update and held back updates goku499 11 1,632 09-21-2022, 02:39 PM
Last Post: Katsujinken
  [SOLVED] Lost Internet connectivity after recent update drh 3 756 09-11-2022, 09:24 PM
Last Post: Katsujinken
  Rescue Your Mobian post Update Aug22 faster fix to working guide biketool 9 1,790 09-05-2022, 12:10 AM
Last Post: biketool
  Loving latest Mobian Update drh 11 1,915 08-22-2022, 12:19 PM
Last Post: biketool
  apt-get update "The following signatures were invalid..." grump_fiddle_reinstall 13 4,127 08-22-2022, 10:28 AM
Last Post: Eugo
  Exclamation point in cellular icon after update Zebulon Walton 8 2,376 06-22-2022, 05:57 PM
Last Post: albafrati

Forum Jump:


Users browsing this thread: 1 Guest(s)