WiFi quality degrades too much
#1
Since I've got my Pinebook Pro this problem keeps haunting me. WiFi gets really bad on negligible distances and obstacles.

Here are some speedtests I've just did:

Code:
Test 1 (far):
Download: 1.94 Mbit/s
Upload: 3.24 Mbit/s

Test 2 (middle):
Download: 6.01 Mbit/s
Upload: 16.17 Mbit/s

Test 3 (closest):
Download: 42.00 Mbit/s
Upload: 48.58 Mbit/s


The first test is done at 5 meters distance with 2 solid concrete walls and my back that block the WiFi signal.
The second test is done at ~2 meters distance with the same walls blocking it.
The third test is done with the laptop on top of the router.

This is based on the 2.4GHz band. Now one would say the walls are the problem, but if I do the test with my smartphone at the very same place as I did the 1st test, my speeds would reach ~30Mbit/s. So apparently the walls shouldn't cause that much of a problem. Just to make sure, I took another laptop (Acer TravelMate B117), placed it on the very same place as my Pinebook Pro in the 1st test, ran a speedtest and the speeds were the same as my phone - ~30Mbit/s.

The conclusion is that my Pinebook Pro is the problem and not the router or the location. I just can't figure out whats wrong. I've changed distributions, changed the firmware drivers, tried everything in the Wiki about problematic wifi, nothing fixes the issue.
Is it antenna problem? Firmware problem? Something I'm missing?

Just for the sake of completeness, I'm running on Manjaro ARM 20.04 right now. This is the firmware I did my speedtests with:
Code:
# pacman -Ss ap6256 
community/ap6256-firmware 2020.01-1 [installed]
    Firmware files for the ap6256 wifi/bt module

Edit: This should be quite useful as well:

Code:
Test 1 (far):
wlan0     IEEE 802.11  ESSID:"Anonymous" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 0F:0F:0F:0F:0F:0F  
          Bit Rate=6.5 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=32/70  Signal level=-78 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:60  Invalid misc:0   Missed beacon:0

Test 2 (middle):
wlan0     IEEE 802.11  ESSID:"Anonymous" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 0F:0F:0F:0F:0F:0F   
          Bit Rate=52 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=40/70  Signal level=-70 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:154  Invalid misc:0   Missed beacon:0
         
Test 3 (closest):
wlan0     IEEE 802.11  ESSID:"Anonymous" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 0F:0F:0F:0F:0F:0F  
          Bit Rate=43.3 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-11 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:154  Invalid misc:0   Missed beacon:0
#2
Thanks for this post and for describing this problem way better than I could. I am having what looks to be the same issue with a brand new Pinebook pro (3 days old). I do not have a solution. The only thing I can add is that after the first boot my 5GHz connection was strong (about 20 feet from the modem). After updating the system (490 updates) I need to be very near the modem to get a 2.4GHZ connection. 5GHz is no longer available. I would appreciate any advice/help resolving this issue.
#3
The 5GHz WiFi issue is widely known. Its because of the new firmware. You can downgrade it to 2020.01 and it should be fixed. There are numerous topics about it, one of which is this: https://forum.pine64.org/showthread.php?tid=10262

Unfortunately my WiFi problem is not related with this 5GHz problem. Regardless of the band its still as bad as it could be. To be more precise, with 5GHz is even worse than 2.4GHz.
#4
5G works at the lower channels with the current firmware fine.
#5
Lower channels only? That is probably regulatory domain related.

What's 'iw get reg' output for supported frequencies?
#6
Even though you've suggested that for the 5GHz problem, I've thought that I might be having a regulatory domain issue as well for my 2.4 GHz. So I've set it to my own country and voila, its much better. Still not as good as my other devices, but at least 15mbit/s is way better than ~2mbit/s.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Wifi Troubles IDEFK 17 1,235 05-24-2021, 05:03 AM
Last Post: walterbe
  Pinebook pro poor performance on 5Ghz WiFi Iolaum 10 4,144 05-23-2021, 04:35 AM
Last Post: Ralim
  No WIFI network discovery in any manjaro installation (but works on fedora) pineitup 1 503 02-05-2021, 09:10 AM
Last Post: BlueJayLinux
  Wifi very slow on PBP Manjaro? WeaseleyRon 2 572 01-21-2021, 10:21 AM
Last Post: moonwalkers
  is it possible to get wifi monitor mode on the pbp? BananaPekan 0 382 01-17-2021, 01:50 PM
Last Post: BananaPekan
  Wifi stopped working after updates pineitup 10 2,996 11-07-2020, 02:59 AM
Last Post: wdt
  Wifi very slow on PBP Manjaro motezart 3 1,202 10-13-2020, 07:30 PM
Last Post: wdt
  Trouble connecting to my home wifi bastafari 10 2,850 09-27-2020, 06:37 PM
Last Post: bastafari
  Pinebook Pro won't connect to wifi Samuel Venable 4 1,570 09-22-2020, 12:26 AM
Last Post: bcnaz
  No battery or wifi after poweroff Goin2mars 3 1,473 09-19-2020, 09:58 AM
Last Post: xmixahlx

Forum Jump:


Users browsing this thread: 1 Guest(s)