Axolotl on PinePhone / Mobian
#11
(12-07-2020, 03:03 AM)marcih Wrote:
(12-06-2020, 01:49 PM)arno_nuehm Wrote:
(11-18-2020, 02:38 PM)marcih Wrote:
(11-17-2020, 11:51 AM)arno_nuehm Wrote:
(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?

Is it really a "freeze" or is it just taking a bit more time? In my case (around 04.11.2020 - same date for the Mobian nightly image) it took quite a while for "npm install" to finish.
I'm not quite sure, I left it alone for half an hour or so with no progress, I assumed it was frozen since the little spinning line on the left wasn't moving either. I'll give it a try again tomorrow, leave it be for longer.

Have you tried it? I will have a go with a fresh installation of the fde-image in a few days and give you an update...
I have, with no luck. Interestingly, building the Flatpak went through fine so I don't know what the issue is. Either way, the app is currently not functional anyway, Electron crashes and qmlscene is not bundled in the Flatpak and doesn't seem to recognise the apt-installed copy.

With electron there is a known issues on arm64/aarch64 devices, I think. And Axolotl with qmlscene isn't working for me, too, I'm using it with the server flag and Firefox-esr as frontend. It's a work-around, but it works quite fine.
In a few days, I will try a fresh installation of Mobian/Axolotl and look into the qmlscene issues as well. Let's hope for the best.
  Reply
#12
(12-07-2020, 04:20 AM)arno_nuehm Wrote:
(12-07-2020, 03:03 AM)marcih Wrote: I have, with no luck. Interestingly, building the Flatpak went through fine so I don't know what the issue is. Either way, the app is currently not functional anyway, Electron crashes and qmlscene is not bundled in the Flatpak and doesn't seem to recognise the apt-installed copy.

With electron there is a known issues on arm64/aarch64 devices, I think. And Axolotl with qmlscene isn't working for me, too, I'm using it with the server flag and Firefox-esr as frontend. It's a work-around, but it works quite fine.
In a few days, I will try a fresh installation of Mobian/Axolotl and look into the qmlscene issues as well. Let's hope for the best.

Oh oops, I forgot to add the link to the GitHub issue regarding the Electron crash in my last post. It seems that there has been some activity in the aforementioned report as well, a new PR for adding a "-e qml" option which should work with Flatpak. I tried using firefox-esr as well, I could get as far as entering the verification code sent to my phone but FF crashed at that point so I gave up and I'm now waiting for either Electron or QML to work on Mobian. As soon as the PR gets merged, I'll rebuild and see what happens when I try to run the Flatpak. Wink
  Reply
#13
(12-07-2020, 05:34 AM)marcih Wrote:
(12-07-2020, 04:20 AM)arno_nuehm Wrote:
(12-07-2020, 03:03 AM)marcih Wrote: I have, with no luck. Interestingly, building the Flatpak went through fine so I don't know what the issue is. Either way, the app is currently not functional anyway, Electron crashes and qmlscene is not bundled in the Flatpak and doesn't seem to recognise the apt-installed copy.

With electron there is a known issues on arm64/aarch64 devices, I think. And Axolotl with qmlscene isn't working for me, too, I'm using it with the server flag and Firefox-esr as frontend. It's a work-around, but it works quite fine.
In a few days, I will try a fresh installation of Mobian/Axolotl and look into the qmlscene issues as well. Let's hope for the best.

Oh oops, I forgot to add the link to the GitHub issue regarding the Electron crash in my last post. It seems that there has been some activity in the aforementioned report as well, a new PR for adding a "-e qml" option which should work with Flatpak. I tried using firefox-esr as well, I could get as far as entering the verification code sent to my phone but FF crashed at that point so I gave up and I'm now waiting for either Electron or QML to work on Mobian. As soon as the PR gets merged, I'll rebuild and see what happens when I try to run the Flatpak. Wink

Thanks for the update!
  Reply
#14
(12-07-2020, 05:54 AM)arno_nuehm Wrote:
(12-07-2020, 05:34 AM)marcih Wrote:
(12-07-2020, 04:20 AM)arno_nuehm Wrote:
(12-07-2020, 03:03 AM)marcih Wrote: I have, with no luck. Interestingly, building the Flatpak went through fine so I don't know what the issue is. Either way, the app is currently not functional anyway, Electron crashes and qmlscene is not bundled in the Flatpak and doesn't seem to recognise the apt-installed copy.

With electron there is a known issues on arm64/aarch64 devices, I think. And Axolotl with qmlscene isn't working for me, too, I'm using it with the server flag and Firefox-esr as frontend. It's a work-around, but it works quite fine.
In a few days, I will try a fresh installation of Mobian/Axolotl and look into the qmlscene issues as well. Let's hope for the best.

Oh oops, I forgot to add the link to the GitHub issue regarding the Electron crash in my last post. It seems that there has been some activity in the aforementioned report as well, a new PR for adding a "-e qml" option which should work with Flatpak. I tried using firefox-esr as well, I could get as far as entering the verification code sent to my phone but FF crashed at that point so I gave up and I'm now waiting for either Electron or QML to work on Mobian. As soon as the PR gets merged, I'll rebuild and see what happens when I try to run the Flatpak. Wink

Thanks for the update!




Axolotl 0.9.0.1 is now running with qmlscene on the latest fde-image (20201215). I updated the Mobian Wiki - Manual install.
The registration process is still tricky. If it fails, use the following lines to get a clean start
Code:
rm ~/.cache/QtProject/QtQmlViewer/qmlcache/* && rm -r ~/.local/share/textsecure.nanuc && rm -r ~/.config/textsecure.nanuc
And a restart of Mobian is also helpful. Also, Axolotl has some known registration issues.
Let me know, if your registration worked. I didn't want to de-link my desktop app and tried several online burner numbers. The code was sent but in the end, I used my backup folders.

Update: From time to time, Axolotl is not starting correctly. Clearing the above mentioned qmlcache folder helps.
  Reply
#15
Hi everyone.  I got my new Pinephone last Friday and have been trying to get Axolotl installed for a few days now.  I tried following arno's post from 12/16, but it's not quite working.

I installed mobian-installer-pinephone-phosh-alpha3.img and then followed the steps on the mobian wiki.

qt / qml interface

sudo apt install flatpak flatpak-builder

flatpak install org.kde.Platform//5.15
flatpak install org.kde.Sdk//5.15
flatpak install org.freedesktop.Sdk.Extension.golang//20.08
flatpak install org.freedesktop.Sdk.Extension.node12//20.08
flatpak install io.qt.qtwebengine.BaseApp//5.15

wget https://raw.githubusercontent.com/nanu-c...xolotl.yml
sudo flatpak-builder --install build org.nanuc.Axolotl.yml


Everything seemed to work properly.

However, when I tap the Axolotl icon, nothing happens. I just get the background screen.

Trying to run the cache clearing script

rm ~/.cache/QtProject/QtQmlViewer/qmlcache/* && rm -r ~/.local/share/textsecure.nanuc && rm -r ~/.config/textsecure.nanuc

I get the message that so such directory exists at home/mobian/.cache/QtProject/QtQmlViewer/qmlcache

I'm sure there's something obvious I'm missing.

Any help is appreciated, thanks.
  Reply
#16
(12-21-2020, 02:00 PM)acm006 Wrote: Hi everyone.  I got my new Pinephone last Friday and have been trying to get Axolotl installed for a few days now.  I tried following arno's post from 12/16, but it's not quite working.

I installed mobian-installer-pinephone-phosh-alpha3.img and then followed the steps on the mobian wiki.

qt / qml interface

sudo apt install flatpak flatpak-builder

flatpak install org.kde.Platform//5.15
flatpak install org.kde.Sdk//5.15
flatpak install org.freedesktop.Sdk.Extension.golang//20.08
flatpak install org.freedesktop.Sdk.Extension.node12//20.08
flatpak install io.qt.qtwebengine.BaseApp//5.15

wget https://raw.githubusercontent.com/nanu-c...xolotl.yml
sudo flatpak-builder --install build org.nanuc.Axolotl.yml


Everything seemed to work properly.

However, when I tap the Axolotl icon, nothing happens. I just get the background screen.

Trying to run the cache clearing script

rm ~/.cache/QtProject/QtQmlViewer/qmlcache/* && rm -r ~/.local/share/textsecure.nanuc && rm -r ~/.config/textsecure.nanuc

I get the message that so such directory exists at home/mobian/.cache/QtProject/QtQmlViewer/qmlcache

I'm sure there's something obvious I'm missing.

Any help is appreciated, thanks.

I had the same issue, there is an issue open on Axolotl Github that I think is related (see. https://github.com/nanu-c/axolotl/issues/289) regarding flatpak file paths. I found a quick fix by making my own desktop icon as shown below. Axolot sometime fails to start the first time but otherwise has been working fairly well for me.

sudo nano /usr/share/applications/axolotl.desktop

[Desktop Entry]

Type=Application
Name=Axolotl2
GenericName=Signal Chat Client
Exec=flatpak run org.nanuc.Axolotl -e=qt
Icon=/home/mobian/build/files/share/icons/hicolor/128x128/apps/org.nanuc.Axolotl.png
Terminal=false
Categories=Network;Chat;InstantMessaging;Qt;
StartupWMClass=axolotl
  Reply
#17
(12-21-2020, 08:38 PM)Ersatz Wrote:
(12-21-2020, 02:00 PM)acm006 Wrote: Hi everyone.  I got my new Pinephone last Friday and have been trying to get Axolotl installed for a few days now.  I tried following arno's post from 12/16, but it's not quite working.

I installed mobian-installer-pinephone-phosh-alpha3.img and then followed the steps on the mobian wiki.

qt / qml interface

sudo apt install flatpak flatpak-builder

flatpak install org.kde.Platform//5.15
flatpak install org.kde.Sdk//5.15
flatpak install org.freedesktop.Sdk.Extension.golang//20.08
flatpak install org.freedesktop.Sdk.Extension.node12//20.08
flatpak install io.qt.qtwebengine.BaseApp//5.15

wget https://raw.githubusercontent.com/nanu-c...xolotl.yml
sudo flatpak-builder --install build org.nanuc.Axolotl.yml


Everything seemed to work properly.

However, when I tap the Axolotl icon, nothing happens. I just get the background screen.

Trying to run the cache clearing script

rm ~/.cache/QtProject/QtQmlViewer/qmlcache/* && rm -r ~/.local/share/textsecure.nanuc && rm -r ~/.config/textsecure.nanuc

I get the message that so such directory exists at home/mobian/.cache/QtProject/QtQmlViewer/qmlcache

I'm sure there's something obvious I'm missing.

Any help is appreciated, thanks.

I had the same issue, there is an issue open on Axolotl Github that I think is related (see. https://github.com/nanu-c/axolotl/issues/289) regarding flatpak file paths. I found a quick fix by making my own desktop icon as shown below. Axolot sometime fails to start the first time but otherwise has been working fairly well for me.

sudo nano /usr/share/applications/axolotl.desktop

[Desktop Entry]

Type=Application
Name=Axolotl2
GenericName=Signal Chat Client
Exec=flatpak run org.nanuc.Axolotl -e=qt
Icon=/home/mobian/build/files/share/icons/hicolor/128x128/apps/org.nanuc.Axolotl.png
Terminal=false
Categories=Network;Chat;InstantMessaging;Qt;
StartupWMClass=axolotl

Hello there,
I described the situation for manual installation not using flatpak-builder so the paths are a bit different. But I have the same issues with -e qt as described by acm006. Sometimes the app starts and sometimes it fails.
It may be related to the main .qml file which produces some error messages. Have a look here: Link.
For me, the deamonized option is still the best way to use Axolotl - regardless of the building process.

And my future idea is to have the deamon running and start the UI with qmlscene separately if needed. Good on resources...
  Reply
#18
(12-16-2020, 07:06 PM)arno_nuehm Wrote: ...
Axolotl 0.9.0.1 is now running with qmlscene on the latest fde-image (20201215). I updated the Mobian Wiki - Manual install.
...

 I have just followed the steps under "Manual install" with no major problems (BTW npm install ran about 25 minutes) until
Code:
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$ npm run build

> axolotl-web@0.1.0 build
> vue-cli-service build


⠹  Building for production...

ERROR  Failed to compile with 3 errors                                                                                                                    22:09:47

error  in ./src/assets/dark.scss

Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm64) with Node.js 12.x
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.14.1
    at module.exports (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at getDefaultSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getDefaultSassImplementation.js:24:10)
    at getSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getSassImplementation.js:19:72)
    at Object.loader (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/index.js:40:61)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/webpack/lib/NormalModule.js:316:20
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:367:11
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:233:18
    at runSyncOrAsync (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
    at Array.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:205:4)
    at Storage.finished (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:55:16)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:91:9
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/graceful-fs/graceful-fs.js:115:16
    at FSReqCallback.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:63:3)

@ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/thread-loader/dist/cjs.js!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/App.vue?vue&type=script&lang=js& 33:2-30
@ ./src/App.vue?vue&type=script&lang=js&
@ ./src/App.vue
@ ./src/main.js
@ multi ./src/main.js

error  in ./src/assets/light.scss

Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm64) with Node.js 12.x
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.14.1
    at module.exports (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at getDefaultSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getDefaultSassImplementation.js:24:10)
    at getSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getSassImplementation.js:19:72)
    at Object.loader (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/index.js:40:61)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/webpack/lib/NormalModule.js:316:20
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:367:11
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:233:18
    at runSyncOrAsync (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
    at Array.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:205:4)
    at Storage.finished (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:55:16)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:91:9
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/graceful-fs/graceful-fs.js:115:16
    at FSReqCallback.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:63:3)

@ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/thread-loader/dist/cjs.js!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/App.vue?vue&type=script&lang=js& 35:2-31
@ ./src/App.vue?vue&type=script&lang=js&
@ ./src/App.vue
@ ./src/main.js
@ multi ./src/main.js

error  in ./src/components/Message.vue?vue&type=style&index=0&id=b1b7f866&lang=scss&scoped=true&

Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm64) with Node.js 12.x
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.14.1
    at module.exports (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at getDefaultSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getDefaultSassImplementation.js:24:10)
    at getSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getSassImplementation.js:19:72)
    at Object.loader (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/index.js:40:61)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/webpack/lib/NormalModule.js:316:20
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:367:11
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:233:18
    at runSyncOrAsync (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:221:10)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:236:3
    at context.callback (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:111:13)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/cache-loader/dist/index.js:147:7
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/graceful-fs/graceful-fs.js:57:14
    at FSReqCallback.oncomplete (fs.js:156:23)

@ ./src/components/Message.vue?vue&type=style&index=0&id=b1b7f866&lang=scss&scoped=true& 1:0-532 1:548-551 1:553-1082 1:553-1082
@ ./src/components/Message.vue
@ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/thread-loader/dist/cjs.js!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/pages/MessageList.vue?vue&type=script&lang=js&
@ ./src/pages/MessageList.vue?vue&type=script&lang=js&
@ ./src/pages/MessageList.vue
@ ./src/router/router.js
@ ./src/main.js
@ multi ./src/main.js

ERROR  Build failed with errors.
npm ERR! code 1
npm ERR! path /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web
npm ERR! command failed
npm ERR! command sh -c vue-cli-service build

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/mobian/.npm/_logs/2021-01-19T22_09_48_338Z-debug.log
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$

I absolutely haven't a clue what I am doing - I am merely following the recipe, so any suggestions welcome!

TIA

Previous step seems to have been fine:
Code:
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$ npm install

added 1753 packages, and audited 1820 packages in 25m

7 packages are looking for funding
  run `npm fund` for details

1 low severity vulnerability

To address all issues, run:
  npm audit fix

Run `npm audit` for details.
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.13 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone BraveHeart now v1.2b 3/32Gb daily driver, dual boot via p-boot with Mobian/f2fs/Phosh on eMMC, Arch/ext4/Phosh on SDcard
  • PinePhone v1.2a 2G/16Gb that needs USB board replaced
  Reply
#19
Having a similar issue when opening axolotl:
ERRO[0001] '/home/mobian/snap/axolotl/210/vendor/electron-linux-arm64/electron' exited with code: 1
  Reply
#20
(01-19-2021, 04:16 PM)dukla2000 Wrote:
(12-16-2020, 07:06 PM)arno_nuehm Wrote: ...
Axolotl 0.9.0.1 is now running with qmlscene on the latest fde-image (20201215). I updated the Mobian Wiki - Manual install.
...

 I have just followed the steps under "Manual install" with no major problems (BTW npm install ran about 25 minutes) until
Code:
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$ npm run build

> axolotl-web@0.1.0 build
> vue-cli-service build


⠹  Building for production...

ERROR  Failed to compile with 3 errors                                                                                                                    22:09:47

error  in ./src/assets/dark.scss

Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm64) with Node.js 12.x
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.14.1
    at module.exports (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at getDefaultSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getDefaultSassImplementation.js:24:10)
    at getSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getSassImplementation.js:19:72)
    at Object.loader (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/index.js:40:61)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/webpack/lib/NormalModule.js:316:20
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:367:11
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:233:18
    at runSyncOrAsync (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
    at Array.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:205:4)
    at Storage.finished (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:55:16)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:91:9
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/graceful-fs/graceful-fs.js:115:16
    at FSReqCallback.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:63:3)

@ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/thread-loader/dist/cjs.js!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/App.vue?vue&type=script&lang=js& 33:2-30
@ ./src/App.vue?vue&type=script&lang=js&
@ ./src/App.vue
@ ./src/main.js
@ multi ./src/main.js

error  in ./src/assets/light.scss

Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm64) with Node.js 12.x
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.14.1
    at module.exports (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at getDefaultSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getDefaultSassImplementation.js:24:10)
    at getSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getSassImplementation.js:19:72)
    at Object.loader (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/index.js:40:61)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/webpack/lib/NormalModule.js:316:20
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:367:11
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:233:18
    at runSyncOrAsync (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
    at Array.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:205:4)
    at Storage.finished (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:55:16)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:91:9
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/graceful-fs/graceful-fs.js:115:16
    at FSReqCallback.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:63:3)

@ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/thread-loader/dist/cjs.js!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/App.vue?vue&type=script&lang=js& 35:2-31
@ ./src/App.vue?vue&type=script&lang=js&
@ ./src/App.vue
@ ./src/main.js
@ multi ./src/main.js

error  in ./src/components/Message.vue?vue&type=style&index=0&id=b1b7f866&lang=scss&scoped=true&

Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm64) with Node.js 12.x
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.14.1
    at module.exports (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/binding.js:13:13)
    at Object.<anonymous> (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/node-sass/lib/index.js:14:35)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at getDefaultSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getDefaultSassImplementation.js:24:10)
    at getSassImplementation (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/getSassImplementation.js:19:72)
    at Object.loader (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/sass-loader/dist/index.js:40:61)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/webpack/lib/NormalModule.js:316:20
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:367:11
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:233:18
    at runSyncOrAsync (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
    at iterateNormalLoaders (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:221:10)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:236:3
    at context.callback (/home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/loader-runner/lib/LoaderRunner.js:111:13)
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/cache-loader/dist/index.js:147:7
    at /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web/node_modules/graceful-fs/graceful-fs.js:57:14
    at FSReqCallback.oncomplete (fs.js:156:23)

@ ./src/components/Message.vue?vue&type=style&index=0&id=b1b7f866&lang=scss&scoped=true& 1:0-532 1:548-551 1:553-1082 1:553-1082
@ ./src/components/Message.vue
@ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/thread-loader/dist/cjs.js!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/pages/MessageList.vue?vue&type=script&lang=js&
@ ./src/pages/MessageList.vue?vue&type=script&lang=js&
@ ./src/pages/MessageList.vue
@ ./src/router/router.js
@ ./src/main.js
@ multi ./src/main.js

ERROR  Build failed with errors.
npm ERR! code 1
npm ERR! path /home/mobian/go/src/github.com/nanu-c/axolotl/axolotl-web
npm ERR! command failed
npm ERR! command sh -c vue-cli-service build

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/mobian/.npm/_logs/2021-01-19T22_09_48_338Z-debug.log
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$

I absolutely haven't a clue what I am doing - I am merely following the recipe, so any suggestions welcome!

TIA

Previous step seems to have been fine:
Code:
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$ npm install

added 1753 packages, and audited 1820 packages in 25m

7 packages are looking for funding
  run `npm fund` for details

1 low severity vulnerability

To address all issues, run:
  npm audit fix

Run `npm audit` for details.
mobian@duklapp:~/go/src/github.com/nanu-c/axolotl/axolotl-web$


Hello there,

I tested the manual install of Axolotl 0.9.4 with a fresh Mobian (FDE-Installer 20201215) and all the latest updates. And I got the same error message at
Code:
npm run build

I will post an issue on github tomorrow; hopefully 0.9.5 fixes that. I'm still running 0.9.0.1 on my daily driver...

Cheers
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pure Maps GPS on Pinephone Mobian godzillest 0 2 23 minutes ago
Last Post: godzillest
  Mobian repository status henrythemouse 2 172 Yesterday, 09:32 AM
Last Post: biketool
  What do you use for voice chat on Mobian? ragreenburg 4 133 Yesterday, 08:36 AM
Last Post: ragreenburg
  Axolotl on Pinephone CarmeloLabadie 1 38 Yesterday, 12:56 AM
Last Post: kqlnut
  Armbian on the PinePhone Meow 0 100 07-21-2021, 10:42 PM
Last Post: Meow
  Wipe function on mobian? Wahtone 4 275 07-21-2021, 09:55 AM
Last Post: e-minguez
  Best/easiest way to install minimal Debian on PinePhone? mcgee 6 379 07-18-2021, 09:35 AM
Last Post: swiley
  Dark theme (on Mobian)? TRS-80 6 290 07-14-2021, 01:35 PM
Last Post: biketool
  (Gnome) Maps won't start on Mobian? TRS-80 3 220 07-11-2021, 12:09 PM
Last Post: TRS-80
  Mobian Constant Vibration tumblingdog 4 789 07-10-2021, 02:40 AM
Last Post: aed

Forum Jump:


Users browsing this thread: 2 Guest(s)