PINE64
Axolotl on PinePhone / Mobian - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: PinePhone (https://forum.pine64.org/forumdisplay.php?fid=120)
+--- Forum: PinePhone Software (https://forum.pine64.org/forumdisplay.php?fid=121)
+---- Forum: Debian on PinePhone (https://forum.pine64.org/forumdisplay.php?fid=139)
+---- Thread: Axolotl on PinePhone / Mobian (/showthread.php?tid=12047)

Pages: 1 2 3 4 5 6 7 8 9 10 11


Axolotl on PinePhone / Mobian - arno_nuehm - 11-06-2020

Hello there,

The arm64 deb package for Axolotl 1.0.1 is successfully built.

https://github.com/nuehm-arno/axolotl-mobian-package

Please be aware that you can only use on primary device/registration in the Signal server world - Axolotl works as such primary device/registration.

Please feel free to test it and post some feedback, if you like, and also check out the Mobian Wiki for the Axolotl news regarding the Pinephone:

https://wiki.mobian-project.org/doku.php?id=axolotl


RE: Axolotl on PinePhone / Mobian - dukla2000 - 11-06-2020

Welcome.

Great stuff, thanks for working it all out and documenting it.


RE: Axolotl on PinePhone / Mobian - jed - 11-11-2020

@arno_nuehm Thanks for the guide. Unfortunately for me, Phosh hard crashes when trying to enter the registration PIN.

The keyboard keeps re-opening, then a prompt to "log out" appears, forcing a hard reset.


RE: Axolotl on PinePhone / Mobian - marcih - 11-16-2020

Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?


RE: Axolotl on PinePhone / Mobian - ragreenburg - 11-16-2020

(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?
I would guess no other than the developer considering this issue on their GitHub.


RE: Axolotl on PinePhone / Mobian - marcih - 11-16-2020

(11-16-2020, 09:42 AM)ragreenburg Wrote:
(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?
I would guess no other than the developer considering this issue on their GitHub.
Hmm, I have seen that issue but it seems to me they're discussing something completely different, there seems to be a different issue with running it but it sounds like they've gotten it to build successfully.


RE: Axolotl on PinePhone / Mobian - arno_nuehm - 11-17-2020

(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?

Is it really a "freeze" or is it just taking a bit more time? In my case (around 04.11.2020 - same date for the Mobian nightly image) it took quite a while for "npm install" to finish.

(11-11-2020, 04:25 PM)jed Wrote: @arno_nuehm Thanks for the guide. Unfortunately for me, Phosh hard crashes when trying to enter the registration PIN.

The keyboard keeps re-opening, then a prompt to "log out" appears, forcing a hard reset.

Which UI are you using? With phosh 0.6.0-1, Midori is up again and maybe the registration is working in this setup.

And to be transparent: I only wrote the "Alternative Setup" part and commented/corrected "Manual install".


RE: Axolotl on PinePhone / Mobian - marcih - 11-18-2020

(11-17-2020, 11:51 AM)arno_nuehm Wrote:
(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?

Is it really a "freeze" or is it just taking a bit more time? In my case (around 04.11.2020 - same date for the Mobian nightly image) it took quite a while for "npm install" to finish.
I'm not quite sure, I left it alone for half an hour or so with no progress, I assumed it was frozen since the little spinning line on the left wasn't moving either. I'll give it a try again tomorrow, leave it be for longer.


RE: Axolotl on PinePhone / Mobian - arno_nuehm - 12-06-2020

(11-18-2020, 02:38 PM)marcih Wrote:
(11-17-2020, 11:51 AM)arno_nuehm Wrote:
(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?

Is it really a "freeze" or is it just taking a bit more time? In my case (around 04.11.2020 - same date for the Mobian nightly image) it took quite a while for "npm install" to finish.
I'm not quite sure, I left it alone for half an hour or so with no progress, I assumed it was frozen since the little spinning line on the left wasn't moving either. I'll give it a try again tomorrow, leave it be for longer.

Have you tried it? I will have a go with a fresh installation of the fde-image in a few days and give you an update...


RE: Axolotl on PinePhone / Mobian - marcih - 12-07-2020

(12-06-2020, 01:49 PM)arno_nuehm Wrote:
(11-18-2020, 02:38 PM)marcih Wrote:
(11-17-2020, 11:51 AM)arno_nuehm Wrote:
(11-16-2020, 07:05 AM)marcih Wrote: Lucky you, I can't even get it to build, it always freezes at "npm install" when it's installing(?) node's rxjs. Has anybody gotten it to build successfully recently?

Is it really a "freeze" or is it just taking a bit more time? In my case (around 04.11.2020 - same date for the Mobian nightly image) it took quite a while for "npm install" to finish.
I'm not quite sure, I left it alone for half an hour or so with no progress, I assumed it was frozen since the little spinning line on the left wasn't moving either. I'll give it a try again tomorrow, leave it be for longer.

Have you tried it? I will have a go with a fresh installation of the fde-image in a few days and give you an update...
I have, with no luck. Interestingly, building the Flatpak went through fine so I don't know what the issue is. Either way, the app is currently not functional anyway, Electron crashes and qmlscene is not bundled in the Flatpak and doesn't seem to recognise the apt-installed copy.