Power consumption and suspend to ram
#31
It took a few minutes to "puzzle out" what has happened here
When you did install of bsp uboot, it does 2 things, put uboot files in /boot for you to dd,
AND change extlinux,conf,, wrongly, the root= statement is now wrong (on emmc), not on SD
boot flow, with this mixed up boot, uboot (emmc) -> extlinux.conf (SD) ->rootfs (emmc)
so... edit extlinux.conf (emmc) to have correct root=
sudo blkid will show all
And, BTW, 5.9 cannot do suspend 3, s3, s2mem, suspend to mem
(what version? uname -r or ls /lib/modules/)
If you want this, have to downgrade to 5.8, if it is in /var/cache/pacman/pkgs/ is a lot easier (pacman -U something)
Be sure that the boot is sorted first, of course
  Reply
#32
(11-30-2020, 12:47 PM)wdt Wrote: It took a few minutes to "puzzle out" what has happened here
When you did install of bsp uboot, it does 2 things, put uboot files in /boot for you to dd,
AND change extlinux,conf,, wrongly, the root=  statement is now wrong (on emmc), not on SD
boot flow, with this mixed up boot, uboot (emmc) -> extlinux.conf (SD) ->rootfs (emmc)
so... edit extlinux.conf (emmc) to have correct root=
sudo blkid  will show all
And, BTW, 5.9 cannot do suspend 3, s3, s2mem, suspend to mem
(what version? uname -r or ls /lib/modules/)
If you want this, have to downgrade to 5.8, if it is in /var/cache/pacman/pkgs/ is a lot easier (pacman -U something)
Be sure that the boot is sorted first, of course

Thank you very much for looking into this.
You are right, the extlinux.conf had a wrong entry under root=, so I modified it and the emmc now boots, but the screen is still blank.

I will boot from a clean SD and rewrite the default uboot on the emmc. So I will stick to it, as I do not know how to downgrade to 5.8. I wanted the S3 to work, because as of now leaving the PBP to sleep consumes the battery fast.
Is there any easy way to enable the S3?

Cheers!
  Reply
#33
(11-30-2020, 01:29 PM)3xC0MM Wrote:
(11-30-2020, 12:47 PM)wdt Wrote: It took a few minutes to "puzzle out" what has happened here
When you did install of bsp uboot, it does 2 things, put uboot files in /boot for you to dd,
AND change extlinux,conf,, wrongly, the root=  statement is now wrong (on emmc), not on SD
boot flow, with this mixed up boot, uboot (emmc) -> extlinux.conf (SD) ->rootfs (emmc)
so... edit extlinux.conf (emmc) to have correct root=
sudo blkid  will show all
And, BTW, 5.9 cannot do suspend 3, s3, s2mem, suspend to mem
(what version? uname -r or ls /lib/modules/)
If you want this, have to downgrade to 5.8, if it is in /var/cache/pacman/pkgs/ is a lot easier (pacman -U something)
Be sure that the boot is sorted first, of course

Thank you very much for looking into this.
You are right, the extlinux.conf had a wrong entry under root=, so I modified it and the emmc now boots, but the screen is still blank.

I will boot from a clean SD and rewrite the default uboot on the emmc. So I will stick to it, as I do not know how to downgrade to 5.8. I wanted the S3 to work, because as of now leaving the PBP to sleep consumes the battery fast.
Is there any easy way to enable the S3?

Cheers!

For whatever reson u-boot.itb was not present in the /boot. I copied it there from the SD card and now I am able to boot from the emmc.
Thank you very much!

Now I just need to see how can I resolve the S3 activation. Smile
  Reply
#34
ls -l /var/cache/pacman/pkgs/linux-* ,,, is there linux-pinbookpro-5.8.14...,,, then pacman -U that package
otherwise, install downgrade, may (likely) have to enable arch repo,, AUR is what it is called
5.7.19 also works (for mem sleep)
But reading your post again, I am a bit confused,, bsp uboot has 3 files,
idbloader.img,,uboot.img,,trust.img. When you see u-boot.itb, that is mainline, has trust within it
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Replacement Power Cord recommendation? nathanielwheeler 3 405 01-23-2021, 06:43 PM
Last Post: KC9UDX
  power light blinking during charge when pbpro is off Idaho 0 418 01-04-2021, 10:53 AM
Last Post: Idaho
  Taming the power switch? ab1jx 4 1,122 11-30-2020, 10:57 PM
Last Post: rimaille
Exclamation Seemingly lost power permanently now /cry jimsurvak 2 775 11-16-2020, 06:22 PM
Last Post: jimsurvak
Photo Faulty power circuit hackerfantastic 1 845 08-24-2020, 01:48 PM
Last Post: Arwen
  We need more power, Scotty! mtnygard 4 1,750 07-23-2020, 11:21 AM
Last Post: mamboman777
  PBP running shipping Manjaro won't wake from suspend fornio 2 1,450 07-21-2020, 07:04 AM
Last Post: vancheese
  Suspend with NVME not working - Default Debian appdev46 5 2,969 07-14-2020, 01:53 PM
Last Post: Jeremiah Cornelius
  My PBP does not power on at all prokofiev 9 2,573 07-12-2020, 03:27 AM
Last Post: prokofiev
Exclamation [SOLVED] PBP will no longer power on s3rvant 10 3,642 07-04-2020, 01:57 PM
Last Post: prokofiev

Forum Jump:


Users browsing this thread: 1 Guest(s)