Partitioning encrypted CCC Carbon Copy Cloner AND setting up Time Machine on HDD
I'm new to owning a SBC (Rock64) and new to OMV.
Installed ayufan's stretch-openmediavault-rock64-0.9.14-1159-armhf and am able to get around on it ok.

I have a previously partitioned USB 3TB External HD. It has a ~500GB encrypted CCC partition, a ~500GB partition for Time Machine, and the remaining 2GB I would like to keep as storage for Photos and Music, etc.

The filesystems are HFS plus. The encrypted partition can't be seen by OMV file systems.

I ran these:
apt-get install hfsplus hfsutils hfsprogs
mkdir /media/hfs
mount -t hfsplus /dev/sdXY /media/hfs

I am able to create Shared SMB folders and access my photos. Spent a few hours on the TM partition with no luck though. Problems when adding a shared folder:

Failed to set file group to 'users' for '/srv/dev-disk-by-label-TMRock64/'
Error #0:
OMV\Exception: Failed to set file group to 'users' for '/srv/dev-disk-by-label-TMRock64/': in /usr/share/openmediavault/engined/rpc/
Stack trace:
#0 [internal function]: OMVRpcServiceShareMgmt->set(Array, Array)
#1 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
#2 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('set', Array, Array)
#3 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('ShareMgmt', 'set', Array, Array, 1)
#4 {main}

Although it will let me apply that, as if there was no error...

I can add the newly shared folder to Apple Filing and set user permission, but then I get this error when I try to setup the new TM on my mac
The operation couldn’t be completed. (OSStatus error 2.)

OR I will get this

You do not have the necessary read, write and append privileges on the selected network backup disk.

Is the problem the HFSplus? I tried deleting the partition to format it on OMV but then it disappeared on OMV, I could only recreate it on the mac. I've also tried reinstalling OMV.

I can reconfigure the disk with different partitions if needed, I just would like to know what those should be before going through the process.

Any Ideas? Thanks

This person says avoid HFS+
permissions problem with share on HFS+ drive

Possibly Related Threads…
Thread Author Replies Views Last Post
  Looking for guidance on setting up with external RTC Ditchmagnet 0 298 05-13-2022, 05:22 PM
Last Post: Ditchmagnet
  Setting a MAC on Rock64 U-Boot kiriakos 2 2,331 03-23-2021, 04:51 AM
Last Post: kiriakos
Sad Rock64 crash randomly during usb 3 copy with RAID1 drive phalae 24 25,378 09-14-2020, 10:48 AM
Last Post: BrownLuther007
  Problem with time in rock64 gedas07 2 3,575 11-12-2018, 12:07 PM
Last Post: gedas07
  virtual machine, arm host kwarren 1 2,384 08-06-2018, 05:26 PM
Last Post: hiccupstix
  Real-time webcam shaders yoann.b87 4 3,527 06-18-2018, 09:55 AM
Last Post: yoann.b87
  Any reason why ntp time is 6 minutes slow (Solved) Rocklobster 1 1,829 05-29-2018, 05:27 AM
Last Post: Rocklobster
  monitor setting & keyboard issues gpine1 2 2,388 05-27-2018, 03:51 PM
Last Post: Luke
Question Completely new to this - Can I use ROCK64 as basic Linux desktop machine @ 3840x1600? King_V 4 4,986 04-20-2018, 08:48 AM
Last Post: King_V
  I'm installing winxp by qemu virtual machine. fbms 2 3,067 09-03-2017, 07:08 PM
Last Post: fbms

Forum Jump:

Users browsing this thread: 1 Guest(s)