Fix for Armbian not booting on PBP from eMMC
I just finally found a solution for this and wanted to share at a high-level. 

In short: there's something not right about the DTB file from Armbian.  I replaced the Armbian file "/boot/dtb/rockchip/rk3399-pinebook-pro.dtb" with the file "/usr/lib/linux-image-5.<x>.<x>/rockchip/rk3399-pinebook-pro.dtb" from Kali and it boots like a champ after that.

After getting it to boot my 2.4ghz wifi worked but 5ghz did not.  Download the 3 files here to your /usr/lib/firmware/brcm folder:
that worked well thanks. something is wrong with latest armbian dtb for pinebookpro

also the 5GHz did not work out of the box but worked with your fix, quality


I've had a lot of issues with booting both the Pinebook Pro and Rockpro64 from eMMC, but *finally* discovered that the problems began when I upgraded to the 5.15 kernel. Downgrading, and pinning, to the 5.10 kernel fixes the problems booting from eMMC and *also* fixes ALL the problems I had with the Pine64 docking station not working! Incidentally, the HDMI on the dock does NOT work if using USB-C PD to power the Pinebook Pro: It only works if I use the 5V barrel connector to power the Pinebook Pro and power the dock from the Pinebook. The VGA display does work when using USB-C PD, though. I changed kernels using "armbian-config" and 'froze' the Armbian 'firmware' settings, but this failed to pin the packages and I broke it again as soon as I did an upgrade so I pinned the packages manually:

cat /etc/apt/preferences
Package: linux-dtb-current-rockchip64
Pin: version 21.08.2
Pin-Priority: 1001

Package: linux-headers-current-rockchip64
Pin: version 21.08.2
Pin-Priority: 1001

Package: linux-image-current-rockchip64
Pin: version 21.08.2
Pin-Priority: 1001

AFAIK, "armbian-config" should do this automatically, but doesn't...

This is the kernel I'm running now:

inux pinebook-pro 5.10.63-rockchip64 #21.08.2 SMP PREEMPT Wed Sep 8 10:57:23 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

Might be worth comparing the dtb's?


Even if you fix boot, Armbians apt updater is broken big time at the moment. Dev in forums is basically telling ppl to f off.
Quote:Dev in forums is basically telling ppl to f off

It is your stupid shopping decision and not devs in forums.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 0 95 01-19-2023, 01:47 PM
Last Post: Cs137
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 2 288 12-31-2022, 12:18 PM
Last Post: pine4546464
  Armbian is [edit: no longer] dropping support for Pinebook Pro TRS-80 4 2,573 12-23-2022, 12:01 AM
Last Post: TRS-80
  My installation guide starting from messed up eMMC Besouro 0 254 12-19-2022, 01:01 PM
Last Post: Besouro
  Armbian VPU decoding support coming soon LivingLinux 0 298 11-13-2022, 02:32 PM
Last Post: LivingLinux
  newer ""emmc-installer" images (manjaro xfce) magistral 1 429 10-10-2022, 06:22 AM
Last Post: maxjrh
  6/22 run of PBPs - is reimaging eMMC with new OS possible still? elitegamercody 29 3,715 10-04-2022, 07:55 PM
Last Post: wdt
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 376 09-30-2022, 10:09 AM
Last Post: crazyquark
  Booting Arch from USB lorebett 6 931 09-18-2022, 11:35 AM
Last Post: lorebett
  Debian emmc installer db579 6 1,132 08-23-2022, 06:13 AM
Last Post: db579

Forum Jump:

Users browsing this thread: 1 Guest(s)