Rock64s will not boot any OS
#1
I own 4x Rock64 boards.

3x of them of them will not boot.

They turn on all lights and never do anything. No HDMI output. Nothing.

I have a custom script that installs ArchLinux ARM which used to work/boot just fine. I've used it dozens of times.

I also tried the Armbian and Manjaro Arm images. Same results. All lights turn on, no HDMI output, it just sits there.

Two of the boards are V3, one is V2.

Yes, the jumper is installed.
Away
  Reply
#2
after much wailing and gnashing of teeth...

v2 board:
I made a fresh ArchLinux Arm card using my old script. Stuck it in the V2. It wouldn't boot. Out of frustration I just kept hitting the reset button. After about 6 hours of being belligerent... I kept hitting reset, punched it a few times, Threw it across the room against the wall a few times. Plugged it in. It booted! It continues to boot every time! Running it hard with my cryptography toys, its working perfectly. I guess it just needed some violent persuasion? Yeah, I don't trust it, but it's being going strong for 12 hours now... I guess I beat some sense into it? It realized that working properly was in its best interest?

v3 boards:
I've downloaded and DDed every image (for V3) on this page:
https://wiki.pine64.org/index.php/ROCK64...e_Releases

Only one boots: Debian by MrFitIt2001

Absolutely nothing else will boot. I'll say it again, absolutely NOTHING on that page works except for one... And it's of no use to me.

The V3 boards are useless bricks. Almost none of the advertised software actually works. What does work, while many may be thankful MrFixIt2001 for being the only functioning delivarable, does not suit my use case.

The V2 boards are tempermental, at best.

I'll be looking elsewhere from now on. No more Pine64 products for me.
Away
  Reply
#3
Just a note that I have six Rock64 boards. All booting and working with Armbian from first boot.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Unable to boot armbian fchazal 2 89 05-19-2020, 06:43 PM
Last Post: Rocklobster
  Help me understand the boot up process olivercfc 0 105 11-10-2019, 08:30 AM
Last Post: olivercfc
Brick Rock64 stuck in boot, please help! Malmgren 7 463 11-05-2019, 07:02 AM
Last Post: Malmgren
Question [SOLVED] Alpine Linux won't boot rock7 1 517 10-22-2019, 04:30 PM
Last Post: rock7
  Rock64 Rev3 doesn't boot and leds blinking fast dishins 2 308 08-12-2019, 06:31 AM
Last Post: dishins
  Forcing u-boot to detect USB3 storage jandastroy 8 1,118 04-02-2019, 10:06 PM
Last Post: t4_4t
  Consistent boot from SSD? Is it possible? SirRyanTheGeek 1 230 04-02-2019, 12:28 PM
Last Post: SirRyanTheGeek
  Not able to boot Armbian 5.75@Rock64 4GB wundidajah 1 319 03-29-2019, 05:30 AM
Last Post: dkryder
  Boot from USB - What's about resizing the partitions? hg6806 5 399 02-28-2019, 11:09 PM
Last Post: evilbunny
  Rock64 fedora core 29 boot issue: Help please? forwardbackwards 5 1,356 12-31-2018, 04:32 AM
Last Post: toons

Forum Jump:


Users browsing this thread: 1 Guest(s)