How I am running ubports as a daily driver
#1
1. Write ubports image to emmc
2. Extend root filesystem to 16GB as per https://askubuntu.com/a/958145
Code:
sudo parted /dev/mmcblk2
  resizepart 1
  yes
  -0
  quit
sudo resize2fs /dev/mmcblk2p1

3. Wifi work-around.


Code:
nano /home/phablet/fix-wifi.sh:
sudo nmcli radio all off
sudo rmmod 8723cs
sudo modprobe 8723cs
sudo nmcli radio all on
#2
Thanks for this! Off to try it now.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
OS: Mobian Bookworm, Phosh. Pinephone Braveheart from 2020-02-11
#3
Any app recommendations at this point?  I have found OnionBrowser and Stellarium work very well.  FluffyChat works but without E2E right now.  WireUT works with some keyboard overlay issues.  I am able to play music from Terminal with ffplay.
#4
(03-02-2020, 11:47 AM)supernova Wrote: Any app recommendations at this point?  I have found OnionBrowser and Stellarium work very well.  FluffyChat works but without E2E right now.  WireUT works with some keyboard overlay issues.  I am able to play music from Terminal with ffplay.
have you explored "brax.Me" app , and all the stuff "Rob Braxman " does on youtube , and in his store ,vpn`s, etc, etc
#5
Well, I'm stuck on very simple stupid stuff. SSH used to work, doesn't now for some frustrating reason ["no route"], so I figured I'd just use nano on the phone. I can't get at CTRL-X to save the laboriously typed in file! Aargh. What's up with that??

Doing the little nano menu at the bottom left above the keyboard, selecting "Ctrl" and hitting X on the keyboard just gets me a nice "X" typed into the file.

I can't find any combination of keys that gives me a Ctrl-X either. Eg something like ^[[X. It all just echoes to the file. It isn't one of the preset choices starting with Ctrl-R of course. That would be too easy. Aargh. Again.

The line about using dpkg-reconfigure tzdata, after a LOT of difficulty getting the selection to change in the ncurses menu, is the one and only method that's worked to get time working! Thanks!
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
OS: Mobian Bookworm, Phosh. Pinephone Braveheart from 2020-02-11
#6
(03-02-2020, 05:03 PM)quixote Wrote: ...
Doing the little nano menu at the bottom left above the keyboard, selecting "Ctrl" and hitting X on the keyboard just gets me a nice "X" typed into the file.

I can't find any combination of keys that gives me a Ctrl-X either. Eg something like ^[[X. It all just echoes to the file. It isn't one of the preset choices starting with Ctrl-R of course. That would be too easy.  Aargh. Again.
...

That 'Ctrl' doesnt send a ctrl, its the name of the shortcut menu.
Press and hold that little handburger menu, drag up to 'nano' and release, that'll give you nano shortcuts, including CTRL-O and CTRL-X.
#7
(03-02-2020, 10:25 PM)faeredia Wrote: That 'Ctrl' doesnt send a ctrl, its the name of the shortcut menu.
Press and hold that little handburger menu, drag up to 'nano' and release, that'll give you nano shortcuts, including CTRL-O and CTRL-X.

Ohhhhhhhhhh.  Thanks!
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
OS: Mobian Bookworm, Phosh. Pinephone Braveheart from 2020-02-11
#8
So, finally got it all entered, scripts set up. (I'd love to know why my ability to ssh vaporized! Problem for another day.) Restarted.

/etc/rc.local didn't seem to run on startup. ?? It is executable, but there wasn't any sound until I ran it manually. (I copied it to an executable in /home/phablet and ran that. Don't know if that makes a difference.)

Ran the start modem script and fix wifi script.

It allows me to send and receive SMS. W00T!

Voice calling is showing signs of life, but is not functional on my system. The phone app comes up, recognizes the SIM, and dials, but the phone app crashes as soon as there's a connection. Calling in from another number, the phone rings on the other phone, but not on the pinephone, and then it goes to voicemail. There's no visual sign on the display of an incoming call either. Sound is on and functions in other apps, eg if the keyboard click is set to on.

Wifi refuses to appear at all, in any way.

Any ideas for improvements from here?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
OS: Mobian Bookworm, Phosh. Pinephone Braveheart from 2020-02-11
#9
(03-02-2020, 05:03 PM)quixote Wrote: SSH used to work, doesn't now for some frustrating reason ["no route"], 

Did your IP address on the phone change? You can check that with:
$ ip a

You can also make sure your ssh server is running:
$ sudo service ssh status
#10
(03-03-2020, 02:06 AM)quixote Wrote: So, finally got it all entered, scripts set up. (I'd love to know why my ability to ssh vaporized! Problem for another day.) Restarted.

/etc/rc.local didn't seem to run on startup. ?? It is executable, but there wasn't any sound until I ran it manually. (I copied it to an executable in /home/phablet and ran that. Don't know if that makes a difference.)

Ran the start modem script and fix wifi script.

It allows me to send and receive SMS. W00T!

Voice calling is showing signs of life, but is not functional on my system. The phone app comes up, recognizes the SIM, and dials, but the phone app crashes as soon as there's a connection. Calling in from another number, the phone rings on the other phone, but not on the pinephone, and then it goes to voicemail. There's no visual sign on the display of an incoming call either. Sound is on and functions in other apps, eg if the keyboard click is set to on.

Wifi refuses to appear at all, in any way.

Any ideas for improvements from here?

Can you run
Code:
cat /etc/rc.local
in ssh and copy the output here? For reference, this is what you should see:

Code:
phablet@ubuntu-phablet:~$ cat /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

modprobe snd_soc_simple_amplifier
modprobe snd_soc_simple_card_utils
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
amixer -c 0 set 'Line Out' unmute
amixer sset 'Line Out' 100%

exit 0
phablet@ubuntu-phablet:~$

Honestly, not sure why the wifi is not working for you. Make sure that wifi is enabled in the UI and then run
Code:
./fix-wifi.sh
in a terminal and that should be enough to get wifi working.


Possibly Related Threads…
Thread Author Replies Views Last Post
  PinePhone UBPorts Edition stuck on PINE64 logo screen Giovanni Iannotti 4 1,157 09-01-2021, 01:20 PM
Last Post: Giovanni Iannotti
Information UBports Pinephone progress FOSSagent0 21 14,176 08-24-2021, 10:37 AM
Last Post: michel_luc
  online accounts in UBports Uturn 2 1,601 03-30-2021, 09:12 AM
Last Post: Uturn
  UBPorts Not Working Pinoideae 7 4,202 03-13-2021, 01:51 PM
Last Post: KNERD
  How to enable Ethernet with UBPorts and convergence dock? piney-tim 1 1,591 11-27-2020, 07:40 PM
Last Post: piney-tim
  UBPorts Convergence MonCon 0 1,346 11-24-2020, 04:25 PM
Last Post: MonCon
  Looks like I found a mild reason why UBPorts for pinephone hasn't seen much progress. plainenough 13 9,546 11-21-2020, 06:30 PM
Last Post: Nooblife
  "No network" on new UBPorts community edition pinephone professorsnapper 6 4,115 10-19-2020, 10:27 PM
Last Post: htc_tattoo
  DisplayPort driver SJSEng 0 1,097 10-12-2020, 06:43 AM
Last Post: SJSEng
  My Daily QA - 2020-10-01 plainenough 1 1,640 10-02-2020, 09:56 PM
Last Post: Phillip Bell

Forum Jump:


Users browsing this thread: 1 Guest(s)