Sailfish install problem.
#1
Sailfish is one of the oses i'd like to try out, but it's also the only one I can't get to boot properly.
The flash-it script reported success, the device starts to boot, the sailfish logo appears then it goes to a blank screen and the led comes on. looks kind of pink. I've left it in this state for several minutes but no change. 
All other images I've tried have worked fine on the phone, including using the same sd card. any clues? what am I missing?

Edit: That's a bit scary, nothing else would boot on the pinephone until I did a reset (long hold vol down plus power). back to normal now but something's really wrong with sailfish.
#2
The auto brightness in the sailfish image is currently broken. Hold the phone up to a bright light and the screen will turn on. Get through the setup and disable auto brightness in settings>display.
#3
(02-06-2020, 11:39 PM)Prophentes Wrote: The auto brightness in the sailfish image is currently broken. Hold the phone up to a bright light and the screen will turn on. Get through the setup and disable auto brightness in settings>display.

+1

Added to the wiki - anyone else is welcome to please help keep the wiki up-to-date.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.18 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC
#4
(02-06-2020, 11:39 PM)Prophentes Wrote: The auto brightness in the sailfish image is currently broken. Hold the phone up to a bright light and the screen will turn on. Get through the setup and disable auto brightness in settings>display.

That fixed it!
Thanks
#5
I'm having an install problem too, but mine is different.  I got the install script to work, it runs says it is downloading the files, then asks me for to SD card location (mmcblk0) in my case.  I give it the block name and it begins to run.  It goes through the process and tells me it was successful and that I can install the card in my Pine64 device.  But when I look at the card, it is empty.  I can unmount from my computer, remount it, and it still shows empty.  When I check the output from the install script it says in a couple of places, "mmcblk0p1 doesn't exist and no size was given" and "mmcblk0p2 doesn't exist and no size was given".  What the heck?  I even went so far as to use gParted to format the card, erase all partitions and make it one big partition (14.4 GB) so it has plenty of room to install to.  Can't figure out what's going wrong.
I refuse to tiptoe through life, only to arrive safely at death.
#6
(02-16-2020, 01:55 AM)noeman5 Wrote: I'm having an install problem too, but mine is different.  I got the install script to work, it runs says it is downloading the files, then asks me for to SD card location (mmcblk0) in my case.  I give it the block name and it begins to run.  It goes through the process and tells me it was successful and that I can install the card in my Pine64 device.  But when I look at the card, it is empty.  I can unmount from my computer, remount it, and it still shows empty.  When I check the output from the install script it says in a couple of places, "mmcblk0p1 doesn't exist and no size was given" and "mmcblk0p2 doesn't exist and no size was given".  What the heck?  I even went so far as to use gParted to format the card, erase all partitions and make it one big partition (14.4 GB) so it has plenty of room to install to.  Can't figure out what's going wrong.

That's strange. I had no issues flashing to my 16GB sd card from my Pinebook Pro. What distro and computer are you using? It is hard to say what may the issue, but here are some suggestions:

- Make sure you run as root.
- Ensure you have the latest script, and it is executable: https://raw.githubusercontent.com/sailfish-on-dontbeevil/flash-it/master/flash-it.sh
- Make sure it is the correct block device. Type lsblk before inserting the sd card, then again after to be sure
- Enter the path of the block device, with the /dev, and without the partition number (p1 or p2) For example: /dev/mmcblk0
- Ensure you have met all requirements. Type ./flash-it.sh -h:
  "This command requires: parted, sudo, wget, tar, unzip, lsblk,mkfs.ext4."
               "Some distros do not have parted on the PATH. If necessary, add"
               "parted to the PATH before running the script.
- Try running on another computer or partition or vm
- Try flashing another distro image with dd or Etcher, just to test if it is your computer or sd card, or issues just with getting the script to run properly

I hope you get this working.
#7
Photo 
the flash-it finish successful, but nothing written on sd card


Attached Files
.png   Bildschirmfoto von 2020-02-24 17-28-00.png (Size: 273.23 KB / Downloads: 348)
#8
I have the same issue: empty SD card after flashing.
#9
(02-24-2020, 11:24 AM)cefre00 Wrote: I have the same issue: empty SD card after flashing.

Seems hat Sailfish script won't work any more. And no one has a solution.

I must say, I'm a little disappointed about the available OS for the phone.
#10
(02-25-2020, 01:34 AM)harvey186 Wrote:
(02-24-2020, 11:24 AM)cefre00 Wrote: I have the same issue: empty SD card after flashing.

Seems hat Sailfish script won't work any more. And no one has a solution.

I must say, I'm a little disappointed about the available OS for the phone.

To be honest I expected this. This is an experimental something, which breaks a lot. I wish I would have more knowledge to fix this, but apparently I do not have that kind of knowledge. I tweeted for help, let's see if there will be anyone, who can have a look at this. Wink

Don't lose your lust or motivation. This phone won't be ready to be a daily driver for months, at least. But in the meantime we can experiment with many OSs, as soon as the flashing works. Tongue Angel


Possibly Related Threads…
Thread Author Replies Views Last Post
  Using Windows 10 to install SailfishOS Kimberley van Buyten 0 185 05-27-2022, 01:43 AM
Last Post: Kimberley van Buyten
  PinePhone versus Sailfish (Sony/Jolla) richieeee 10 5,034 07-10-2021, 04:18 AM
Last Post: acrux
  Lock screen problem? undo 5 4,161 03-03-2020, 05:00 AM
Last Post: explit
  Sailfish web browser linux6730 3 3,651 02-25-2020, 05:42 AM
Last Post: DrYak
  Sailfish still supported? Mangled 4 4,208 02-08-2020, 08:22 PM
Last Post: Mangled

Forum Jump:


Users browsing this thread: 3 Guest(s)