How to turn Bluetooth radio off by default
#1
Hello I was wondering how the Bluetooth radio can be configured so it is off by default every time the system starts up? Thanks.
#2
Are you looking to prevent Bluetooth access on boot?
Or reducing power usage?

The Bluetooth part of the WiFi chip uses a separate interface from WiFI. That can be software disabled to prevent access. However, you would need to send the Bluetooth chip a command to disable the radio.

Whence it's figured out, (both radio off and disabling access), we need it on the Wiki.
--
Arwen Evenstar
Princess of Rivendale
#3
I think the command is something like:

Code:
rfkill block bluetooth

would have to put it in some startup script.

EDIT:

For systemd it's actually really easy, just enable the rfkill-block service:

Code:
sudo systemctl enable rfkill-block@bluetooth
#4
Cool Thanks. Still fairly new to linux, so some features I just sort of expect in a distro, especially when it comes to radio connectivity stuff by default.

If it can be set to off by default, after clicking the bluetooth icon, it would make sense since this would save some power, eliminate unwanted connections or automatic pairing that is undesired, reduce EMF (yes I am sensitive to it), and so on.


Thanks for the help.
#5
(02-05-2020, 09:42 AM)slyecho Wrote: EDIT:

For systemd it's actually really easy, just enable the rfkill-block service:

Code:
sudo systemctl enable rfkill-block@bluetooth

This doesn't seem to work on Manjaro.
#6
Well, I tried and yes, it seems to be activated on boot. If you deactivate the bluetooth service: 
Code:
sudo systemctl disable bluetooth

Then it seems to stay off, however you need to start the service manually then, too.
I, myself just keep it on all the time, I haven't really needed to squeeze the most from the battery because it is already very impressive on its own.
#7
The problem on Manjaro is that Blueman turns the radio on by default.

Here is how you disable this behavior:
right click on the bluetooth panel icon > select 'plugins' > PowerManager > configuration > unselect the auto power on option

Should work on any distro that uses blueman and turns radio on by default.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Enabling spekaer/Connecting to bluetooth from command line axisarm 1 221 08-06-2021, 04:29 PM
Last Post: nfms
Music No sound on PBP default installation ivek 9 3,649 05-09-2021, 05:58 PM
Last Post: binholz
  curious why KDE by default? dieselnutjob 7 3,410 07-18-2020, 03:21 PM
Last Post: Damon
  Root access over SSH enabled by default gibby 3 3,616 06-28-2020, 01:19 PM
Last Post: Arwen
  Better (than default Debian/MATE) Linux distro? mspohr 34 16,490 06-11-2020, 01:34 PM
Last Post: s3rvant
  Slow WiFi on Manjaro Default Image 20.04 for PBP SuperUJ 8 4,514 05-28-2020, 08:16 PM
Last Post: nekojet
  Default Manjaro KDE build download link for Pinebook Pro? qeek 8 4,101 03-21-2020, 09:41 AM
Last Post: MrDitchy
  The default OS / kernel had a wifi issue? dawncold 15 7,803 03-02-2020, 06:26 PM
Last Post: lowry
  Pinebook Pro - change default user fonske 2 1,679 02-24-2020, 10:59 PM
Last Post: dlester1964d
  Restore default Debian system perceg 43 26,156 02-20-2020, 05:28 PM
Last Post: Thovthe

Forum Jump:


Users browsing this thread: 1 Guest(s)