How to enable widevine in firefox (PrimeVideo)
#1
The steps below worked for me in getting Amazon Prime Video working in firefox. I'm assuming they'll also enable Netflix, but who knows. It's possible some subset of these instructions is enough, but I'm just going to spew out everything I did before it started working. If someone else wants to figure out what subset of these steps is needed to get it working, be my guest. Smile

I've basically borrowed liberally from this how-to:
https://www.reddit.com/r/firefox/comment...plugin_to/


..and borrowed values as needed from the widevine files on my Windows desktop machine. Not all of this may be necessary. e.g., Rather than put in the incorrect version number for widevine (I have no idea what version is on my system), I'm just using 0. Likewise, x-cdm-codecs is taken from my windows machine so it could be completely wrong for the platform..

Steps:

1. Make sure widevine is up-to-date and working in chromium on your PBP, because we're going to 'borrow' those libs.
2. Figure out what your mozilla profile directory is (aboutConfusedupport, see "Profile Folder")
3. Open a terminal and change to that directory.
4. mkdir -p gmp-widevinecdm/0/ && cd gmp-widevinecdm/0/
5. cp /usr/lib/chromium-browser/libwidevinecdm* .
6. create a file called manifest.json, and fill it with:

{
    "name": "WidevineCdm",
    "description": "Widevine Content Decryption Module",
    "version": "0",
    "x-cdm-module-versions": "4",
    "x-cdm-interface-versions": "10",
    "x-cdm-host-versions": "10",
    "x-cdm-codecs": "vp8,vp9.0,avc1",
    "x-cdm-persistent-license-support": true
}

7. Open firefox, and open about:config. Create the following entries:

media.gmp-widevinecdm.version - string - "0"
media.gmp-widevinecdm.visible - bool - true
media.gmp-widevinecdm.enabled - bool - false

and then change the following already-existing entries:

media.eme.enabled - true
media.eme.encrypted-media-encryption-scheme.enabled - true


8. Open about:addons. You should now see an entry for Widevine. Click on the drop down on the right, and select Always enabled.
  Reply
#2
Moving to Tutorials
  Reply
#3
Is this just for the default debian or does this apply to other distros like Manjaro?
  Reply
#4
(01-18-2020, 01:00 AM)clover Wrote: Is this just for the default debian or does this apply to other distros like Manjaro?

I've only attempted this on default debian. If widevine is already working in chromium on Manjaro, then I assume a similar series of steps could be followed to get firefox working as well. (it's possible the libwidevinecdn* files might be found in a different location? I really don't know Manjaro's layout.)
  Reply
#5
(01-17-2020, 11:00 PM)sirspate Wrote: The steps below worked for me in getting Amazon Prime Video working in firefox. I'm assuming they'll also enable Netflix, but who knows. It's possible some subset of these instructions is enough, but I'm just going to spew out everything I did before it started working. If someone else wants to figure out what subset of these steps is needed to get it working, be my guest. Smile

I've basically borrowed liberally from this how-to:
https://www.reddit.com/r/firefox/comment...plugin_to/


..and borrowed values as needed from the widevine files on my Windows desktop machine. Not all of this may be necessary. e.g., Rather than put in the incorrect version number for widevine (I have no idea what version is on my system), I'm just using 0. Likewise, x-cdm-codecs is taken from my windows machine so it could be completely wrong for the platform..

Steps:

1. Make sure widevine is up-to-date and working in chromium on your PBP, because we're going to 'borrow' those libs.
2. Figure out what your mozilla profile directory is (aboutConfusedupport, see "Profile Folder")
3. Open a terminal and change to that directory.
4. mkdir -p gmp-widevinecdm/0/ && cd gmp-widevinecdm/0/
5. cp /usr/lib/chromium-browser/libwidevinecdm* .
6. create a file called manifest.json, and fill it with:

{
    "name": "WidevineCdm",
    "description": "Widevine Content Decryption Module",
    "version": "0",
    "x-cdm-module-versions": "4",
    "x-cdm-interface-versions": "10",
    "x-cdm-host-versions": "10",
    "x-cdm-codecs": "vp8,vp9.0,avc1",
    "x-cdm-persistent-license-support": true
}

7. Open firefox, and open about:config. Create the following entries:

media.gmp-widevinecdm.version - string - "0"
media.gmp-widevinecdm.visible - bool - true
media.gmp-widevinecdm.enabled - bool - false

and then change the following already-existing entries:

media.eme.enabled - true
media.eme.encrypted-media-encryption-scheme.enabled - true


8. Open about:addons. You should now see an entry for Widevine. Click on the drop down on the right, and select Always enabled.

Hello sirspate.

Thanks very much for this!  I followed these steps and now Amazon Prime video is working.  Netflix, however, continues not to work.  The new error I get there is F7121-1331.  Searching google yielded this gem (see last line):

If you experience the error code M7121-1331 on your computer, it typically points to a problem with your browser. Using unsupported browsers, such as Speed Browser, can interfere with the player Netflix uses to play TV shows and movies. Follow the troubleshooting steps below to resolve the issue.

Ensure your browser is supported
Netflix requires the following browser versions to stream successfully.
  • Google Chrome version 64 or later on Windows 7 or later, Mac OS X 10.10 or later (Mavericks), Chrome OS, or Linux*
  • Internet Explorer 11 or later on Windows 8.1 or later
  • Microsoft Edge on Windows 10
  • Mozilla Firefox version 59 or later on Windows 7 or later or Mac OS X 10.10 or later (Yosemite)
    • Supported on stable, official release builds from Mozilla. Non-Mozilla builds are not supported.
  • Opera version 47 or later on Windows 7 or later or Mac OS X 10.10 or later (Yosemite)
  • Safari on Mac OS X 10.10 or later (Yosemite)
    • Supported on all 2012 or later models and select 2011 models
Note:
It's possible that some unsupported browser versions may continue to function, however we cannot guarantee the Netflix experience on those browsers.
*Due to the many configurations of Linux available, customer support is unable to assist with troubleshooting issues on Linux devices.

Thanks again for your work on this sirspate.  If I find a way to get Netflix working I'll reply here.

Bill
  Reply
#6
I attempted this on the Bionic image this morning. After completing the steps I was able to watch Prime for a glorious couple of minutes, then I restarted Firefox and got a message (I'm sorry I don't remember the exact message, but something about using old firefox being risky) and the choices were cancel or Update profile. I think all the work I had done got reset somehow. I'll try again a few and take notes of the specific message if it reappears.

(01-20-2020, 07:59 AM)mamboman777 Wrote: I attempted this on the Bionic image this morning.  After completing the steps I was able to watch Prime for a glorious couple of minutes, then I restarted Firefox and got a message (I'm sorry I don't remember the exact message, but something about using old firefox being risky) and the choices were cancel or Update profile.  I think all the work I had done got reset somehow.  I'll try again a few and take notes of the specific message if it reappears.

After repeating the steps, everything seems to be working as expected.  Thanks again!  Great work!
  Reply
#7
(01-18-2020, 01:00 AM)clover Wrote: Is this just for the default debian or does this apply to other distros like Manjaro?

Wide vine for arm is currently only for 32 bit user space . Manjaro and many others are 64 bit , so at least for now it’s a no go.
  Reply
#8
I presume others can use widevine by adding armhf arch
  Reply
#9
This helped me get a bit further... I can see the Widevine plugin listed in Firefox and services like Amazon Music actually load, but playback still isn't working. Prime Video just shows a black screen, for example.
  Reply
#10
I managed to get Netlfix working using firefox.

It seems that the problem was the user agent.

I switched to 'Mozilla/5.0 (X11; CrOS armv7l 6946.63.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Safari/537.36' and it works.

Any useragent switcher extension should work.

Thanks for this great tutorial.

It works on both default debian and Ayufan ubuntu
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro XFCE: Enable Natural Scrolling (Reverse scrolling direction) kiddailey 0 1,794 01-22-2020, 08:10 PM
Last Post: kiddailey
  Widevine-flash on Chromium-SD Card mamboman777 3 1,630 01-20-2020, 04:00 PM
Last Post: tophneal

Forum Jump:


Users browsing this thread: 1 Guest(s)