NTFS drive not working
#1
I have a Seagate 2.5" external drive formatted to NTFS.
When I connect the drive, nothing seems to be happening on the PBP.
lsblk does list the drive, but that's it.
df doesn' t see it.
GParted starts scanning, but never seems to finish.

When I look in Package Manager, ntfs-3g is already installed.
Any suggestions?
  Reply
#2
Are you able to manually mount the drive?

Code:
sudo mkdir /mnt/ntfs
sudo mount -t ntfs-3g /dev/sda1 / mnt/ntfs
Linux n00b trying to learn.
Brute force and ignorance sometimes works!
| Pinebook Pro + Toshiba OCZ RC100 240GB |
  Reply
#3
**
Pretty sure you will need to use an external power source for your drive.

A Lot of posts here have the same or simular problem, external power source seems the only way.

The PBP just does not have enough power for most "external drives"

Unless you try usb flashdrive or sd cards.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#4
Have you tried the external drive while having your power adapter plugged in?
Maybe it doesn't have enough juice when on running on batteries to spin up the drive properly.
Or try one of those split usb cables that has 2 connections, one for power one for the laptop.
  Reply
#5
Did you try the USB3 socket or the USB2 socket? The current limiter for each port is configured differently (as you would expect given the spec requires USB3 sockets to be capable of delivering more power). I think the current limiter on the USB3 socket will start to kick in if the drive consumes more than an amp (but I can't be sure since I can't find a datasheet for the part).
PineTime: wasp-os and MicroPython, Pinebook Pro:  Debian Bullseye
  Reply
#6
please do a lsusb on the shell, and post the output.
They are two types of USB adapters out there

- usb storage device
- usb ata

maybe the driver is missing here
  Reply
#7
Thanks for the suggestions. Turns out the drive is broken. Tried it with another NTFS drive and the PBP shows it without any problem.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Sad Webcam not working in pinebook pro with Manjaro jcarball 2 266 04-28-2021, 03:23 PM
Last Post: jcarball
  Built-in Webcam Not Working fozzedout 36 13,646 02-01-2021, 08:59 AM
Last Post: lemaurien19
  [split] U-Boot with NVMe support, keyboard & display working as400 83 31,807 01-27-2021, 12:48 AM
Last Post: as400
  Booting to sdcard stopped working after emmc flash techiedog 3 989 12-31-2020, 06:30 PM
Last Post: Anarethos
  Wifi stopped working after updates pineitup 10 2,641 11-07-2020, 02:59 AM
Last Post: wdt
  Working terminal emulator bookguy1 7 2,963 08-04-2020, 02:34 PM
Last Post: mfashby
  Suspend with NVME not working - Default Debian appdev46 5 3,049 07-14-2020, 01:53 PM
Last Post: Jeremiah Cornelius
  USB-C to 4k monitor: right 1/3 not working robt 4 1,636 07-12-2020, 02:46 PM
Last Post: robt
  Nvme drive not being recognised. vssz 12 4,098 06-18-2020, 02:43 AM
Last Post: vssz
  New PBP - WiFi not working! ashwinpatel 9 3,460 06-16-2020, 10:15 PM
Last Post: ashwinpatel

Forum Jump:


Users browsing this thread: 1 Guest(s)