Pinebook is going the way of Betamax?
#1
I've bought one a year ago, attracted by the idea and the somewhat low price point (somewhat because the shipping and import tax doubled the price, but I wanted to support the project) plus the idea of getting better at working with linux.

A year later, I have to say this failed big time. You built a neat product, looks sleek, the premise is awesome. But the included software is ancient, so you start looking for a new OS. Now, I am somewhat proficient with linux in that I can apt-get my way around the command line and maybe understand a simple script or symlink, but compiling something or building something myself is not something I know how to do. And that's where things break down.

None if the images (and I tried neigh all of them) that are mentioned as being fit for the Pinebook were stable in any way. I haven't been able to use any of them with any measure of success. My latest install of Manjaro ARM KDE lasted for 2 bootups: After the first major 'update' the system broke down and the wifi is since inoperable. I'm sure it's easy to fix for a linux guru or when I get down to it and put a couple of hours of research into it, but having to fix a new issue every freaking fresh install is getting up my nerves after a year. I've had update cycles break the system, but often the system will just break itself and stop working after X bootups. Weird audio issues. Weird mouse issues. Weird display issues. Weird network issues. Every time I give it a go something else breaks without me having even touched the system or the configuration. 

The actual 'installation procedure' is either boot from SD, install from a capable installer FROM SD to EMMC or the dreaded "DD" which for me, no matter the amount of instructions from people who assume half an word is enough, has never worked. I've tried scripts, after failing those I contacted the people who made the scripts, and they didn't respond or stopped responding after I asked a question. Numerous attempts from users to create something viable have died out, and many of the builds still being produced by avid enthusiasts are riddled with issues. 

I know this product was sold with a big disclaimer. It's supposed to be a 'learning experience'. It's such a shame the product is so unusable even that is not an attainable goal because the 'experience' is condensed down to keeping the bloody thing running (or even getting it to work). 

I would have loved to be able to have some form of Debian running on it, because that's a system I know. But the 'armbian' images are DD only (and I've tried ever method I've found to DD the installation to the EMMC, every try has borked the system and did not give the described results) so I couldn't get them to work. Heck, I couldn't even figure out why it didn't work as described, and attempts to find support have landed me nothing. 

Can't say that I'm anything but dissappointed in this project, and my purchase.
  Reply
#2
If you want to run Armbian on your Pinebook, I can try and help you set up the latest image, even with the infamous DD, hit me up here or on the IRC/Discord chat channel for the Pinebook.
Come have a chat in the Pine A64 IRC channel >>
  Reply
#3
Honestly, my only disappointment is the hardware. The CPU is almost two generations old. However, that is also to be expected at this price point so it really isn't much of a disappointment.

Even the "new" rockchips aren't keeping up with Apple and Samsung, and that's what's needed for a feature device. Of course, a "feature" device will cost 10x -- 15x more money units...

Sent from my moto x4 using Tapatalk
  Reply
#4
(11-28-2019, 01:47 PM)trigger Wrote: But the 'armbian' images are DD only (and I've tried ever method I've found to DD the installation to the EMMC, every try has borked the system and did not give the described results) so I couldn't get them to work.

What's wrong with the nand-sata-install feature that can also install to eMMC? The name might seem a bit counter-intuitive, but that's the name it has given it's origins, and it's also availbly as a menu option in armbian-config.

https://docs.armbian.com/User-Guide_Gett...d-sata-usb

For my pinebook, I try the more recent images every now and then, and would really like to go with Manjaro ARM, but until the issue with it not charging properly is fixed, it's a no-go for me (for an eMMC install, anyway). I will have to try again, as there has been another mainline kernel release since I tried last. For my regular eMMC install, I've stuck with ayufan's ubuntu builds... can't remember if I upgrade to bionic or not, or stuck with xenial. It might be old, but it is an LTS build, and still works well.
  Reply
#5
What charging issues ?
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pinebook Wlan Driver does not work properly matze79 0 25 Yesterday, 12:38 PM
Last Post: matze79
  Q4OS for PINEBOOK q4osteam 89 27,313 11-12-2019, 09:17 PM
Last Post: ac8dg
Information Manjaro ARM for Pinebook erchache2000 68 5,584 11-08-2019, 07:36 AM
Last Post: fitter
  Pinebook 1080p / KDE Neon freezes every 5-10 min pyrrhumain 12 619 11-02-2019, 10:03 AM
Last Post: rookieone
  Are Pinebook images compatible with Pine64+? starcrescent 7 183 09-18-2019, 09:22 AM
Last Post: tophneal
  Archlinux (mainline) for Pinebook anarsoul 51 14,976 08-28-2019, 05:23 PM
Last Post: conlaoch
  will openMP work on a pinebook? rustythorn 2 139 07-23-2019, 01:42 PM
Last Post: tophneal
  Armbian - Xenial Desktop (Pinebook) pineadmin 83 18,832 07-17-2019, 01:22 PM
Last Post: catsmile
  pinebook 1080p crash and fix nano2 2 234 06-24-2019, 07:41 PM
Last Post: pyrrhumain
  NIxOS installation guide for Pinebook Surehand53 0 251 06-23-2019, 03:46 AM
Last Post: Surehand53

Forum Jump:


Users browsing this thread: 1 Guest(s)