Package compatibility
I apologize if this is a dumb question, but how does compatibility work when installing packages? I've been able to install packages on my new Pinebook Pro (Ubuntu MATE) using either apt or the .deb package manager. Every now and then, some of these installs fail. My question is what is required for an Ubuntu application to be able to run on the Pinebook Pro? Did someone have to specifically compile it for the right CPU architecture? And if that is the case, are we significantly limited then on what can run on the Pinebook Pro?

If there is a good reading material that explains this in detail, I'd appreciate a link or if you point me in the right direction.

Thank you!
Run this

dpkg --print-architecture

It should say arm64 i guess. That's your cpu arch in the PBP.

Next look into /etc/apt/sources.list and files (if any) under /etc/apt/sources.list.d/ I bet you'll see the official ubuntu repos listed there.

So the answer is basicly you can install anything from the official ubuntu repos for arm64 arch OR software built for arm64 from somewhere else.

Unfortunately you didn't provide any details on what errors you experienced with apt.

(11-15-2019, 01:24 PM)fcs Wrote: using either apt or the .deb package manager

Idk what you mean under ".deb package manager" but it case it is "dpkg -i xxx.deb" (and based on your question) I'd suggest you not install debs downloaded from some random place.
Thank you so much for your response, that makes sense. So, it does not mean applications have to be compiled for a Pinebook Pro, but more generally for arm64?

What I meant by ".deb package manager" was a simple double click on a downloaded .deb file, which I believe then calls the dpkg command as you indicated. Not installing from a random place certainly sounds like good advice!

I wanted to understand the general concept, that's why I did not provide the specifics, but since we are here, this is what I was trying to install:

(Zoom is a videoconferencing service.) I selected Ubuntu from the drop-down menu and then 64-bit and also 32-bit and neither of them worked. It gave an error message (I don't remember exactly, but I can reproduce it).
(11-15-2019, 10:00 PM)fcs Wrote: I selected Ubuntu from the drop-down menu and then 64-bit and also 32-bit and neither of them worked

It surely would not work because their "32-bit" is i386 and "64-bit" is amd64.
I understand it now. Thank you very much!
(11-16-2019, 10:16 AM)fcs Wrote: I understand it now. Thank you very much!

You might contact them and ask about ARM, both 32 & 64 bit. It may not make a difference in the short term. But with Raspberry Pi and other ARM CPU based computers that can be used as desktops, (or in our case laptops), they would likely start seeing more ARM CPU requests for their software. You could even mention Raspberry Pi and others, like our Pinebook Pros.

Note that the default OS image is 64 bit kernel but only 32 bit userland. If I understand it correctly, we can't run 64 bit userland, (on the default OS image). So by default, a user would need ARM 32 bit software. I hope that changes, I'd like multi-lib, (both 32 & 64 bit), with a few 64 bit userland programs.
Arwen Evenstar
Princess of Rivendale
When I run:
dpkg --print-architecture

I get:

Does this invalidate any of the information provided here?

Possibly Related Threads…
Thread Author Replies Views Last Post
  Software Compatibility, If on Pi then? chetchinglo 5 7,023 06-06-2020, 07:11 PM
Last Post: chetchinglo
  Error when trying to install local package with pkcon koenigs 0 2,011 05-11-2020, 03:22 AM
Last Post: koenigs
  How to install a package mjcohen 1 2,818 12-05-2019, 01:12 AM
Last Post: ventus_orientis

Forum Jump:

Users browsing this thread: 1 Guest(s)