Help: Keyboard and trackpad SPI update utility broke trackpad

I ran ayufan's keyboard and trackpad SPI update utility (found here: I got the following error message:

update pass
QObject: Cannot create children for a parent that is in a different thread.
(Parent is QApplication(0xfffbe9dc), parent's thread is QThread(0xab2ca308), current thread is QThread(0xec1201a8)

I'm still able to use the keyboard on the PBP, but the trackpad behaves as through one of the mouse buttons is being held down. Then after a couple of uses the cursor seizes in place. I've tried running it again but I get more or less the same error. I can work around it for now by plugging in a USB mouse.

Does anyone have any guidance on how to re-flash the SPI, or know when the keyboard/trackpad update utility will be fixed?

I heard they were working on a firmware update for the keyboard, but I was not aware they had one available yet.
I think the SPI is un-used at this time on the PBP, but it is meant for booting purposes ?
I DO want to keep up on all the available updates....
   Donate to $upport
your favorite OS Team
There is no new firmware update for the trackpad/keyboard yet. @Feakster, where did you read it was to be flashed?
I'll see if I can get you the factory firmware again.
Come have a chat in the Pine A64 IRC channel >>
To all those reading this thread - DO NOT run the update utility. I'll let you know when we've got the firmware.
You can find me on IRC, Discord and Twitter

(11-10-2019, 07:35 AM)xalius Wrote: There is no new firmware update for the trackpad/keyboard yet. @Feakster, where did you read it was to be flashed?
I'll see if I can get you the factory firmware again.

Thank you.

Sorry. Must have misread something.

I have done the wrong thing, too.
I'll follow this thread in the hope someone finds a solution for the trackpad.
The instructions in this thread solved the issue for me:
Oh rats Step 2 didnt work, your instuctions didn't mention that you start in the wrong directory after a re-start......These instructions from so called "experts" are invariably incorrect...I should have learnt and not bothered . trackpad...thanks
even you message board doesn't work....thanks

Possibly Related Threads...
Thread Author Replies Views Last Post
  Keyboard - Some keys not working Christoph.Krn 0 46 05-19-2020, 05:36 AM
Last Post: Christoph.Krn
  Pinebook Pro Revised Keyboard Firmware jackhumbert 55 8,858 05-07-2020, 08:18 PM
Last Post: mil
  Trackpad sluggish response ravanh 17 1,156 04-08-2020, 07:52 AM
Last Post: chaoskampf
  Touchpad, Keyboard, I2C oh my. resistanceisfutile 12 1,039 04-05-2020, 08:13 PM
Last Post: akirakyle
Exclamation Firmware/Keyboard Failure on ANSI PBP Jeremiah Cornelius 1 199 02-08-2020, 06:59 PM
Last Post: bcnaz
  ANSI PBP Keyboard Mapping for Tilde character appdev46 3 227 01-15-2020, 05:33 AM
Last Post: bcnaz
  Keyboard keys rearrangable? the7thstranger 6 380 01-14-2020, 09:30 AM
Last Post: jackhumbert
Lightbulb Keyboard Shortcut Suggestion Feakster 1 155 11-27-2019, 10:27 AM
Last Post: Arwen
  Trackpad Emulation Der Geist der Maschine 5 404 11-24-2019, 10:39 AM
Last Post: Der Geist der Maschine
  keyboard problem romansvec 12 755 11-11-2019, 02:45 PM
Last Post: CryptoRick

Forum Jump:

Users browsing this thread: 1 Guest(s)