Remote-viewer "Bus Error"
#1
Hi all,

I have a Proxmox server with a SPICE-enabled guest.  I'm able to install the remote-viewer application from apt, but when I attempt to connect to the Proxmox guest machine's console, remote-viewer crashes out with the text "Bus error".   I've attempted the console connection also via Firefox and Chrome, as well.  I don't have this issue on my Ubuntu Mate box (main desktop -> Proxmox cluster)

I'd love to get this to work, as it would let me leverage my ProxMox cluster I have running at my house.

Happy to provide any requested logs.
  Reply
#2
(11-04-2019, 02:26 PM)wingmanjd Wrote: Hi all,

I have a Proxmox server with a SPICE-enabled guest.  I'm able to install the remote-viewer application from apt, but when I attempt to connect to the Proxmox guest machine's console, remote-viewer crashes out with the text "Bus error".   I've attempted the console connection also via Firefox and Chrome, as well.  I don't have this issue on my Ubuntu Mate box (main desktop -> Proxmox cluster)

I'd love to get this to work, as it would let me leverage my ProxMox cluster I have running at my house.

Happy to provide any requested logs.

I have the same problem with virt-manager, so I guess the problem is in one or the spice libs.
  Reply
#3
(11-08-2019, 09:21 AM)mfritsche Wrote: I have the same problem with virt-manager, so I guess the problem is in one or the spice libs.

I did try the Ubuntu Mate build, and the problem exists there as well.
  Reply
#4
I'm no gdb expert, but the core tells me:

Program terminated with signal SIGBUS, Bus error.
#0 0xee762994 in ?? () from /usr/lib/arm-linux-gnueabihf/libspice-client-glib-2.0.so.8

Changing the VM settings from "Display Spice" to "Display VNC" seems to work for now.
  Reply
#5
(11-08-2019, 03:09 PM)mfritsche Wrote: Changing the VM settings from "Display Spice" to "Display VNC" seems to work for now.

Agreed, this gets by in a pinch, but the refresh rate is lower than the SPICE client.
  Reply
#6
Okay, this is going to be a bit of a long shot, because I'm really not an expert on how all this stuff works, and barely even understand the nuts and bolts of how libraries get organized and used under Linux. However, I also hit the mysterious "bus error" problem myself, and in my case, I found a way to fix it that worked, so I figure I might as well share.

For me, this happened with `zpaq`, which is a very small high-performance archive compressor that I use a lot. At first, I had no idea what to try, but then when attempting to build from source, I ran across this in the readme:

Code:
-DNOJIT  = turn off run time optimization of ZPAQL to 32 or 64 bit x86
          in libzpaq. Use this for a non-x86 processor, or old
          processors not supporting SSE2 (mostly before 2001).

That was, as far as I can tell, it. When I recompiled using this flag, everything was fine. I guess the maintainer of zpaq (and lrzip, a similar tool that produced a similar error when I tried it) overlooked this when they committed their build to the repos?

In any case, if building from source is an option for you, it seems like this problem may sometimes be caused by incorrect runtime optimizations being enabled, and can be corrected by disabling them.

Good luck!
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Remote desktop client suggestions? rot26 12 395 11-15-2019, 03:11 AM
Last Post: mfritsche

Forum Jump:


Users browsing this thread: 1 Guest(s)