board not working
#1
Hi

When I woke up one morning, I wanted to turn on rockpro64, but it didn't. Green LED flickers, white and red LEDs do not light. board not working. What could be the problem?

"RockPro64 4GB"
  Reply
#2
(07-03-2019, 07:17 AM)kardanadm Wrote: Hi

When I woke up one morning, I wanted to turn on rockpro64, but it didn't. Green LED flickers, white and red LEDs do not light. board not working. What could be the problem?

"RockPro64 4GB"

The green led shouldn't flicker, what power supply are you using?
  Reply
#3
(07-03-2019, 05:27 PM)evilbunny Wrote:
(07-03-2019, 07:17 AM)kardanadm Wrote: Hi

When I woke up one morning, I wanted to turn on rockpro64, but it didn't. Green LED flickers, white and red LEDs do not light. board not working. What could be the problem?

"RockPro64 4GB"

The green led shouldn't flicker, what power supply are you using?

I used two different 12V power supplies.

12V 4.5A and 12V 3.3A
  Reply
#4
(07-03-2019, 05:27 PM)evilbunny Wrote:
(07-03-2019, 07:17 AM)kardanadm Wrote: Hi

When I woke up one morning, I wanted to turn on rockpro64, but it didn't. Green LED flickers, white and red LEDs do not light. board not working. What could be the problem?

"RockPro64 4GB"

The green led shouldn't flicker, what power supply are you using?

board is still not working. Should I throw it in the trash or repair it? What is your advice? where the problem may be. I want to take it to an electrician for repair. Is there any possibility of repair?
  Reply
#5
(08-30-2019, 09:49 AM)kardanadm Wrote:
(07-03-2019, 05:27 PM)evilbunny Wrote:
(07-03-2019, 07:17 AM)kardanadm Wrote: Hi

When I woke up one morning, I wanted to turn on rockpro64, but it didn't. Green LED flickers, white and red LEDs do not light. board not working. What could be the problem?

"RockPro64 4GB"

The green led shouldn't flicker, what power supply are you using?

board is still not working. Should I throw it in the trash or repair it? What is your advice? where the problem may be. I want to take it to an electrician for repair. Is there any possibility of repair?

According to the wiki, the green LED should light as long as there is 12V applied to the connector. (Even if the RockPro64 is powered off.)
I have no clue on what is your issue, and I dont have such devices yet, but if I were you I would start by looking at the card, and check if there is some burned electronic component.
By the way, after how much time did you get this issue ? Are you using your device a lot ?
  Reply
#6
(08-30-2019, 10:11 AM)kaylios Wrote:
(08-30-2019, 09:49 AM)kardanadm Wrote:
(07-03-2019, 05:27 PM)evilbunny Wrote:
(07-03-2019, 07:17 AM)kardanadm Wrote: Hi

When I woke up one morning, I wanted to turn on rockpro64, but it didn't. Green LED flickers, white and red LEDs do not light. board not working. What could be the problem?

"RockPro64 4GB"

The green led shouldn't flicker, what power supply are you using?

board is still not working. Should I throw it in the trash or repair it? What is your advice? where the problem may be. I want to take it to an electrician for repair. Is there any possibility of repair?

According to the wiki, the green LED should light as long as there is 12V applied to the connector. (Even if the RockPro64 is powered off.)
I have no clue on what is your issue, and I dont have such devices yet, but if I were you I would start by looking at the card, and check if there is some burned electronic component.
By the way, after how much time did you get this issue ? Are you using your device a lot ?

I wasn't home. my wife and children watched movies on youtube. Maybe they didn't shut down SBC, they don't remember. I came home in the morning and wanted to run SBC, it did not work.

I got this SBC from Ameridroid. previously bought another rockpro64 and odroid-n2, malfunctioned and implemented RMA. Thank you very much to Ameridroid.
We communicated for this board, they asked me to send the board to them, and I sent the board to them.
The board went to the US but they did not look at the board, did not detect problems. The board returned it back to me, they told you I've done a lot RMA. They may be right.
Cargo from Turkey usa 20 dollars and 30 dollars I paid taxes, RMA to return. I'm angry and sorry for that.
I asked them to tell me what's wrong with the Bboard, they cut off the communication.
  Reply
#7
I dont understand.
You said that Amerdroid "did not look at the board, did not detect problems". How can they tell you your board has no issue if they didnt look at it ?
And you had several issue, on different kind of boards ? So maybe all your boards are ok but your electrical power supply (if you use one) isn't ok ?
And you paid 20 USD + 30  USD= 50 USD only for RMA ? At this price I would have preferred to buy a new board ...
  Reply
#8
(08-31-2019, 06:23 AM)kaylios Wrote: I dont understand.
You said that Amerdroid "did not look at the board, did not detect problems". How can they tell you your board has no issue if they didnt look at it ?
And you had several issue, on different kind of boards ? So maybe all your boards are ok but your electrical power supply (if you use one) isn't ok ?
And you paid 20 USD + 30  USD= 50 USD only for RMA ? At this price I would have preferred to buy a new board ...

They didn't check the board. board is broken or board is not broken, they did not tell me. they just sent it back Smile

I have two different PSUs and now I'm using this PSU for odroid-n2. no problem on the PSU.

Yes I've paid 50 USD, maybe more Smile

Ameridroid told me you wanted to do RMA. asked me to return the board. board US went. then he realized and thought that he did me a lot RMA  Big Grin

I am sorry for my English. I am writing with google translate.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  board not working with EMMC RockPro64Newbie 1 199 05-10-2019, 02:22 AM
Last Post: Unkn0wn
  PCIe SSD drive still not working ?? dr_ju_ju 7 929 04-15-2019, 04:16 PM
Last Post: tllim
  Is my board dead? (again) duckkcud 8 682 01-24-2019, 07:12 PM
Last Post: 40four
  Only ttyS2 working with rockpro64. rahulsharma 1 199 01-15-2019, 12:33 AM
Last Post: rahulsharma
  Review/Advice for new board owner (support,purchase etc) tinkerdan 8 956 12-24-2018, 10:07 PM
Last Post: celer
  RockPro64 Features/options working/not working lavermil 9 1,168 10-23-2018, 02:48 AM
Last Post: lavermil
  Is my board dead? [SOLVED] duckkcud 2 406 10-15-2018, 07:46 PM
Last Post: duckkcud
Question Android 7.1 on EMMC not working, suggestions? SmartDIYTech 4 478 06-01-2018, 03:00 PM
Last Post: Luke
  measurements in mm of the ROCKPRO64 SBC board? killor 2 1,333 03-10-2018, 08:44 AM
Last Post: killor
  Queries regarding Android development on these board kafan1986 3 892 03-02-2018, 12:40 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)