Problems flashing u-boot on RockPRO64 eMMC
#1
Hi all,

I'm using a RockPro64 board with a eMMC.

I succesfully flashed an Armbian image to this emmc, and I can boot it without problems.

I tried to disable boot from SPI (placing a jumper on pins 25-23 on PI-2 connector) and I'm able to boot from eMMC (u-boot spl and u-boot are loaded from there).

I tried to compile a u-boot.itb from scratch using Ayufan's repo https://github.com/ayufan-rock64/linux-u-boot/ and I flashed it to eMMC using USB OTG cable and rkdeveloptool at offset 0x4000. But old bootloader stills boot, as my bootloader were flashed not in the right place.
Besides that, I can use rkdeveloptool only if I stop u-boot and then run command

rockusb 0 mmc 0

Additionally, only first of two scenarios reported here https://wiki.pine64.org/index.php/ROCKPr...e#OTG_mode is working, because if I disable SPI and eMMC with jumpers (so no bootloaders present) my board enter in MaskMode but rkdeveloptool does not work (seems unable to communicate with board).

What I'm doing wrong?

Thanks in advance, regards

mauro
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RockPro64 alpha software support bavay 2 221 05-22-2019, 01:33 PM
Last Post: frewind
  NEMS Linux for RockPro64 pineadmin 0 204 05-09-2019, 05:51 PM
Last Post: pineadmin
Big Grin RETRO GAMING: UPDATED RECALBOX FOR THE RK3399 ROCKPRO64 Mrfixit2001 18 1,556 04-27-2019, 11:09 AM
Last Post: Mrfixit2001
  Help at prompts during first boot. Diesel141 0 74 04-24-2019, 01:15 PM
Last Post: Diesel141
  RockPro64 Official Kernel Support ASIC 6 1,696 04-11-2019, 01:10 PM
Last Post: fosf0r
  RockPro64 won't boot. Faradn 6 263 03-28-2019, 04:18 AM
Last Post: karcsika
  Unable to boot ayufan images vman 0 97 03-27-2019, 02:06 AM
Last Post: vman
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 20 2,821 03-23-2019, 05:03 PM
Last Post: mara
  How to configure optee_os to build for rockpro64 yakman2020 1 159 03-06-2019, 03:49 PM
Last Post: tllim
  Arch Linux on RockPro64 mmatyas 24 6,316 02-27-2019, 06:07 PM
Last Post: mmatyas

Forum Jump:


Users browsing this thread: 1 Guest(s)