RockPro64 alpha software support
Although the RockPro64 has great specs in theory, it is often not usable for real applications because of the current state of software support.

First problem: USB3. No matter which kernel I've tried to use on my RockPro64 (Ayufan's 4.20, 5.0 as well as Armbian's 4.4.174 which is supposed to be directly based on Pine64's patches), there is no way to do any serious usage of USB3 storage. With all the dev. kernels, I end up with massive filesystem corruption after transferring a few Gb of data in/out of USB3. With kernel 4.4, transferring a few Gb of data leads to kernel crash. I can do some benchmarks (with hdparm for example), but not serious usage. My usb storage is a Samsung SSD connected through a JMicron JMS567 bridge (with Hardkernel's latest firmware), so this is very similar to the USB3/sata adapter sold by Pine64. Of course, the whole thing works very well on my laptop (running Debian Buster) where it can transfer 100's of Gb without a sweat. I've tried other USB cables, I've tried a laptop power supply (that can provide up to 6A), nothing can make the RockPro64's USB3 stable.

For mainline kernels (even with a thick layer of additional patches), several other major issues remain: there is no HDMI output (so if you're out of luck, your system is not connecting to the network and you don't have an easy way to check what it is doing on a connected screen). There is no proper handling of the big.little clusters (so the processes get distributed more or less randomly, leading to unsatisfying performance, see this previous post). There is no support for the DDR4 memory, it is handled as ddr3. The eMMC is handled as HS-200 instead of HS-400 (so less speed, see FreeBSD post and it is far from stellar anyway). The SPI memory seems to be half-buggy, half-slow (see lkml). The U-boot is still relying on an older version (from 2017) because of difficulties in making it work with the current mainline (see this post). There are some reports of problems with using the PCIe (see this thread ). Half of the time, the board does not reboot but gets stuck when shutting down.

I am wondering if somebody at Pine64 works with the community to help fix these problems... (this is not supposed to be mean, but a genuine question: is the community left by to fight by itself or is there some support from Pine64).

More on the topic of USB3: other boards with RK3399 experience the same issue (see
Luke, tllim, Can someone talk to Rockchip?
What did you format the filesystem as? Can you run a sequential fio write/read mix test and see if that gets it to error? What is the output of dmesg when you start seeing errors? What are the errors you described?


Edit: Found discussion @ that answers most of above
(05-24-2019, 03:57 PM)mknawabi Wrote: What did you format the filesystem as? Can you run a sequential fio write/read mix test and see if that gets it to error? What is the output of dmesg when you start seeing errors? What are the errors you described?


Edit: Found discussion @ that answers most of above

I've had fs either as ext4 or f2fs. I get the errors both when reading or when writing. But if i just run a simple benchmark (hdparm test), everything works. The bug is triggered when reading or writing large amount of data (a few Gb, I managed to trigger it today with ~900Mb). Depending on the kernel version, it ends up in system lockup or filesystem corruption or just that the usb drive is not reachable anymore (and can not be unmounted, so even a reboot is not going to be that much fun).

The discussion on Ayufan's github does not give any proper solution (in my mind, as I was part of this discussion, see that contains my dmesg output when the usb crashes): the only setup that works involves two usb hubs chained to isolate the drive, this is really a very hacky workaround and not any kind of real solution (it significantly degrades the performances and a board that needs this kind of setup can not advertise being USB3!). [Edit] please keep in mind that several people tried powered usb hubs, I tried a 6A power supply for the board, I blacklisted uas (and checked that it was blacklisted), nothing helped.

As I keep on seeing more and more RK3399 boards where the USB3 is not stable under load, it seems to me that the rk3399 has a bug and is actually not able to handle usb3 properly.

PS: regarding the other issues that are answered in your link, I could not find anything... this thread was only about usb3 (and did not bring up a solution), there is still no improvement to the big.little handling in dev kernels (since it works properly with the stable kernel, there will eventually be a solution), not for the other problems. But so far, the other problems are annoying but will be fixed at some point (it might take years though) while if the rk3399 has a buggy usb3 implementation, this won't be fixable.
Another version of the dmesg:
Finally!! This definitely has to do with USB suspend (see on a freshly booted system, no problems at all. On a system that has been running for a day (ie the USB had enough time to suspend), the problem is back with tons of error messages... So this explains why pine64 had trouble reproducing this issue!

[edit] The autosuspend is not the culprit... This has to do with some underpower, see this (long) thread. Sorry for the fake news and the disappointment!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Armbian is looking for maintainer for ROCKPro64 TRS-80 13 772 12-01-2021, 05:27 PM
Last Post: Ron Piggott
  Using the PCIe slot of ROCKPro64 as EndPoint mode nonoriri 1 141 11-20-2021, 10:53 AM
Last Post: fire219
  RockPro64 - HDMI and higher resolutions PakoSt 0 132 11-16-2021, 03:48 PM
Last Post: PakoSt
  Debian Bullseye & RockPro64: No tty consoles? Pete Tandy 9 769 11-08-2021, 02:33 PM
Last Post: TRS-80
  Vanilla mainline Debian 11 (Bullseye) on the RockPro64 Pete Tandy 21 1,969 11-06-2021, 06:42 AM
Last Post: Pete Tandy
  RockPro64 EDP in Armbian hannescam 2 407 10-15-2021, 09:07 AM
Last Post: hannescam
  Two Questions About Debian on RockPro64 publiclewdness 0 215 09-30-2021, 11:54 AM
Last Post: publiclewdness
  Overlays not loading at boot - ROCKPRO64 on Armbian rookieone 0 203 09-28-2021, 04:10 AM
Last Post: rookieone
  slave mode on Rockpro64 Radhika.gabani 1 975 09-22-2021, 05:35 AM
Last Post: mahtew
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 46 33,266 09-21-2021, 09:39 AM
Last Post: mara

Forum Jump:

Users browsing this thread: 1 Guest(s)