Rockpro64 boot issues
#11
my quess is theres something wrong with the board... from what your describing and the leaving it over night and working again makes me think there may be a bad cap someplace on the board thats not discharging properly so when going to restart its still seeing voltage present on the board thats interfering with the power up checks... computer motherboards do that as well at times and usually can be fixed by  recapping the bad caps but in the case these days its not worth the time to troubleshoot the board as they are pretty cheap.
  Reply
#12
I recently purchased a RockPro64 and am setting it up with an eMMC module and having the same issue.

I've tried armbian Streth and Bionic, ayufan's Stretch and Bionic, DietPi, and mrfixit2001 Debian. All have the same issue and some cannot even complete setup as a reboot is necessary.

The board's power LED will stay lit, but the while LED will not come back on and it can only be rebooted after removing power or a combination of hard reset and power buttons.
  Reply
#13
Same problem here. Cannot soft shutdown the board, it won’t wake up unless I unplug it for several minutes.
Edit : just noted that DC LED is still lit for time after unplug, when UART Link is plugged in.

UART console give me a stacktrace at shutdown :

Code:
[  OK  ] Reached target Power-Off.
[  68.482653] busb rockchip_usb2phy_otg_sm_work b_idle otg sm work 1
[  68.483207] busb HOST = 0,VBUS_EN=0,vbus_attached=1
[  68.483635] busb vbus_attach rphy->chg_state = 5
[  70.063361] xhci-hcd xhci-hcd.0.auto: Host halt failed, -110
[  70.070594] busb rockchip_usb2phy_exit
[  70.090867] xhci-hcd xhci-hcd.0.auto: Host halt failed, -110
[  70.090880] xhci-hcd xhci-hcd.0.auto: Host controller not halted, aborting reset.
[  70.092996] busb rockchip_usb2phy_exit
[  70.093809] reboot: Power down
[  70.094242] ------------[ cut here ]------------
[  70.094668] No atomic I2C transfer handler for 'i2c-0'
[  70.095278] WARNING: CPU: 0 PID: 1 at drivers/i2c/i2c-core.h:40 i2c_transfer+0xec/0x128
[  70.095997] Modules linked in: bnep joydev rc_cec snd_soc_hdmi_codec dw_hdmi_i2s_audio dw_hdmi_cec rockchipdrm dw_mipi_dsi dw_hdmi realtek analogix_dp cec hci_uart rc_core drm_kms_helper btqca hantro_vpu(C) btrtl rockchip_rga snd_soc_audio_graph_card syscopyarea rockchip_vdec(C) btbcm sysfillrect btintel sysimgblt bluetooth fb_sys_fops dwmac_rk v4l2_h264 videobuf2_dma_sg stmmac_platform stmmac v4l2_mem2mem videobuf2_vmalloc videobuf2_dma_contig pwm_fan videobuf2_memops snd_soc_simple_card mdio_xpcs videobuf2_v4l2 snd_soc_simple_card_utils phylink videobuf2_common ecdh_generic panfrost snd_soc_rockchip_i2s ecc rfkill snd_soc_es8316 snd_soc_rockchip_pcm rockchip_saradc rtc_rk808 dw_wdt rockchip_thermal gpu_sched drm drm_panel_orientation_quirks crypto_user gpio_keys
[  70.102171] CPU: 0 PID: 1 Comm: shutdown Tainted: G        C        5.8.1-1-MANJARO-ARM #1
[  70.102923] Hardware name: Pine64 RockPro64 v2.1 (DT)
[  70.103390] pstate: 60000085 (nZCv daIf -PAN -UAO BTYPE=--)
[  70.103902] pc : i2c_transfer+0xec/0x128
[  70.104267] lr : i2c_transfer+0xec/0x128
[  70.104628] sp : ffff80001004baf0
[  70.104936] x29: ffff80001004baf0 x28: ffff0000f6e2c740
[  70.105426] x27: 0000000000000000 x26: 0000000000000000
[  70.105916] x25: 0000000000000008 x24: 0000000000000000
[  70.106404] x23: ffff0000f6e2c740 x22: ffff80001004bc64
[  70.106894] x21: 0000000000000002 x20: ffff80001004bb48
[  70.107383] x19: ffff0000ebf45080 x18: 0000000000000010
[  70.107872] x17: 0000000000000001 x16: 0000000000000019
[  70.108360] x15: ffff0000f6e2cc58 x14: ffffffffffffffff
[  70.108849] x13: ffff80009004b817 x12: ffff80001004b820
[  70.109339] x11: ffff800012cb3000 x10: 0000000000000000
[  70.109828] x9 : ffff800012eee1d0 x8 : 00000000000003b7
[  70.110317] x7 : 0000000000000000 x6 : 0000000000000007
[  70.110805] x5 : 0000000000000000 x4 : 0000000000000000
[  70.111293] x3 : 0000000000000000 x2 : 00000000ffffffff
[  70.111782] x1 : d145c3e056344d00 x0 : 0000000000000000
[  70.112271] Call trace:
[  70.112510]  i2c_transfer+0xec/0x128
[  70.112853]  regmap_i2c_read+0x60/0xa8
[  70.113206]  _regmap_raw_read+0xd4/0x148
[  70.113573]  _regmap_bus_read+0x40/0x78
[  70.113933]  _regmap_read+0x64/0xf0
[  70.114261]  _regmap_update_bits+0xd0/0x110
[  70.114651]  regmap_update_bits_base+0x64/0x98
[  70.115067]  rk808_pm_power_off+0x70/0x90
[  70.115445]  machine_power_off+0x28/0x38
[  70.115813]  kernel_power_off+0x68/0x78
[  70.116173]  __do_sys_reboot+0x168/0x250
[  70.116539]  __arm64_sys_reboot+0x24/0x30
[  70.116917]  el0_svc_common.constprop.0+0x6c/0x168
[  70.117362]  do_el0_svc+0x24/0x90
[  70.117676]  el0_sync_handler+0x90/0x198
[  70.118041]  el0_sync+0x158/0x180
[  70.118351] ---[ end trace e1d67dcc515f1c25 ]---
  Reply
#14
More or less same here, was running stable (with reboots!) for several weeks but seems to have crashed yesterday when plugging in a USB hard drive. Since then no luck in getting a sign of life:
- green DC LED is on when plugged in (white LED for running board never worked)
- when plugged in ethernet port starts blinking (mostly only amber LED, sometimes also green LED)
- no output on the HDMI port

Long press on the power button turns it off (at least LEDs on ethernet port turn off), only green DC LED stays on.

Already tried a different SD card with new system with the same results. My only idea left is to try jumper cables for the boot order, otherwise I'm out of ideas. So in case there is anything else I could try, please let me know.
  Reply
#15
Are you using the same power supply for both RockPro64 boards?

If so the culprit could be the power supply and not the board.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Troubleshooting RockPro64 + Roshambo case SSD problems necoc.yaotl 1 123 11-30-2020, 11:10 PM
Last Post: necoc.yaotl
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 64 17,068 11-30-2020, 02:41 PM
Last Post: Waryle
  Rockpro64 RAM issues sausal 4 585 11-30-2020, 04:10 AM
Last Post: mstevens
  hardrock64/rockpro64 questions xmixahlx 3 802 11-26-2020, 03:13 AM
Last Post: Munchkin
  Rockpro64 CPU fan mikeD 30 14,321 11-25-2020, 09:28 AM
Last Post: eduapof
  No sound from rockpro64 audio jack. rahulsharma 2 900 11-18-2020, 04:46 AM
Last Post: Wizzard
  NAS kit with RockPro64 keuplat 0 123 11-10-2020, 11:57 AM
Last Post: keuplat
  Rockpro64 with PCI FC Card - Not booting (Sometimes) MSteam 1 217 10-25-2020, 07:42 PM
Last Post: MSteam
  RockPro64 SSD Expansion Board/SATA Shield as0zial 5 965 10-18-2020, 08:05 PM
Last Post: revoman
  RockPro64 Up and running with 10Gb NIC rapier1 3 474 10-04-2020, 11:44 PM
Last Post: zer0sig

Forum Jump:


Users browsing this thread: 1 Guest(s)