Reboot problem on latest ayufan and 4.4
#1
Reboot problem mentioned "Fixed" in 0.7.11 ( https://forum.pine64.org/showthread.php?tid=6706&highlight=0.7.11+reboot ) seems back again.

100% repeatable "sudo reboot" leads to hang on next kernel boot on both 0.7.11 and 0.7.12 pre-release.

System hangs after

Code:
[    0.002074] Console: colour dummy device 80x25
[    0.002493] console [tty0] enabled
[    0.002815] bootconsole [uart0] disabled
lines right before

Code:
[    0.003210] Calibrating delay loop (skipped), value calculated using timer frequency.. 48.00 BogoMIPS (lpj=96000)
line that appears next after cold boot.

mrfixit2001 kernel reboots fine as well as ayufan mainline (though the latter misses eMMC which is a showstopper).

Attaching a long log file containing normal boot and a hang after restart.

Strangely... another board (same RockPRO64 v2.1 4g) manufactured 1 month earlier doesn't have the issue. I tried swapping eMMC to make sure it's not a tainted distributive and the problem remained on the same board each time.

Any ideas?


Attached Files
.log   RockPRO64_reboot_hang.log (Size: 80.55 KB / Downloads: 30)
  Reply
#2
(03-02-2019, 04:37 PM)/dev/null Wrote: Reboot problem mentioned "Fixed" in 0.7.11 ( https://forum.pine64.org/showthread.php?tid=6706&highlight=0.7.11+reboot ) seems back again.

100% repeatable "sudo reboot" leads to hang on next kernel boot on both 0.7.11 and 0.7.12 pre-release.

System hangs after

Code:
[    0.002074] Console: colour dummy device 80x25
[    0.002493] console [tty0] enabled
[    0.002815] bootconsole [uart0] disabled
lines right before

Code:
[    0.003210] Calibrating delay loop (skipped), value calculated using timer frequency.. 48.00 BogoMIPS (lpj=96000)
line that appears next after cold boot.

mrfixit2001 kernel reboots fine as well as ayufan mainline (though the latter misses eMMC which is a showstopper).

Attaching a long log file containing normal boot and a hang after restart.

Strangely... another board (same RockPRO64 v2.1 4g) manufactured 1 month earlier doesn't have the issue. I tried swapping eMMC to make sure it's not a tainted distributive and the problem remained on the same board each time.

Any ideas?

After updating the latest kernel, there is the same problem to me...

kernel-5.3.0 : The system is holding for 20 ~ 30 seconds and booting is fine
kernel-4.4.193-rockchip-dev : The system is holding for 20 ~ 30 seconds. reboot... 
kernel-4.4.167-1213-rockchip-ayufan-g34ae07687fce : delay 1 second, booting is fine 

[ 0.003716] printk: console [tty0] enabled
[ 0.004114] printk: bootconsole [uart8250] disabled
-->> no response..
The system is holding for 20 ~ 30 seconds.
or reboot
Why does it happen?

1: kernel-5.3.0-rc4-dev
2: kernel-5.3.0-rc4-dev-memtest
3: kernel-4.4.193-rockchip-dev
4: kernel-4.4.193-rockchip-dev-memtest
5: kernel-4.4.167-1213-rockchip-ayufan-g34ae07687fce
6: kernel-4.4.167-1213-rockchip-ayufan-g34ae07687fce-memtest

Would you help me?

/etc/lsb-releaseBig GrinISTRIB_ID=Ubuntu

/etc/lsb-releaseBig GrinISTRIB_RELEASE=18.04

/etc/lsb-releaseBig GrinISTRIB_CODENAME=bionic

/etc/lsb-releaseBig GrinISTRIB_DESCRIPTION="Ubuntu 18.04.3 LTS"

/etc/os-release:NAME="Ubuntu"

/etc/os-release:VERSION="18.04.3 LTS (Bionic Beaver)"

/etc/os-release:ID=ubuntu

/etc/os-release:ID_LIKE=debian

/etc/os-releaseTongueRETTY_NAME="Ubuntu 18.04.3 LTS"

/etc/os-release:VERSION_ID="18.04"

/etc/os-release:HOME_URL="https://www.ubuntu.com/"

/etc/os-release:SUPPORT_URL="https://help.ubuntu.com/"

/etc/os-release:BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"

/etc/os-releaseTongueRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"

/etc/os-release:VERSION_CODENAME=bionic
/etc/os-release:UBUNTU_CODENAME=bionic

Regards,
Nick. 
  Reply
#3
Hi Nick, welcome to the forums. You have managed to dig up an old thread but no matter :-)

I have no problems rebooting with
Code:
$ uname -a
Linux rpro64.dukla.net 4.4.197-1236-rockchip-ayufan-g30faab37e339 #1 SMP Tue Oct 22 11:35:10 UTC 2019 aarch64 aarch64 aarch64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.10
Release: 19.10
Codename: eoan

I couldn't get 5.3.0-rc4 to boot at all.
* ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Started Bionic minimal - now "focal", Openbox desktop for general purpose daily PC.
* PinePhone BraveHeart daily driver with Mobian
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Slow/dead ethernet on (non-Ayufan) Linux Mainline (fixed) mmatyas 1 200 04-17-2020, 02:53 AM
Last Post: Thra11
  New Pre-release 0.10.9 from Ayufan Bullet64 0 232 04-09-2020, 06:49 AM
Last Post: Bullet64
  Problem with compiling ayufans linux kernel voegelit 4 412 01-14-2020, 07:38 AM
Last Post: patstew
  Ayufan 5.4.0 rc1 release - cannot boot Mentaluproar 2 557 01-05-2020, 02:39 PM
Last Post: mmiigg
  poor HDD performance - ayufan mainline OMV Mentaluproar 0 173 11-11-2019, 10:26 PM
Last Post: Mentaluproar
  DLNA and/or Plex problem with RockPro64 aldrick 10 632 10-20-2019, 10:34 PM
Last Post: aldrick
  Problem transferring rootfs to HDD alexvs 1 136 10-09-2019, 08:53 AM
Last Post: alexvs
  New Stable release from Ayufan (0.8.3) Luke 13 2,690 08-06-2019, 05:19 PM
Last Post: andyburn
  computelibrary build issue with latest ubuntu 18 image rahulsharma 0 109 07-08-2019, 09:25 AM
Last Post: rahulsharma
Question Configuring eDP port for Ayufan build ? AmroIb 2 395 07-03-2019, 03:39 PM
Last Post: ayufan

Forum Jump:


Users browsing this thread: 1 Guest(s)