[April 23] Q4OS ver 2.7-r5 - 1080P Pinebook / Pinebook |[Feb 26] Recalbox beta v3.1- Rock64 |[Feb 26] Recalbox 190222- RockPro64 / Minimal Debian by mrfixit2001 - 190222 - RockPro64 |[Feb 26] Q4OS 2.7-r2 - Pinebook 1080P / Pinebook |[Feb 22] Batocera Linux 5.20-20190121- RockPro64 | [Feb 19] Manjaro KDE 19.02 / Manjaro LXQT 19.02 - Pinebook1080P / Pinebook | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - RockPro

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Cant update package libgl1-mesa-dri
#1
Hi Just trying to keep my board updated with the Ubuntu releases, Im seeing a package in apt that I cant seem to upgrade:

> The following packages have been kept back:
>  libgl1-mesa-dri
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I tried apt-get --with-new-pkgs and after that failed also dist-upgrade, but the package still isnt installed...?
Reply
#2
(02-10-2019, 06:33 AM)scalextrix Wrote: Hi Just trying to keep my board updated with the Ubuntu releases, Im seeing a package in apt that I cant seem to upgrade:

> The following packages have been kept back:
>  libgl1-mesa-dri
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I tried apt-get --with-new-pkgs and after that failed also dist-upgrade, but the package still isnt installed...?


Have you tried doing the following:

Code:
apt-get -f install libgl1-mesa-dri
Reply
#3
(02-10-2019, 03:55 PM)evilbunny Wrote:
(02-10-2019, 06:33 AM)scalextrix Wrote: Hi Just trying to keep my board updated with the Ubuntu releases, Im seeing a package in apt that I cant seem to upgrade:

> The following packages have been kept back:
>  libgl1-mesa-dri
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I tried apt-get --with-new-pkgs and after that failed also dist-upgrade, but the package still isnt installed...?


Have you tried doing the following:

Code:
apt-get -f install libgl1-mesa-dri

This is the result:
"The following packages have unmet dependencies:
 libgl1-mesa-dri : Depends: libdrm-amdgpu1 (>= 2.4.90) but 2.4.89-1ayufan1 is to be installed
                   Depends: libdrm-freedreno1 (>= 2.4.92) but 2.4.89-1ayufan1 is to be installed
E: Unable to correct problems, you have held broken packages."
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Plex update on rock64 croquin 1 142 03-30-2019, 12:36 PM
Last Post: pfworks
  arm64 package missing - libjpeg8-dev Mentaluproar 1 94 11-12-2018, 10:33 PM
Last Post: evilbunny
  OpenMediaVault fails to update S265 3 1,352 08-23-2018, 06:28 AM
Last Post: S265
  After the update, it does not load zet_lab 3 249 06-05-2018, 09:57 AM
Last Post: cooker
  Apt-get update duplicate entry error Jxck 1 291 06-02-2018, 02:26 PM
Last Post: evilbunny
  Debian Plex Installation Package dejikocv 2 682 02-20-2018, 01:37 PM
Last Post: S3phi40T

Forum Jump:


Users browsing this thread: 1 Guest(s)