PINE64
Cant update package libgl1-mesa-dri - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: ROCK64 (https://forum.pine64.org/forumdisplay.php?fid=85)
+--- Forum: Linux (https://forum.pine64.org/forumdisplay.php?fid=88)
+--- Thread: Cant update package libgl1-mesa-dri (/showthread.php?tid=7156)



Cant update package libgl1-mesa-dri - scalextrix - 02-10-2019

Hi Just trying to keep my board updated with the Ubuntu releases, Im seeing a package in apt that I cant seem to upgrade:

> The following packages have been kept back:
>  libgl1-mesa-dri
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I tried apt-get --with-new-pkgs and after that failed also dist-upgrade, but the package still isnt installed...?


RE: Cant update package libgl1-mesa-dri - evilbunny - 02-10-2019

(02-10-2019, 06:33 AM)scalextrix Wrote: Hi Just trying to keep my board updated with the Ubuntu releases, Im seeing a package in apt that I cant seem to upgrade:

> The following packages have been kept back:
>  libgl1-mesa-dri
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I tried apt-get --with-new-pkgs and after that failed also dist-upgrade, but the package still isnt installed...?


Have you tried doing the following:

Code:
apt-get -f install libgl1-mesa-dri



RE: Cant update package libgl1-mesa-dri - scalextrix - 02-16-2019

(02-10-2019, 03:55 PM)evilbunny Wrote:
(02-10-2019, 06:33 AM)scalextrix Wrote: Hi Just trying to keep my board updated with the Ubuntu releases, Im seeing a package in apt that I cant seem to upgrade:

> The following packages have been kept back:
>  libgl1-mesa-dri
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I tried apt-get --with-new-pkgs and after that failed also dist-upgrade, but the package still isnt installed...?


Have you tried doing the following:

Code:
apt-get -f install libgl1-mesa-dri

This is the result:
"The following packages have unmet dependencies:
 libgl1-mesa-dri : Depends: libdrm-amdgpu1 (>= 2.4.90) but 2.4.89-1ayufan1 is to be installed
                   Depends: libdrm-freedreno1 (>= 2.4.92) but 2.4.89-1ayufan1 is to be installed
E: Unable to correct problems, you have held broken packages."