How to get a minimal Debian system started?
Hi guys,

I'm trying to migrate my homemade headless NAS/mediaserver from an old Odroid U2 board to the Rock64. However, I haven't found any micro SD card image that boots into a system that I can reach via the network. The board just doesn't show up in the overview of my router, nor can I find it using nmap from my desktop PC.

I've tried various images from ayufan's site (haven't found any other), but to no avail. I'm well familiar with tools such as xz and dd, and I know that micro SD cards aren't the most reliable of media. But I can mount the partitions of the flashed SD card just fine on my desktop PC, so that is not it.

So, any hints on how to proceed? I haven't tried to connect the board to a HDMI monitor (it's a bit awkward), but I think any system should at least be pingable via the network.

Have you tried Armbian? They have a Debian Stretch server (minimal image).

I am running on on a number of Rock64 boards and it works fine.

Sent from my iPad using Tapatalk
I grabed the minimum debian.
I grabbed the parrotsec alternative installer.
Bash , can grab 6 embeeded etc..

While this is next often bad: can bridge lan wifi virtualbox cards on windows bridge.

(Since our landlord , loves DS-HELL.. wont let us use cable/FIOS..)
this lets me bond wifi to rockpro64 while i get built in wifi screen linux kernel drivers etc. Using more Public sources of internet...

( the AT&T DSL @10 mins or less of uptime at a time... became annoyed im paying for toiletpaper but getting an empty roll..)

Then from thier i wont care.
As i can use xfce4 on windows10 via ssh ie moba uses x11 and can pull from cygwin/etc packages ie xfce4..
Or kitty on Sabayon(Gentoo) Linux to fwd x11 to screens. To send commands etc..

So far ive added xfc4 firefox cross-gcc-dev

Parrotsec embedded list of packages..

I need next to add mali drivers. And the wifi/bluetooth drivers.. ntfs3g (as my gentoo bins were pulled via dropbox and pushed to 2tb external. ) distcc +avahi..

To emmc, ive parted a bios grub , efi, boot, gentoo stage4 arm64 minimal to root, added normal swap part as doing emerge/compiles in chroot kernel.. etc.. )

Sent from my SM-N960U using Tapatalk
Well, it works now. Turns out that my SD card was defective, after all. Very frequent failure mode but I thought I had ruled it out. Thanks!

Possibly Related Threads…
Thread Author Replies Views Last Post
  rock64-debian-mrfixit-190531.img.xz : missing /usr/lib/dri/ popi 5 2,917 08-12-2021, 04:55 AM
Last Post: igorp
  Debian build from mrfixit2001 Luke 18 19,223 05-17-2021, 02:35 AM
Last Post: Wizzard
  Debian kernel stuck at 4.4.167 Enig123 5 3,375 12-29-2020, 12:57 PM
Last Post: kwinz
  Debian (Vanilla) on Rock64 and eMMC - how ? as365n4 4 3,362 09-21-2020, 04:33 AM
Last Post: as365n4
  pcsx rearmed on rock64 debian stretch does not go fullscreen RockyBoulder 2 3,018 05-09-2020, 03:15 AM
Last Post: lawrencejd
  Fedora 31 crosscompilation fdt problem mimics debian 888789 kf5zmi 2 2,819 01-20-2020, 12:25 PM
Last Post: kf5zmi
  Upgrading Debian Stretch image to Buster cosuhi 2 3,494 08-27-2019, 02:42 AM
Last Post: Malmgren
  Ayufan Debian Stretch Openmediavault 4 5G Wifi Not Connecting Poincare 0 1,685 03-26-2019, 07:28 PM
Last Post: Poincare
  GPU not working with Ubuntu and Debian builds kdawgpoker 10 9,588 12-19-2018, 03:53 PM
Last Post: va88
  Arch Linux minimal image w/ full HDMI output support hiccupstix 1 2,799 11-01-2018, 08:33 AM
Last Post: danboid

Forum Jump:

Users browsing this thread: 1 Guest(s)