Rock64 hangs without trace
#1
I have bought rock64 4GB board bundle (with charger and sd card).
I've initially pushed bionic lxde (0.6.4) with Etcher.
It launched smoothly, I've tried to open Youtube with Firefox - and this was first hang.
Restart
Again - this time youtoube page showed - it died after 3 sec of playing,
In few tries I was able to get, at best, something like 30 sec of playing (more like slideshow not real playing, even though CPU usage was not 100%).

Since then I've tried:
strech minimal
bionic minimal
armbian
openelec
with different (mostly latest versions)

I've tried new charger.
I've tried some other sd cards (inc. Samsung Evo).

The best results came with OpenElec being able to play up to 7 minutes of video before hang.

kernel.log shows nothing, syslog, dmesg , Xorg.. no errors, well, once I had error about fs issues (not clean after one of hard restarts) so now I know that nor bionic either strech are able to run gparted - instant hang also.

Does anyone had seen such issue?
What should else could I try to figure out reason?
  Reply
#2
(08-15-2018, 02:32 AM)szus Wrote: I have bought rock64 4GB board bundle (with charger and sd card).
I've initially pushed bionic lxde (0.6.4) with Etcher.
It launched smoothly, I've tried to open Youtube with Firefox - and this was first hang.
Restart
Again - this time youtoube page showed - it died after 3 sec of playing,
In few tries I was able to get, at best, something like 30 sec of playing (more like slideshow not real playing, even though CPU usage was not 100%).

Since then I've tried:
strech minimal
bionic minimal
armbian
openelec
with different (mostly latest versions)

I've tried new charger.
I've tried some other sd cards (inc. Samsung Evo).

The best results came with OpenElec being able to play up to 7 minutes of video before hang.

kernel.log shows nothing, syslog, dmesg , Xorg.. no errors, well, once I had error about fs issues (not clean after one of hard restarts) so now I know that nor bionic either strech are able to run gparted - instant hang also.

Does anyone had seen such issue?
What should else could I try to figure out reason?

I have the same issues with the said prebuild images and my rock64/4GB. Changed power supply, SDCard doesn't help.

So I started (cross-)compiling the ayufan kernel, disabling all the rock64pro-stuff und started with a plain devuan (1.0) image for the raspi3. Video playback was possible with youtube (480) and firefox, but cpu load was at 4.0.

At the moment I'm rocking alt-linux sisyphus aarch64 (with the ayufan kernel, xorg-armsoc, libmali, ffmpeg and gstreamer, libvpx (with neon optimize)) Local video-playback works with low cpu load (0.3 yay!), but mpv is killed from time to time. Video-playback from my ftp-server still hangs after 3-4 seconds. Firefox 61 plays youtube at cpuload of 2.0-3.0 at 720p stable enough for music videos.
With compiling a lot on the box I noticed that every parallel build (-j3 or -j4) failed with segmentation fault and compily xorg with -j1 is no fun at all, but completed at least.

I tried cpuburn-a53 and stopped after reaching temperatures of 90ᵍC. After that I setup the rk3328 to 1GHz max.
I tried memtest, but this did run multiple times over 2 hours without an error.

So yes, I have the same issues, but no clue about the reason, sorry.
  Reply
#3
Not sure how important the Distro that you run is but Stretch from this source is running for me 24/7 for the last three months without any issues. https://www.armbian.com/rock64/
  Reply
#4
(08-21-2018, 05:53 AM)Rocklobster Wrote: Not sure how important the Distro that you run is but Stretch from this source is running for me 24/7 for the last three months without any issues. https://www.armbian.com/rock64/

I don't think it is the distro. I have the network-video-playback problem with various ayufan-images and even with android. The parallel compiler problem is happening with different gcc-versions from 4.8 over 6 to 7.2.1.
  Reply
#5
I did not had time last weeks to keep checking things but I guess I was not clear here.
Network playing or playing at all is not an issue.
It is that my rock64 is simply not usable.

Any use case for this (like network playing, like movie playing even simple gparted) is failing without any logs.

I started some memtest (nothing running, just start memtest after reboot) and it fails all the time.

Should I consider call for replacement ?
  Reply
#6
Well, I did call my supplier here in germany (Humberg Computertechnik), told them what happened and although I bought the rock64 six mounth ago, it was absolutely no problem to get a replacement.
I had a nice chat where they told me, that in very rare cases (less than 1%) the memory of the SBC can be faulty. So - yes - call your supplier.
  Reply
#7
Just to close the topic.

Pine support suggested to try Android 7.1 build as it is used by factory to test boards.
Obviously mine was not tested enough Wink - because Android 7.1 was barely loading.
Outcome - support said that this is hardware issue most probably.

I bought it in May and there is no warranty any longer - so shit happens Smile

Solution - test your board as soon as possible.
  Reply
#8
That is pure shit. Minimum warranty on faulty unit would be 1 year. Chase your supplier and remind him of that.
  Reply
#9
(09-13-2018, 02:18 PM)Rocklobster Wrote: That is pure shit. Minimum warranty on faulty unit would be 1 year. Chase your supplier and remind him of that.

Well - I bought it directly from pine shop, they have statement on website "30 days warranty"...
  Reply
#10
Contact the Pine supplier in China. They have exchanged a number of boards that have been found to be faulty.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Plastic storage box for Rock64 matwey 0 17 Today, 07:48 AM
Last Post: matwey
  Another non-booting ROCK64 SuburbanDad 7 214 Yesterday, 04:14 AM
Last Post: Rocklobster
  Rock64 v2 network issues alephnull 1 95 06-07-2019, 03:30 PM
Last Post: alephnull
  Rock64 v3 - POE P1V 1 100 06-07-2019, 12:24 AM
Last Post: tllim
  Rock64 v3 and SD-Cards Humberg 11 1,360 06-06-2019, 12:48 AM
Last Post: igorp
  Download RetroPie for your Rock64 CiniCraft 3 618 06-01-2019, 08:02 PM
Last Post: x79ftw
Sad Bad first experience with rock64. Performs worse than my pi :( ekg 9 1,272 05-24-2019, 09:42 AM
Last Post: thatchunkylad1989
  Python GPIO Library for the Rock64 (R64.GPIO) Leapo 32 11,939 05-12-2019, 02:46 PM
Last Post: tllim
  Rock64 LCD compatibility for linux. AmroIb 0 101 05-04-2019, 09:09 PM
Last Post: AmroIb
  rock64, compile problems "illegal instruction", "memory fault" -> ddr_333Mhz? hunderteins 4 234 04-25-2019, 02:26 PM
Last Post: mcerveny

Forum Jump:


Users browsing this thread: 1 Guest(s)