Rock64 board not working, no HDMI no Ethernet.
#1
Hello,

I have a rock64, I'm using the ARMbian onto the device, I cannot tell if this is working or not.

- Green light power goes on.(right side)
- PWR led on.
- STBY led on.
- Ethernet connector shows activity.

This is what I get:
- No HDMI output, I tried with two different monitors.
- I connect an ethernet cable directly to the router and I cannot see the device scanning the LAN.

Since I don't have the serial console cable, is there any way to debug if this is really working since I cannot tell.

- Is the device doing an DHCP automatically?
- Do you recommend any other distribution that is more stable or has support?

Regards.
  Reply
#2
(12-21-2021, 05:34 AM)EDited Wrote: Hello,

I have a rock64, I'm using the ARMbian onto the device, I cannot tell if this is working or not.

- Green light power goes on.(right side)
- PWR led on.
- STBY led on.
- Ethernet connector shows activity.

This is what I get:
- No HDMI output, I tried with two different monitors.
- I connect an ethernet cable directly to the router and I cannot see the device scanning the LAN.

Since I don't have the serial console cable, is there any way to debug if this is really working since I cannot tell.

- Is the device doing an DHCP automatically?
- Do you recommend any other distribution that is more stable or has support?

Regards.

The LED sequence is a real crap shoot on these boards. Mine shows solid green and one second pulsing red.

After what seems like it has booted have you checked your LAN to see if the board has been recognised and has a reported address.Use one of those network Analyzer apps on your mobile phone to see it.

Next I'd look at the original image you downloaded ensuring it was properly extracted and burned to the SD card. Try the process again to double check. Next I'd try a different SD card.

Poor quality power supplies giving under voltage have been know to cause problems with the board booting.

Try the above first before dealing with the HDMI issue. When burning a new Armbian image try using the server version first before attempting the desktop version to check your board is actually working properly.
  Reply
#3
Rocklobster covered the basics already, I just wanted to add that if you are going to be playing with SBC, it is a very good idea to get yourself a serial adapter. They are a tremendous help in several ways; not just when things go wrong, but also for testing, development, etc. And they are only a few bucks each. In fact get 2 or 3, "just in case." Wink
Cheers,
TRS-80

What is Free Software and why is it so important for society?

Protocols, not Platforms

For the most Linux-y experience on your Linux phone, try SXMO!

I am (nominally) the Armbian Maintainer for PineBook Pro (although severely lacking in time these days).
  Reply
#4
(12-21-2021, 05:34 AM)EDited Wrote: Hello,

I have a rock64, I'm using the ARMbian onto the device, I cannot tell if this is working or not.

- Green light power goes on.(right side)
- PWR led on.
- STBY led on.
- Ethernet connector shows activity.

This is what I get:
- No HDMI output, I tried with two different monitors.
- I connect an ethernet cable directly to the router and I cannot see the device scanning the LAN.

Since I don't have the serial console cable, is there any way to debug if this is really working since I cannot tell.

- Is the device doing an DHCP automatically?
- Do you recommend any other distribution that is more stable or has support?

Regards.


@EDited I have a Rock64 that was running fine until the latest updates on the os (Arch/Manjaro/Plasma). I submitted a post in another location to that effect. I can reimage with an older version, and it will run until updates are attempted, then it's DejaVu. This has been going on for me for some time, on the Rock 64 as well as a Rock3A made by Raxda, so I believe it is not the hardware, especially since I can roll back to an older version and it works. Since I only know to post it on the forums, I can't say how to get help, or if anyone cares. Good Luck.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 No Audio @ Debian 12 dmitrymyadzelets 2 449 04-08-2024, 06:47 AM
Last Post: dmitrymyadzelets
  OpenWRT on the Rock64 CanadianBacon 14 8,706 04-03-2024, 08:48 AM
Last Post: helpmerock
  Rock64 bricked shawwwn 7 5,895 03-17-2024, 12:22 PM
Last Post: dmitrymyadzelets
  Rock64 won't boot luminosity7 10 4,444 03-16-2024, 08:33 AM
Last Post: dmitrymyadzelets
  Rock64 doesn't boot dstallmo 1 401 03-16-2024, 08:29 AM
Last Post: dmitrymyadzelets
  How well does Rock64 deal with HDR and Atmos on Kodi? drvlikhell 3 2,027 04-29-2023, 04:24 AM
Last Post: newestssd
  Latest Manjaro Update fails HDMI Flagtrax 0 606 01-06-2023, 10:47 AM
Last Post: Flagtrax
  ROCK64 v3 can it boot from USB? Tsagualsa 4 2,221 11-29-2022, 11:31 AM
Last Post: Macgyver
  rock64 v3 spiflash Macgyver 0 797 11-28-2022, 02:18 PM
Last Post: Macgyver
  my rock64 dosen't work rookie_267 0 996 10-07-2022, 07:50 PM
Last Post: rookie_267

Forum Jump:


Users browsing this thread: 1 Guest(s)