How install Qbittorrent on Debian?
#1
How install Qbittorrent on Debian?
I try but end-up with errors
  Reply
#2
Well it would help for a start if you describe what you did and what the errors are :-)
Come have a chat in the Pine A64 IRC channel >>
  Reply
#3
(03-14-2018, 08:36 AM)xalius Wrote: Well it would help for a start if you describe what you did and what the errors are :-)


I folow this tutorial https://www.tecmint.com/install-qbittorr...-in-linux/
the error:


Code:
[email protected]:~$ sudo apt-get install qbittorrent
[sudo] password for rock64:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 qbittorrent : Depends: libboost-system1.65.1 but it is not installable
               Depends: libqt5core5a (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5gui5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5network5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libtorrent-rasterbar9 (>= 1.1.6+git20180215.01c41fadcf+patched-configure) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:~$
  Reply
#4
Anyone?
  Reply
#5
(03-14-2018, 08:57 PM)Callisto Wrote:
Code:
               Depends: libqt5core5a (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5gui5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5network5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libtorrent-rasterbar9 (>= 1.1.6+git20180215.01c41fadcf+patched-configure) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:~$



It looks like you half upgraded packages, and then decided to set the apt repository to an older version.

The quick fix would be to re-flash an image. Otherwise you need to downgrade/upgrade to a later version.
  Reply
#6
Right now this image for rock64 board come with half upgraded packages:
http://wiki.pine64.org/index.php/ROCK64_...0171222.5D
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pine64 Debian Stretch/mainline [4.14.7] CallMeFoxie 48 16,822 1 hour ago
Last Post: amp
  Digital drawing tablet Huion - proper drivers install janeku 20 4,244 05-19-2019, 09:24 PM
Last Post: xinhua
  Debian 10 (Buster) in deep freeze - includes support for Pine64+ amp 4 114 05-18-2019, 02:24 AM
Last Post: amp
  Installing Debian with the Debian Installer (Buster RC1) amp 0 61 05-04-2019, 12:05 PM
Last Post: amp
  Script to build pure Debian images for Pine64+ amp 1 67 05-01-2019, 09:09 PM
Last Post: tllim
  Debian (Stretch) for Pine64-LTS wgray 2 166 04-04-2019, 09:54 PM
Last Post: wgray
  Is there just one fuctioning Debian Desktop image? KNERD 7 1,208 03-29-2019, 02:00 AM
Last Post: desai_amogh
  (ARCHIVED) Debian Jessie Images (3.10.102 BSP Kernel) New Release lenny.raposo-pine64.pro 259 100,784 05-21-2018, 06:30 AM
Last Post: Luke
  eMMC module as storage for Debian/Android le_moose1 1 394 03-25-2018, 08:11 PM
Last Post: KNERD
  Debian Pine64 h264/5 Video under vlc ozcy 5 1,245 03-16-2018, 04:28 AM
Last Post: dani

Forum Jump:


Users browsing this thread: 1 Guest(s)