Won't boot with GPS breakout attached
#1
I'm fairly new to the Rock64 boards and recently decided it would be fun to play around with one. I bought the 2GB RAM version plus 16GB eMMC and power adapter. I used Etcher to flash ayufan's minimal artful arm64 image which worked great! It booted and I plugged in the network and was able to shell in just fine. I ran into problems, however, when I attempted to attach this GPS board to it: https://store.uputronics.com/index.php?r...duct_id=81. After plugging it all in I can see that the GPS board powers up just fine and even acquires a GPS signal and starts the TIMEPULSE LED going...BUT the main board doesn't boot. The white power LED is on and the red standby LED is solid with the green LED on the left side of the ethernet jack on but it doesn't appear to actually boot at all. Any suggestions?

Note: my first thought was that the expansion board could be drawing too much power but I looked at the spec sheet for the ublox MAX-8Q and it only draws up to a max of 65mA. The power supply supposedly outputs up to 3000mA which I can only imagine should be sufficient. The expansion board is designed for any of the Raspberry Pi+ models and when I look at the traces from the ublox chip to the header on the GPS board it seems that the pins do match up where they should.
#2
you might get a hint from opening a terminal and enter the command dmesg that should show you a fairly complete log of the boot that is if it does attempt to boot. otherwise you might do a serial console which should show all the action after applying power up to the point that it might be crashing or locking up boot.
#3
If it would boot at all then dmesg would be helpful but it doesn't seem to come up at all. I thought about the serial console but the problems are: 1) I haven't had luck getting it to work with my UART adapter (CP2102) very well - just get gibberish (yes, I know it's 1500000 8N1....doesn't make a difference) and 2) It boots fine without the GPS board attached and wouldn't likely give me anything useful that way but the GPS board takes over the pins I need to attach to for the console if I have it attached - assuming I could even get the serial console to work.
#4
guess what? rock64 has 3 uarts. i suggest you read this thread. it won't give you the answer but it will point you in the right direction.
https://forum.pine64.org/showthread.php?...&pid=32693

a side point is any gps card that will not let you select optional uart connections is cheap. so find out which uart the gps board wants to use and then learn how to get access to another uart. if it is not possible to set up a serial console on an optional uart and your gps card can only use one uart then not sure what you do next.


Possibly Related Threads…
Thread Author Replies Views Last Post
  boot hdd usb3 philipe 1 655 01-27-2021, 02:12 PM
Last Post: tllim
  Libreelec Rock64 - 4GB no boot spiker15 3 1,528 11-02-2020, 12:36 AM
Last Post: wilsonYan
  Rock64 - boot helpmerock 2 1,261 10-08-2020, 01:29 PM
Last Post: helpmerock
  No boot up after power on Whoopsadaisy 4 2,255 09-26-2020, 05:14 PM
Last Post: simonsouth
Bug u-boot (forks) status mcerveny 14 7,459 08-27-2020, 01:44 PM
Last Post: globaltree
Sad No boot, garbage console text and blinking red light ... jean_bruder 2 1,497 07-19-2020, 08:37 AM
Last Post: jean_bruder
  Graphical boot manager john3voltas 0 739 03-25-2020, 02:27 PM
Last Post: john3voltas
  doesn't boot, no video cjyar 7 2,890 11-15-2019, 03:45 PM
Last Post: ab1jx
  Unable to boot from SPI stevefan1999 4 2,563 05-01-2019, 04:47 PM
Last Post: rhens1
  No Boot, Red Green and White flash at 1 sec intervals wesleykonrad 2 1,718 01-28-2019, 11:54 PM
Last Post: wesleykonrad

Forum Jump:


Users browsing this thread: 1 Guest(s)