How can I reliably get battery status on pinebook
#1
Hi,

thanks to the great Q4os developers I now have a quite decent Debian Stretch system running.  After I managed to flash the eMMC with Q4os I simply editet sources.list to point to Stretch instead of Jessie and did a dist-upgrade.   I needed to fiddle a bit with the graphics since X was lost but rebuilding libump and xf86-video-fbturbo under Stretch did the trick.  (I'm a Debian developer and might consider creating at least an official libump package - need to check the license of fbturbo whether it is acceptable in Debian.)

I now try to get some reliable information about the battery status.  I'm using xfce4 but the battery plugin always says the battery is empty (even if I get a desktop notification that the battery is full when plugging in power adapter.

The command acpi does not work.

How do others check the battery status on pinebook?

Kind regards

        Andreas.
  Reply
#2
Does q4os also have the 'sudo pine64_health.sh' script? Because there you can see it reliably.
  Reply
#3
(09-19-2017, 02:00 PM)joekinley Wrote: Does q4os also have the 'sudo pine64_health.sh' script? Because there you can see it reliably.

If it doesn't have that script, you can download it from here. Or if you just want battery info, you can use this script that I wrote. I run it on the pinebook with using a screenlets terminal widget to have it stuck on the desktop for when I'm testing stuff and want to seem some more stats than just 'how charged / how flat' is the battery. Wink ACPI doesn't work on the pine64/pinebook as ARM doesn't have ACPI... instead you query the '/sys/class/power_supply/battery/' path for current usage, voltage, and charging or discharging, and percentage charge.
  Reply
#4
Code:
[battery]
label=
command=tail "/sys/class/power_supply/battery/capacity"

I add this to my i3block cfg file and it is working perfect for me
  Reply
#5
I run a Debian-based distro also, and 'acpi' and 'acpi -V' would mot work until I installed  it with

'apt-get install acpi'.   [You may have to use 'sudo apt-get install acpi']

'acpi -V' (note the space) is the "verbose" version, which also gives you the current health of your battery, i.e., percentage capacity now vs. original design (new) capacity. Great command-line utility to have.
  Reply
#6
I have no particular solution for your OS and xfce4, but can point you to my solution for LXDE/lxpanel on Armbian 5.86 with a very similar problem:
Display battery charge value with LXDE and lxpanel

Moreover, the current Armbian release 5.86 with Ubuntu bionic utilizes xfce as well. The power manager of xfce displays battery charge information correctly, so that you could check whether you find your solution in the internal configuration of xfce on Armbian 5.86.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Reset User or Factory Reset PineBook Linux 11.6" pittman64 1 73 07-07-2020, 11:26 PM
Last Post: tllim
  Pinebook is going the way of Betamax? trigger 9 1,085 06-21-2020, 03:08 PM
Last Post: secristr
  Pinebook Pro (i3 WM): Confirm Shutdown on Power Button etothepii 2 174 06-07-2020, 11:18 AM
Last Post: xmixahlx
  Slarm64 on Pinebook [Slackware Arm - 64 bit] KRT 10 1,104 06-04-2020, 11:31 PM
Last Post: KRT
Information Manjaro ARM for Pinebook erchache2000 75 10,252 05-10-2020, 02:06 PM
Last Post: telle
  pinebook black screen when booting with "different power mode than last used" penzoiders 12 1,589 04-27-2020, 06:27 AM
Last Post: tophneal
  Kali Linux for the Pinebook Luke 1 465 03-03-2020, 05:01 AM
Last Post: e-minguez
  Anyway to run Teamviewer for ARM/Pinebook? Ekkaia 8 3,812 01-16-2020, 08:51 PM
Last Post: dhosh
  Pinebook Wlan Driver does not work properly matze79 2 298 12-15-2019, 02:50 AM
Last Post: matze79
  Display battery charge value with LXDE and lxpanel wlad 1 554 12-04-2019, 03:36 AM
Last Post: pnts-se

Forum Jump:


Users browsing this thread: 1 Guest(s)