Armbian - Xenial Desktop (Pinebook)
#35
^ fwiw, armbian is not old & outdated - it's based on ubuntu 16.04, which is still the current LTS version and supported until April 2021: https://wiki.ubuntu.com/Releases

But it's interesting you were experiencing similar trouble. Were you refering to the screenshot i took?

(12-29-2017, 07:24 AM)dahni Wrote: i'm having problems with video playback after a not-so-recent (i think i did it in october) upgrade.

before that, all video would look normal, and most video would playback with only minimal framedrop.

now, most only display like this
this is with mpv, and its output is something like this - looks ok to me???
but the problems are abundant with all video formats and media players (mplayer too, and i spent a good while playing with VLC's settings).

i tried:

downgrading kernel back to 3.10.105 version == downgrading packages linux*pine* to version 5.31.
it helped a little - i was able to watch a few very old & lo-res episodes.

then i found this: Video playing will break on sunxi legacy unless adding cma=96M to kernel boot parameter, so i undid the downgrade and added that option to /boot/boot.cmd & recompiled, after which i could see those 96M in 'dmesg|grep -i cma' (was 64M before).
but it did not help at all, the situation was just as bad as before the kernel downgrade!

what to do?
(12-29-2017, 11:14 AM)dkryder Wrote: pine64 is sun50i, probably not covered by that change, but i'm not sure what effect "cma=96M" would have on pine64. but that offers no help to your issue. video can usually be improved by using a good quality 32gb or larger sd card, using emmc, or move root filesystem to ssd or 7200rpm hd. depending on software used there may be config settings that can also help. but those color problems are very strange. are using a dvi monitor?

finally i get some time to come back to this!
i have little more to offer by way of troubleshooting:
The problem (see screenshot from previous post, garbled colors) seems to only occur with some old AVIs and MP4s.
I was hoping to narrow it down to one video codec, but not sure. maybe Xvid.
Of the problematic videos, most still play with mplayer (but in software decoding i guess, because the system load is larger), but not in mpv.
but there's a few cases that show the same problems in all 3 players installed: mpv, mplayer, vlc.
here's the image one more time.

mpv seems to indicate hardware decoding (vdpau) for all affected videos - although it is a little unclear whether it couldn't also refer to audio. i think not. look at the output.

so that would make it clearly a problem with the graphics chip & driver.

i have tested remote & local videos, but the issue is the same (only more buffering problems with remote video, no surprises there).
  Reply


Messages In This Thread
RE: Armbian - Xenial Desktop (Pinebook) - by Luke - 11-11-2017, 08:15 AM
RE: Armbian - Xenial Desktop (Pinebook) - by dahni - 02-25-2018, 12:43 AM
RE: Armbian - Xenial Desktop (Pinebook) - by Luke - 02-25-2018, 09:50 AM
RE: Armbian - Xenial Desktop (Pinebook) - by Luke - 02-26-2018, 01:53 PM
RE: Armbian - Xenial Desktop (Pinebook) - by Luke - 08-10-2018, 04:54 PM
RE: Armbian - Xenial Desktop (Pinebook) - by Luke - 12-10-2018, 02:27 PM
RE: Armbian - Xenial Desktop (Pinebook) - by Luke - 12-13-2018, 02:30 PM
RE: Armbian - Xenial Desktop (Pinebook) - by WZ9V - 01-08-2019, 08:07 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
Information Manjaro ARM for Pinebook erchache2000 87 16,512 10-13-2020, 09:49 AM
Last Post: Corkonian
  Slarm64 on Pinebook [Slackware Arm - 64 bit] KRT 13 3,052 10-03-2020, 04:01 AM
Last Post: mara
  Pinebook Pro (i3 WM): Confirm Shutdown on Power Button etothepii 3 752 08-14-2020, 06:03 AM
Last Post: loblik
  Manjaro sway profile for pinebook e-minguez 3 545 07-21-2020, 03:25 PM
Last Post: jezek
  Reset User or Factory Reset PineBook Linux 11.6" pittman64 1 624 07-07-2020, 11:26 PM
Last Post: tllim
  Pinebook is going the way of Betamax? trigger 9 2,024 06-21-2020, 03:08 PM
Last Post: secristr
  pinebook black screen when booting with "different power mode than last used" penzoiders 12 3,071 04-27-2020, 06:27 AM
Last Post: tophneal
  Kali Linux for the Pinebook Luke 1 949 03-03-2020, 05:01 AM
Last Post: e-minguez
  Anyway to run Teamviewer for ARM/Pinebook? Ekkaia 8 4,908 01-16-2020, 08:51 PM
Last Post: dhosh
  Pinebook Wlan Driver does not work properly matze79 2 655 12-15-2019, 02:50 AM
Last Post: matze79

Forum Jump:


Users browsing this thread: 2 Guest(s)