Android 7.1 (Pinebook) 0.3.10-66 [Sep 19] | Android 7.1 (PINE A64(+)) 0.3.10-66 [Sep 19] | Android 7.1 (SOPINE) 0.3.10-66 [Sep 19] | Linux Images (ROCK64) 0.5.9-104 [Sep 13] | Android Images (ROCK64) 0.3.4-86 [Sep 13] | PINE64 Installer v2.0.0-beta.3 [Sep 12] | Android Images (ROCK64) 20170809 [Aug 24] | Debian Jessie LXDE (ROCK64) 20170809 [Aug 16]

Getting Started | Visit the WIKI | IRC Logs | Forum Rules/Policy


Wifi module able to share ethernet connection? Connection is unstable!
#1
Hi,

First of all, thanks to longsleep, lenny, and others for their work to provide working images for the pine64.

Now running the pine64+ 2GB with the wifi/BT module. After several trials, both latest debian-mate and ubuntu-mate seems to work fine after I changed the HDMI cable from 1m to 0.5m.
The 1m cable was only working with longsleep 20160507-1 image, and always failed to output the HDMI signal with the newest kernel Undecided
The 0.5m seems to be fine with the latest images :-)

I have a question regarding the capabilities of the wifi module: can I connect to the pine64 through wifi from a phone and share the pine ethernet connection or are the module capabilities limited to connect the pine64 to already existing wifi networks?
I would like to set the 1st option, if possible, in order to connect my phone through wifi to the pine64 that is already wired connected...

Thanks in advance for any help and advice!
Cheers!
Reply
#2
Creating an access point should be possible with any wifi interface on Linux nowadays, nothing specific to the hardware. As long as the firmware for the Realtek chipset does Ad-hoc or master mode you should be good.
Come have a chat in the Pine A64 IRC channel >>
Reply
#3
Yes, it's what I thought... but no luck so far!

I can see other wifi networks (likely from the neighbourhood).
I tried several combinations to add a wifi network but I could not see the new SSID when my phone was scanning.
I also tried to change the wifi management from false to true in the network manager config file: I then saw two times the list of wifi networks, but could not create one visible from my phone.

I will try the following next:
http://ubuntuhandbook.org/index.php/2014...ot-ubuntu/

Update:
Used the 3rd method from the above link "Using Unity’s Default Network Manager with a little hack".
Its working now with my android phone, but for some reason it does not connect using an iphone: the wifi network is recognized but the password is always rejected?!?!
Reply
#4
I've figured out Access Point mode (mostly followed this post https://help.ubuntu.com/community/WifiDo...ccessPoint)
it is visible from iPhones, Androids, MacBook, I have not tested actual communication yet, but i do see AP in the air and can connect to it
OS image is xubuntu longsleep , WiFi card ordered from pine64 kickstarter

my /etc/hostapd/hostapd.conf contains this
auth_algs=1
beacon_int=50
channel=3
country_code=US
disassoc_low_ack=1
driver=nl80211
hw_mode=g
ht_capab=[HT40+][HT40-][SHORT-GI-40]
ieee80211d=1
ieee80211n=1
interface=wlan1
require_ht=0
rsn_pairwise=CCMP
ssid=myaccesspointname
wmm_enabled=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_passphrase=0123456789
Reply
#5
Another thing: after a fresh start the wifi is working but the connection is lost after few minutes; the hotspot does not appear anymore on the phone in the list of available wifi networks. Need to restart to get it back, or there might be a command to restart the network without restarting the pine?!?!

Thanks vigor, I will check that ;-)
Reply
#6
(08-05-2016, 07:07 PM)cr2016 Wrote: Another thing: after a fresh start the wifi is working but the connection is lost after few minutes; the hotspot does not appear anymore on the phone in the list of available wifi networks. Need to restart to get it back, or there might be a command to restart the network without restarting the pine?!?!

Thanks vigor, I will check that ;-)

I have to say my pine64 access point is pretty solid, it allocates dhcp addresses 10.0.0.1/24 and i connect to it via http and ssh - no problem. I left it running overnight and it was still up this morning.

I noticed - you have to be 7 to 15 feet away from Access point (Pine64) then connection is stable, if you are too close - it does not work at all or unstable.

One thing i noticed about network stack in general, i have to comment out all lines in /etc/network/interfaces.d/eth0
if the ethernet wire not plugged in, then wifi works stable after boot. I am not sure how to handle that, but i would like to run it with only two wifi interfaces - no ethernet wires. The pine64 will be located where there is no wires.
Reply
#7
No time to try something new...
I hope that the method described in your post is more stable than the one I found previously ;-)
Need some quiet time to try out!
Reply
#8
Tried again the wifi connection with 2 other devices. Same problem: can create the access point, can see it, can connect to it from 3 different devices and can share the wired connection, but the wifi connection is unstable and the access point is not visible anymore after few hours.
Is there a way to log/monitor the wifi activity over time?
Reply
#9
I am not entirely sure it will help with pine64, like i said before mine wifi in Access point mode works stable with Ubunutu, but in Raspberry pi disabling power management helps to keep wifi up:

sudo vim /etc/modprobe.d/8192cu.conf
and add the following line :

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

original here : http://www.raspberrypi-spy.co.uk/2015/06...pberry-pi/
Reply
#10
I've attempted to get a hotspot running on my Pine64 2GB board (Ubuntu longsleep, but I forget what image version I installed from), first following the same instructions I followed to run a hotspot on my Raspberry Pi (http://www.movingelectrons.net/blog/2016...ry-pi.html), then modifying my hostapd.conf to match the one posted by vigor above in this thread. The hotspot appears to be running, but I can't seem to connect to it. I've tried connecting with an Android tablet and phone, and with a Macbook Pro. They all see it, but just will not establish a connection.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Create a WiFi hotspot on Debian 8 JulianM 1 2,597 09-11-2017, 12:53 AM
Last Post: alex17pat
  Pine64 doesn't recognize Wifi/BT Module clobeca 3 131 07-13-2017, 08:58 PM
Last Post: MarkHaysHarris777
  Better WiFi/BT module? fonix232 17 1,051 02-13-2017, 04:38 AM
Last Post: xalius
Sad wifi direct bj_jung 2 702 12-29-2016, 10:26 AM
Last Post: happytuna
  Enabling wifi c4tich 10 1,847 12-28-2016, 02:22 PM
Last Post: workaccountbro
  WIFI & Bluetooth? 7777777 14 5,659 12-24-2016, 05:01 AM
Last Post: Toriless
  RF connector on wifi\bt board kb1qzh 1 342 12-15-2016, 06:36 PM
Last Post: tllim
  Losing WiFi Connection on Android Everytime mribunal 4 650 10-10-2016, 06:38 PM
Last Post: mribunal
  Unable to activate wifi on Linux smouton 5 1,441 09-17-2016, 10:35 PM
Last Post: MarkHaysHarris777
  Trouble getting Wifi board to work with Remix OS Seussman71 6 3,278 07-17-2016, 11:47 PM
Last Post: grantos

Forum Jump:


Users browsing this thread: 1 Guest(s)