Try to boot armbian 22.02 on SoPine baseboard
#1
Hello,

I try to boot Armbian on the SoPine with baseboard from a eMMC module.

From armbian/pine64, I try some Arbian images.
I get this error:
Quote:U-Boot SPL 2022.07-armbian (Nov 30 2022 - 10:45:59 +0000)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###

So I try this specialized image Armbian_22.11.1_Pine64so_bullseye_current_5.15.80.img.xz.
But it's stuck at the `armbi_root: clean` line:
Quote:U-Boot 2022.07-armbian (Nov 30 2022 - 10:45:55 +0000) Allwinner Technology

CPU:  Allwinner A64 (SUN50I)
Model: SoPine with baseboard
DRAM:  2 GiB
Core:  73 devices, 22 uclasses, devicetree: separate
WDT:  Not starting watchdog@1c20ca0
MMC:  mmc@1c0f000: 0, mmc@1c11000: 1
Loading Environment from FAT... Unable to use mmc 1:1...
In:    serial
Out:  serial
Err:  serial
Net:  phy interface11
eth0: ethernet@1c30000
MMC: no card present
** Bad device specification mmc 0 **
Couldn't find partition mmc 0
MMC: no card present
** Bad device specification mmc 0 **
Couldn't find partition mmc 0
starting USB...
Bus usb@1c1a000: USB EHCI 1.00
Bus usb@1c1a400: USB OHCI 1.0
Bus usb@1c1b000: USB EHCI 1.00
Bus usb@1c1b400: USB OHCI 1.0
scanning bus usb@1c1a000 for devices... 1 USB Device(s) found
scanning bus usb@1c1a400 for devices... 1 USB Device(s) found
scanning bus usb@1c1b000 for devices... 1 USB Device(s) found
scanning bus usb@1c1b400 for devices... 1 USB Device(s) found
      scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc1(part 0) is current device
Scanning mmc 1:1...
Found U-Boot script /boot/boot.scr
3259 bytes read in 2 ms (1.6 MiB/s)
## Executing script at 4fc00000
U-boot loaded from eMMC or secondary SD
Boot script loaded from mmc
155 bytes read in 2 ms (75.2 KiB/s)
MMC: no card present
** Bad device specification mmc 0 **
41777 bytes read in 4 ms (10 MiB/s)
3821 bytes read in 3 ms (1.2 MiB/s)
Applying kernel provided DT fixup script (sun50i-a64-fixup.scr)
## Executing script at 45000000
17114760 bytes read in 393 ms (41.5 MiB/s)
21934088 bytes read in 504 ms (41.5 MiB/s)
Moving Image from 0x40080000 to 0x40200000, end=41750000
## Loading init Ramdisk from Legacy Image at 4ff00000 ...
  Image Name:  uInitrd
  Image Type:  AArch64 Linux RAMDisk Image (gzip compressed)
  Data Size:    17114696 Bytes = 16.3 MiB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
## Flattened Device Tree blob at 4fa00000
  Booting using the fdt blob at 0x4fa00000
  Loading Ramdisk to 48fad000, end 49fff648 ... OK
  Loading Device Tree to 0000000048f3a000, end 0000000048facfff ... OK

Starting kernel ...

done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems
done.
Begin: Will now check root file system ... fsck from util-linux 2.36.1
[/sbin/fsck.ext4 (1) -- /dev/mmcblk2p1] fsck.ext4 -a -C0 /dev/mmcblk2p1
armbi_root: clean, 69593/130816 files, 435596/523264 blocks

My questions are:
- should I change any configuration files from the Armbian_22.11.1_Pine64so_bullseye_current_5.15.80.img.xz's image?
- should I try another image?

Thank's by advance
  Reply
#2
(12-30-2022, 07:48 PM)adjivas Wrote: Hello,

I try to boot Armbian on the SoPine with baseboard from a eMMC module.

From armbian/pine64, I try some Arbian images.
I get this error:
Quote:U-Boot SPL 2022.07-armbian (Nov 30 2022 - 10:45:59 +0000)
DRAM: 0 MiB
### ERROR ### Please RESET the board ###

So I try this specialized image Armbian_22.11.1_Pine64so_bullseye_current_5.15.80.img.xz.
But it's stuck at the `armbi_root: clean` line:
Quote:U-Boot 2022.07-armbian (Nov 30 2022 - 10:45:55 +0000) Allwinner Technology

CPU:  Allwinner A64 (SUN50I)
Model: SoPine with baseboard
DRAM:  2 GiB
Core:  73 devices, 22 uclasses, devicetree: separate
WDT:  Not starting watchdog@1c20ca0
MMC:  mmc@1c0f000: 0, mmc@1c11000: 1
Loading Environment from FAT... Unable to use mmc 1:1...
In:    serial
Out:  serial
Err:  serial
Net:  phy interface11
eth0: ethernet@1c30000
MMC: no card present
** Bad device specification mmc 0 **
Couldn't find partition mmc 0
MMC: no card present
** Bad device specification mmc 0 **
Couldn't find partition mmc 0
starting USB...
Bus usb@1c1a000: USB EHCI 1.00
Bus usb@1c1a400: USB OHCI 1.0
Bus usb@1c1b000: USB EHCI 1.00
Bus usb@1c1b400: USB OHCI 1.0
scanning bus usb@1c1a000 for devices... 1 USB Device(s) found
scanning bus usb@1c1a400 for devices... 1 USB Device(s) found
scanning bus usb@1c1b000 for devices... 1 USB Device(s) found
scanning bus usb@1c1b400 for devices... 1 USB Device(s) found
      scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc1(part 0) is current device
Scanning mmc 1:1...
Found U-Boot script /boot/boot.scr
3259 bytes read in 2 ms (1.6 MiB/s)
## Executing script at 4fc00000
U-boot loaded from eMMC or secondary SD
Boot script loaded from mmc
155 bytes read in 2 ms (75.2 KiB/s)
MMC: no card present
** Bad device specification mmc 0 **
41777 bytes read in 4 ms (10 MiB/s)
3821 bytes read in 3 ms (1.2 MiB/s)
Applying kernel provided DT fixup script (sun50i-a64-fixup.scr)
## Executing script at 45000000
17114760 bytes read in 393 ms (41.5 MiB/s)
21934088 bytes read in 504 ms (41.5 MiB/s)
Moving Image from 0x40080000 to 0x40200000, end=41750000
## Loading init Ramdisk from Legacy Image at 4ff00000 ...
  Image Name:  uInitrd
  Image Type:  AArch64 Linux RAMDisk Image (gzip compressed)
  Data Size:    17114696 Bytes = 16.3 MiB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
## Flattened Device Tree blob at 4fa00000
  Booting using the fdt blob at 0x4fa00000
  Loading Ramdisk to 48fad000, end 49fff648 ... OK
  Loading Device Tree to 0000000048f3a000, end 0000000048facfff ... OK

Starting kernel ...

done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems
done.
Begin: Will now check root file system ... fsck from util-linux 2.36.1
[/sbin/fsck.ext4 (1) -- /dev/mmcblk2p1] fsck.ext4 -a -C0 /dev/mmcblk2p1
armbi_root: clean, 69593/130816 files, 435596/523264 blocks

My questions are:
- should I change any configuration files from the Armbian_22.11.1_Pine64so_bullseye_current_5.15.80.img.xz's image?
- should I try another image?

Thank's by advance

I don't have the SOPINE, however have been having the same boot issue as your original post with the A64-LTS, which shares the same software as the SOPINEs. Did you use this solution, which was who posted this thread? If not, how did you do a hard reset?

As far as different software, what I've found is that it is limited to what works for A64-LTS/SOPINE, and what has been discontinued. As far as Armbian goes, many of the images that are built are not fully tested. It is a resources issue, but when you find an image that doesn't work and message the Armbian team, they usually (if not always) respond. Consequently it is helpful to try different Armbian versions, going backwards until a release boots. Also save the post messages for debugging when an image doesn't boot consistently.

The first image I tried, an Armbian image has kept me at the reset hardware message so I am unsure of other working images.
Quartz64, RockPro64, PinePhone Mobian, PineBook Pro, PineTime, and all the trimmings that make FOSS fun.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't boot from eMMc with Armbian 23.8 Bookworm francoispawlus 1 429 11-13-2023, 04:12 AM
Last Post: francoispawlus
  slarm64 (unofficial slackware) SOPINE A64 (aarch64) mara 6 3,639 09-24-2023, 11:43 AM
Last Post: mara
  Sopine Fedora 32 on clusterboard w/networking revoman 7 9,126 04-10-2023, 08:49 AM
Last Post: langerma
  SoPine SPI booting ayufan 31 38,828 02-13-2023, 08:56 PM
Last Post: mundey
  Manjaro won't boot from EmmC adjivas 0 455 12-30-2022, 06:25 PM
Last Post: adjivas
  sopine-a64 yocto build running on SOPine Baseboard tderensis 1 1,360 07-13-2022, 03:14 PM
Last Post: tderensis
  Armbian 22.02 Release Announcement TRS-80 0 1,072 02-28-2022, 05:00 PM
Last Post: TRS-80
  Warning: Boot regression in latest kernels (4.19, 5.10 etc.) kuleszdl 4 3,503 08-22-2021, 01:27 PM
Last Post: kuleszdl
  Volumio (PINE A64-LTS / SOPINE) pineadmin 7 9,124 02-17-2021, 03:47 AM
Last Post: roel
  No HDMI output on standard Debian install / no boot sagada 2 4,540 09-06-2020, 03:54 AM
Last Post: kuleszdl

Forum Jump:


Users browsing this thread: 1 Guest(s)