Manjaro won't boot from EmmC
#1
Hello,

I have a Sopine Baseboard Model A
This board haven't a SD interface, it's has a eMMC interface.

I downloaded the last 22.06's image of Manjaro Arm from manjaro-arm/pine64-lts-images's repository.

I flashed my eMMC Module and mounted it on the Sopine baseboard, I connected my USB serial console/programmer and I power on the Sopine.

My problem is during the boot, nothing happen after the `Starting kernel ...` line.

Quote:% sudo screen /dev/ttyUSB0 115200
U-Boot SPL 2022.04-2 (May 05 2022 - 08:29:42 +0000)
DRAM: 2048 MiB
Trying to boot from MMC2
NOTICE:  BL31: v2.6(release):
NOTICE:  BL31: Built : 08:29:42, May  5 2022
NOTICE:  BL31: Detected Allwinner A64/H64/R18 SoC (1689)
NOTICE:  BL31: Found U-Boot DTB at 0x209c938, model: SoPine with baseboard
SCP/INF: Crust v0.5.10000


U-Boot 2022.04-2 (May 05 2022 - 08:29:42 +0000) Manjaro Linux ARM

CPU:  Allwinner A64 (SUN50I)
Model: SoPine with baseboard
DRAM:  2 GiB
Core:  39 devices, 17 uclasses, devicetree: separate
WDT:  Not starting watchdog@1c20ca0
MMC:  mmc@1c0f000: 0, mmc@1c11000: 1
Loading Environment from FAT... Unable to read "uboot.env" from mmc1:1...
In:    serial
Out:  serial
Err:  serial
Net:  phy interface10
eth0: ethernet@1c30000
starting USB...
Bus usb@1c1a000: USB EHCI 1.00
Bus usb@1c1a400: USB OHCI 1.0
Bus usb@1c1b000: USB EHCI 1.00
Bus usb@1c1b400: USB OHCI 1.0
scanning bus usb@1c1a000 for devices... 1 USB Device(s) found
scanning bus usb@1c1a400 for devices... 1 USB Device(s) found
scanning bus usb@1c1b000 for devices... 1 USB Device(s) found
scanning bus usb@1c1b400 for devices... 1 USB Device(s) found
      scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc1(part 0) is current device
Scanning mmc 1:1...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinux.conf
1:      Manjaro ARM
Retrieving file: /initramfs-linux.img
Retrieving file: /Image
append: initrd=/initramfs-linux.img console=ttyS0,115200 root=PARTUUID=1f2fe968-00ee-4b00-ad77-12e7c5c80fac rw rootwait audit=0 splash plymouth.ignore-serial-consoles
Retrieving file: /dtbs/allwinner/sun50i-a64-pine64-lts.dtb
Moving Image from 0x40080000 to 0x40200000, end=419e0000
## Flattened Device Tree blob at 4fa00000
  Booting using the fdt blob at 0x4fa00000
  Loading Ramdisk to 497f6000, end 49fff57e ... OK
  Loading Device Tree to 00000000497e9000, end 00000000497f5dd7 ... OK

Starting kernel ...

My questions are:
- Manjaro Arm isn't yet compatible with Sopine Baseboard?
- Should I change any files of configuration from the Manjaro Arm image?

Thank's by advance!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't boot from eMMc with Armbian 23.8 Bookworm francoispawlus 1 599 11-13-2023, 04:12 AM
Last Post: francoispawlus
  Try to boot armbian 22.02 on SoPine baseboard adjivas 1 960 01-11-2023, 03:20 PM
Last Post: MNtinkerer
  Warning: Boot regression in latest kernels (4.19, 5.10 etc.) kuleszdl 4 3,657 08-22-2021, 01:27 PM
Last Post: kuleszdl
  No HDMI output on standard Debian install / no boot sagada 2 4,666 09-06-2020, 03:54 AM
Last Post: kuleszdl
  SOPINE Network boot Ninazu 1 3,825 05-11-2020, 12:40 PM
Last Post: lbruno
  Trying to boot archlinux-minimal-sopine-20170708-1.img kris240376 0 2,559 05-25-2018, 10:30 AM
Last Post: kris240376
  Cannot boot into Xenial Mate Jacob5146 4 6,908 04-22-2018, 11:00 AM
Last Post: Jacob5146
  [SOLVED] Boot from SD works, no boot with eMMC gkkpch 4 7,233 11-25-2017, 07:25 PM
Last Post: gkkpch
  PXE boot w/ SPI Flash bourg 2 4,817 09-12-2017, 03:24 AM
Last Post: ayufan
  No boot on any Linux image :/ oxomoxo 2 3,223 08-11-2017, 09:44 AM
Last Post: oxomoxo

Forum Jump:


Users browsing this thread: 1 Guest(s)