Temporary fix for Modem Not Coming Back on in SXMO Postmarketos Pinephone
#1
Hey,

I hope this script can be useful to someone, but basically the instructions are in the github.

Its a cron job that runs to check if the modem is there, and if it isn't there it will wake it up.

This should work on systemd, too, but it may need some tweaking, as I haven't tested it on systemd.

https://github.com/bakerk98/eg25-modem-cron-job
  Reply
#2
Thanks for you work looking into this problem.  I'm glad to see I'm not alone in this problem and making efforts to mitigate it. 

I was excited to see that restarting eg25-manager might get a modem that's gone missing back online. I can restart eg25-manager without any errors but unfortunately in my case, it doesn't help Sad So far the only sure-fire method I've found is to restart the device. I'm considering automating a call to reboot when the modem disappears, but for now I just have the phone play an audio file every minute to remind me to restart.

I've also seen a second problem that I intend to see if an eg25-manager restart might help. Every so often my phone loses its LTE connection, and when this happens I can't place or receive calls. Since it's not readily apparent if I'm not getting a call because no one's calling or because LTE is off in the weeds, this is also a problem. So again, I play a sound to tell me to check the phone. I thought that mmcli -m 0 -e might fix things but that experiment failed. Sometimes LTE comes back on its own . . .

I'll post if I find anything else of note.

update:

Hmmm. restarting eg25-manager might actually have worked after all. I tried it when LTE service dropped out and it didn't appear to help when I rechecked the output of mmcli -m 0|grep access. But the modem had returned as modem 1, and I was just assuming it would be restarted as modem 0 again. I'll have to wait for the modem to disappear again to retest this.
  Reply
#3
(06-16-2022, 08:40 AM)robthebold Wrote: Thanks for you work looking into this problem.  I'm glad to see I'm not alone in this problem and making efforts to mitigate it. 

I was excited to see that restarting eg25-manager might get a modem that's gone missing back online. I can restart eg25-manager without any errors but unfortunately in my case, it doesn't help Sad So far the only sure-fire method I've found is to restart the device. I'm considering automating a call to reboot when the modem disappears, but for now I just have the phone play an audio file every minute to remind me to restart.

I've also seen a second problem that I intend to see if an eg25-manager restart might help. Every so often my phone loses its LTE connection, and when this happens I can't place or receive calls. Since it's not readily apparent if I'm not getting a call because no one's calling or because LTE is off in the weeds, this is also a problem. So again, I play a sound to tell me to check the phone. I thought that mmcli -m 0 -e might fix things but that experiment failed. Sometimes LTE comes back on its own . . .

I'll post if I find anything else of note.

update:

Hmmm. restarting eg25-manager might actually have worked after all. I tried it when LTE service dropped out and it didn't appear to help when I rechecked the output of mmcli -m 0|grep access. But the modem had returned as modem 1, and I was just assuming it would be restarted as modem 0 again. I'll have to wait for the modem to disappear again to retest this.

Late reply, but for those wondering you can run mmcli commands with 'mmcli -m any' instead of specifying a specific number when the modem inevitably crashes and comes back.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinephone won't boot. spha 13 3,252 05-15-2024, 10:31 PM
Last Post: Richy_T
  Pinephone boot. Richy_T 5 283 05-15-2024, 03:35 PM
Last Post: Richy_T
  eSIM on PinePhone just_a_q 4 2,811 05-14-2024, 01:35 PM
Last Post: Kevin Kofler
  PinePhone - boot from microSD laserpyramid 9 1,043 05-03-2024, 10:09 AM
Last Post: laserpyramid
  pinephone virtual keyboard aular 4 527 04-10-2024, 03:45 PM
Last Post: aular
  PinePhone Doesn't Boot LED Doesn't Show Any Signs When Charging dorkydev 1 350 04-02-2024, 11:50 AM
Last Post: Kevin Kofler
  Are you using the Pinephone as your daily driver? jro 157 113,048 02-18-2024, 11:33 PM
Last Post: aular
  2020 PinePhone Manjaro CE EU for sale, name your price astrojuanlu 7 2,063 02-14-2024, 04:51 PM
Last Post: astrojuanlu
  Modem white list aular 7 1,136 02-13-2024, 04:35 PM
Last Post: aular
  pinephone is not bootble for the box. ijij 1 741 01-19-2024, 01:29 PM
Last Post: fxc

Forum Jump:


Users browsing this thread: 1 Guest(s)