RockPro64 has no white led, nor will it boot past...
#1
I have tried endless OS images, on both SD cards and eMMC, and am simply frustrated.

When I fire up a Debian buster image, it boots to the installer, gets all the way to the end, and then... Dies when it attempt to boot into the os for the first time.

The Armbian and ayufan images get to 'Flattened Device Tree blob at 01f00000' and 'Booting using the fat blob at 0x1f00000' and hangs.

There is no white LED at all as well.

Seems so strange as it grinds though so much doing the installer for Debian Bullseye.  

Hoping this is just my own stupidity, and I am missing something obvious.

Thanks for the advice and guidance.

Cheers
Anjin
  Reply
#2
So.. I kept going backwards, and found an image that booted.  Read a pile of materials, and decided to start with the sigmaris u-boot updates to SPI.  Painless, and system booted a current Armbian without issues.  Also have a white LED now.[/url]
/
u-boot[url=https://github.com/sigmaris/u-boot]
  Reply
#3
(05-30-2022, 09:40 PM)AnjinMeili Wrote: So.. I kept going backwards, and found an image that booted.  Read a pile of materials, and decided to start with the sigmaris u-boot updates to SPI.  Painless, and system booted a current Armbian without issues.  Also have a white LED now.[/url]
/
u-boot[url=https://github.com/sigmaris/u-boot]

Strange you couldn’t get the latest and Armbian Jammy found here to boot from SD. It really is just a case of downloading the image and writing it to an SD Card, popping it into the RP64 applying the power and you’re good to go. At least you’re up and running now but it looks like you spent a lot of time getting there. https://www.armbian.com/rockpro64/
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NAS Optimizations for RockPro64 MNtinkerer 25 2,019 08-03-2022, 01:57 PM
Last Post: MNtinkerer
  RockPro64 ddr clock speed causing system instability CypherShrugged 0 52 07-31-2022, 10:10 AM
Last Post: CypherShrugged
  U-BOOT Tutorial hazz 0 97 07-19-2022, 10:48 PM
Last Post: hazz
  Installation Debian on emmc: which U-Boot and where? vongillus 3 339 07-02-2022, 09:24 AM
Last Post: dkebler
  How to run Raspberry Pi software on RockPro64? pk245 0 211 06-24-2022, 08:20 AM
Last Post: pk245
  enble boot after power loss/restore dkebler 11 1,476 06-22-2022, 09:39 PM
Last Post: dkebler
  OPNsense for RockPro64 one8three 1 270 06-18-2022, 08:48 AM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 189 06-09-2022, 10:56 AM
Last Post: pspgarret
  RockPro64 Debian xrdb -- problem connecting emarsh 0 212 05-19-2022, 09:55 AM
Last Post: emarsh
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 4 3,080 05-11-2022, 02:35 PM
Last Post: PsySc0rpi0n

Forum Jump:


Users browsing this thread: 1 Guest(s)