Modem disabled, can't enable: Invalid transition
I have a new PinePhone, with a new SIM card, and the modem won't connect. The carrier assures me the SIM card is activated. (I went through 5 or 6 support people and I believe the last one actually knew what he was doing.)

The phone came with Manjaro installed. I'm looking at the Cellular Network section of the Settings app, sometimes I see a SIM 1, sometimes SIM 2, I've even seen SIM 4. If I select SIM 1 (or whatever number) and go to Select Network Operator it says "Current operator: none". If I hit the Scan For Networks button, I get one of these messages:

  Scanning networks failed: Object does not exist at path "/org/freedesktop/ModemManager1/Modem/1"
  Scanning networks failed: Cannot scan networks: not enabled yet

I suppose the first one is because the number keeps changing.

When I hit View Modem Details, I see an Enable Modem button and a Force Modem Restart button. I have tried both of those a few times, and they don't do anything as far as I can tell. I have rebooted the phone a few times also.

I suspected a command line equivalent of the Enable Modem button might give me better feedback, so I tried this: `mmcli -m 2 -e` and it said

  error: couldn't enable the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Retry: Invalid transition'

And that, I guess, is the root problem. But I don't know what an invalid transition is so I can't troubleshoot any further without a hint.
Same problem here. I can't understand why these phones don't ship with the modem enabled and ready to use.
Have you tried using a different operating system, just to check if it is a software or hardware issue..?

Being able to boot from an sd card is a big plus for troubleshooting a Pine phone.
   Donate to $upport
your favorite OS Team
I installed Mobian on an SD card and the modem works. This is a good enough solution for me.
Ran into the same problem with a Beta Edition phone using Manjaro and Plasma Mobile. Was working fine at least in December. Trying to call the number gave an operator message says "the user is not receiving calls at the moment".

I got some help on IRC from a user called "signaltonoise" on this:

First I ran "mmcli -m any" which showed the "state" as "disabled".

Then I did "mmcli -m any -e" (requires sudo) which failed with "error: couldn't enable the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Cancelled: Operation was cancelled'"

Then I got the SIM PIN dialog and after entering the PIN and I did "mmcli -m any -e" again and it said "successfully enabled the modem".

Afterwards I immediately got the texts I was waiting for and "mmcli -m any" was showing the "state" as "registered".

Possibly Related Threads…
Thread Author Replies Views Last Post
  Modem white list aular 7 870 02-13-2024, 04:35 PM
Last Post: aular
  qcell modem id aular 6 840 01-15-2024, 10:05 PM
Last Post: aular
  Temporary fix for Modem Not Coming Back on in SXMO Postmarketos Pinephone kebab 2 2,089 07-16-2023, 11:14 AM
Last Post: kebab
  Modem gets disabled on every suspend jojuma 5 1,785 03-27-2023, 02:51 AM
Last Post: jojuma
  Modem audio settings jack1 2 1,299 02-04-2023, 04:01 PM
Last Post: jack1
  The modem switch affects the connection to battery? JohnDoe 2 2,026 03-30-2022, 12:02 AM
Last Post: JohnDoe
Question Modem problems with the distros I tried UltraBlack_ 9 5,269 02-21-2022, 01:57 PM
Last Post: KNERD
Big Grin troubleshooting Chatty / modem? no SMS outbound vap0rtranz 5 3,645 02-14-2022, 12:15 PM
Last Post: vap0rtranz
  PinePhone Beta 3GB modem not working hannescam 15 9,076 01-19-2022, 02:08 AM
Last Post: bcnaz
  Modem shows no carrier nb8550 2 2,255 09-30-2021, 01:19 PM
Last Post: acrux

Forum Jump:

Users browsing this thread: 1 Guest(s)