Android 7.1 (Pinebook) 0.3.10-66 [Sep 19] | Android 7.1 (PINE A64(+)) 0.3.10-66 [Sep 19] | Android 7.1 (SOPINE) 0.3.10-66 [Sep 19] | Linux Images (ROCK64) 0.5.9-104 [Sep 13] | Android Images (ROCK64) 0.3.4-86 [Sep 13] | PINE64 Installer v2.0.0-beta.3 [Sep 12] | Android Images (ROCK64) 20170809 [Aug 24] | Debian Jessie LXDE (ROCK64) 20170809 [Aug 16]

Getting Started | Visit the WIKI | IRC Logs | Forum Rules/Policy


Enabling wifi
#1
I need help with enabling wifi. I connected the module and I made sure it was correctly connected, I'm using xubuntu xenial and ethernet works ok. Pine can't seem to be able to find any wireless signals. How do I configure the wifi module?
Reply
#2
If you come to the chat site, use hexchat client, at irc.pine64.xyz:6667 we can talk about it better...

... what does :

sudo ifconfig

show? (wlan0, wlan1, rename4, other)


marcus
Reply
#3
(06-29-2016, 12:15 PM)MarkHaysHarris777 Wrote: If you come to the chat site, use hexchat client, at irc.pine64.xyz:6667 we can talk about it better...

... what does :

sudo ifconfig

show?   (wlan0, wlan1, rename4, other)


marcus

Hi Marcus, thanks for your reply. ifconfig shows me eth0 and lo. Additionally, iwconfig shows me eth0, sit0, lo, all of which say "no wireless extensions". This shouldn't be important, but I issued those commands via ssh.
Reply
#4
Quote:Hi Marcus, thanks for your reply. ifconfig shows me eth0 and lo. Additionally, iwconfig shows me eth0, sit0, lo, all of which say "no wireless extensions". This shouldn't be important, but I issued those commands via ssh.


For comparision to your setup, isuing 'sudo iwconfig' on my setup (also via SSH, but on debian instead of ubuntu) gets me:


Code:
[email protected]:~$ sudo iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Anembo (Billion)"  Nickname:"<[email protected]>"
          Mode:Managed  Frequency:2.422 GHz  Access Point: 60:03:47:07:7D:85
          Bit Rate:150 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=100/100  Signal level=-63 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dummy0    no wireless extensions.

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<[email protected]>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I take it you're running the pine64 headless - ie. sans X11/GUI interface? Just means you can't use the nice easy GUI config tools. You probably need to add some stuff to the /etc/network/interfaces file. For mine, I have 

Code:
# The wireless interface
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

# Disable Secondary Wireless Lan (8723bs Has Two Interfaces)
iface wlan1 inet manual

and in /etc/wpa_supplicant/wpa_supplicant.conf I have

Code:
network={
ssid="Wireless Network Name"
psk="network-password"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

I'd set those two files up for your config, and then reboot, and see what happens. Otherwise, after creating the appropriate entries in /etc/network/interfaces, you should be able to start it up by going 'sudo ifup wlan0' (to start up wlan0).
Reply
#5
(06-29-2016, 09:55 PM)pfeerick Wrote:
Quote:Hi Marcus, thanks for your reply. ifconfig shows me eth0 and lo. Additionally, iwconfig shows me eth0, sit0, lo, all of which say "no wireless extensions". This shouldn't be important, but I issued those commands via ssh.


For comparision to your setup, isuing 'sudo iwconfig' on my setup (also via SSH, but on debian instead of ubuntu) gets me:


Code:
[email protected]:~$ sudo iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Anembo (Billion)"  Nickname:"<[email protected]>"
          Mode:Managed  Frequency:2.422 GHz  Access Point: 60:03:47:07:7D:85
          Bit Rate:150 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=100/100  Signal level=-63 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dummy0    no wireless extensions.

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<[email protected]>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I take it you're running the pine64 headless - ie. sans X11/GUI interface? Just means you can't use the nice easy GUI config tools. You probably need to add some stuff to the /etc/network/interfaces file. For mine, I have 

Code:
# The wireless interface
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

# Disable Secondary Wireless Lan (8723bs Has Two Interfaces)
iface wlan1 inet manual

and in /etc/wpa_supplicant/wpa_supplicant.conf I have

Code:
network={
ssid="Wireless Network Name"
psk="network-password"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

I'd set those two files up for your config, and then reboot, and see what happens. Otherwise, after creating the appropriate entries in /etc/network/interfaces, you should be able to start it up by going 'sudo ifup wlan0' (to start up wlan0).
I made the proposed changes and it doesn't work, the command sudo iwconfig wlan0 gives the following output
Code:
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.
Reply
#6
Something is wrong, it should just work...

... where did you get your image, and how did you make the SD card?
Reply
#7
(06-30-2016, 08:07 AM)MarkHaysHarris777 Wrote: Something is wrong, it should just work...

... where did you get your image, and how did you make the SD card?

I downloaded from https://www.pine64.com/downloads, concretely I used this one: Ubuntu Linux Image [20160501] based on Longsleep build, updated by Pine64

Regarding to the method of creation of the bootable disk, I cd'ed to the directory where the uncompressed image was and issued the following command:
[url=https://www.pine64.com/downloads][/url]

Code:
sudo dd if=xubuntu-xenial-20160501-longsleep-pine64-8GB.img of=/dev/mmcblk0 bs=1M
I even searched in the terminal history for the very exact command, but as I'm able to boot and install an ssh server, I assumed the disk creation was just ok.
Reply
#8
(06-30-2016, 03:35 PM)c4tich Wrote:
(06-30-2016, 08:07 AM)MarkHaysHarris777 Wrote: Something is wrong, it should just work...

... where did you get your image, and how did you make the SD card?

I downloaded from https://www.pine64.com/downloads, concretely I used this one: Ubuntu Linux Image [20160501] based on Longsleep build, updated by Pine64

Regarding to the method of creation of the bootable disk, I cd'ed to the directory where the uncompressed image was and issued the following command:
[url=https://www.pine64.com/downloads][/url]

Code:
sudo dd if=xubuntu-xenial-20160501-longsleep-pine64-8GB.img of=/dev/mmcblk0 bs=1M
I even searched in the terminal history for the very exact command, but as I'm able to boot and install an ssh server, I assumed the disk creation was just ok.

hm... indeed something fishy is going on.

Since it is booting, it sounds like the image was written fine, but something is not configured correctly..

Can you run uname -a so we can get the kernel version (I believe the current kernel version is 3.10.102 #7, so you should get something like the below output), and regardless of the result, you should probably update your uboot and kernel as there has been a fewupdates since the 1st of May, so that might also fix the issue...

Code:
Linux pine64 3.10.102-0-pine64-longsleep #7 SMP PREEMPT Fri Jun 17 21:30:48 CEST 2016 aarch64 GNU/Linux

Update like this (as root, not sudo!) on any of longsleeps images:

Code:
bash <(curl -s [url=https://raw.githubusercontent.com/longsleep/build-pine64-image/master/simpleimage/platform-scripts/pine64_update_uboot.sh]https://raw.githubusercontent.com/longsl...e_uboot.sh[/url])
bash <(curl -s [url=https://raw.githubusercontent.com/longsleep/build-pine64-image/master/simpleimage/platform-scripts/pine64_update_kernel.sh]https://raw.githubusercontent.com/longsl..._kernel.sh[/url])
Reply
#9
(06-29-2016, 09:55 PM)pfeerick Wrote: For comparision to your setup, isuing 'sudo iwconfig' on my setup (also via SSH, but on debian instead of ubuntu) gets me:


Code:
[email protected]:~$ sudo iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Anembo (Billion)"  Nickname:"<[email protected]>"
          Mode:Managed  Frequency:2.422 GHz  Access Point: 60:03:47:07:7D:85
          Bit Rate:150 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=100/100  Signal level=-63 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dummy0    no wireless extensions.

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<[email protected]>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I take it you're running the pine64 headless - ie. sans X11/GUI interface? Just means you can't use the nice easy GUI config tools. You probably need to add some stuff to the /etc/network/interfaces file. For mine, I have 

Code:
# The wireless interface
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

# Disable Secondary Wireless Lan (8723bs Has Two Interfaces)
iface wlan1 inet manual

and in /etc/wpa_supplicant/wpa_supplicant.conf I have

Code:
network={
ssid="Wireless Network Name"
psk="network-password"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

I'd set those two files up for your config, and then reboot, and see what happens. Otherwise, after creating the appropriate entries in /etc/network/interfaces, you should be able to start it up by going 'sudo ifup wlan0' (to start up wlan0).

I am using debian also and followed your instructions in your reply to other member and now my Pine is on my wireless network. Thanks for providing instructions to get it working.

hawk
Reply
#10
(06-30-2016, 05:20 AM)c4tich Wrote: I made the proposed changes and it doesn't work, the command sudo iwconfig wlan0 gives the following output

Code:
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

Sorry for not getting back to you sooner c4tich. I'm assuming you didn't make any progress as you didn't come back with a suitably joyous response Wink

Sounds more like it's something wrong with the /etc/wpa_supplicant/wpa_supplicant.conf file. Double check that it is formatted correct, and there aren't any missing quotation marks or braces - they are always in matching pairs - one to open and one to close. 

Otherwise, try a simpler version of it with just the network ssid and psk.

Code:
network={
ssid="Wireless Network Name"
psk="network-password"
}

Also, so you get any response'sudo iwconfig'? Does it at least indicate that the wireless module is functioning?

@hawk: Glad you got your wireless up and running, it certainly makes life easier when you can use wifi instead of wired connections!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Create a WiFi hotspot on Debian 8 JulianM 1 2,602 09-11-2017, 12:53 AM
Last Post: alex17pat
  Pine64 doesn't recognize Wifi/BT Module clobeca 3 131 07-13-2017, 08:58 PM
Last Post: MarkHaysHarris777
  Better WiFi/BT module? fonix232 17 1,053 02-13-2017, 04:38 AM
Last Post: xalius
Sad wifi direct bj_jung 2 704 12-29-2016, 10:26 AM
Last Post: happytuna
  WIFI & Bluetooth? 7777777 14 5,661 12-24-2016, 05:01 AM
Last Post: Toriless
  RF connector on wifi\bt board kb1qzh 1 343 12-15-2016, 06:36 PM
Last Post: tllim
  Wifi module able to share ethernet connection? Connection is unstable! cr2016 12 1,051 10-12-2016, 04:16 AM
Last Post: cr2016
  Losing WiFi Connection on Android Everytime mribunal 4 651 10-10-2016, 06:38 PM
Last Post: mribunal
  Unable to activate wifi on Linux smouton 5 1,444 09-17-2016, 10:35 PM
Last Post: MarkHaysHarris777
  Trouble getting Wifi board to work with Remix OS Seussman71 6 3,278 07-17-2016, 11:47 PM
Last Post: grantos

Forum Jump:


Users browsing this thread: 1 Guest(s)