Suddenly, nothing but a backlight and a boot logo flash
#1
I don't know why, but I can't get my phone booted now. It shows the Mobian logo for a second, then nothing but a backlight. I can't SSH in over USB — although that was already not working. I'm not sure where to go from here. Suggestions?
  Reply
#2
I would go for a serial cable to see what's going on. If not try to boot from the SD card.
  Reply
#3
Thanks, I ended up booting into JumpDrive and flashing the eMMC again. I think I just need to be prepared to flash once in a while.

I really wish I could figure out why ssh over USB stopped working, though. That used to work right out of the box.
  Reply
#4
If you would put on your SD card the multi boot image, you could boot jumpdrive but also a Mobian system. And could eventually check what's wrong on your emmc installation. I myself always have the multi boot image inserted since one can choose to boot from the emmc also. I love it!

I saw also quite a bunch of people having a corrupted f2fs filesystem. That also could be checked with booting from the SD card.
  Reply
#5
The Multi-Distro is pretty cool, but it is customized, it has a custom boot-loader.
It is supposed to give you an idea what the distro's look like, but they are derived from older releases.

NOT sure where you got your data on > "Bunch of people having a corrupted f2fs filesystem" ..?

I have not seen that mentioned on this forum, ... ever...!

I think, Mobian is still the only Pinephone operating system using the f2fs filesystem...
( I have been following Mobian since it was just called Debian.)

** When I searched your above quote in the forum, the one and only return was "Your Post"....

While I do agree that the ability to use an sd card to boot/ load/ troubleshoot the Pinephone is really handy.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
@3x5co

To the original Poster of this thread :
I would suggest trying some other distro's from an sd card, as it is a simple way to see if the phone performs properly on a different operating system.

* And can help discover if the problem is hardware or software related.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#6
Well I have nothing against f2fs but I read on the chat rooms (Mobian and Pinephone) several people with corrupted filesystems with f2fs. If you switch off your phone uncleanly and have to connect a serial cable to get it back to life, that's not a sign of very solid filesystem. And the little I googled around f2fs is that it's not yet the best candidate for a phone. For example on the arch wiki it's written: " F2FS has a weak fsck that can lead to data loss in case of a sudden power loss. If power losses are frequent, consider an alternative file system. ". So personally I would use ext4 or btrfs.
  Reply
#7
Regarding p-boot multi-boot image, I find it very useful because the boot menu allows it to boot from emmc. So I just keep it always in my phone and when I switch it on, I choose emmc booting. I have much less risk to break the SD card slot and if my emmc system fails for whatever reason, I have other systems on the SD card to boot from.
  Reply
#8
As far as the micro-sd card holder goes, I have not kept track of how many times I have swapped sd cards in my 5 Pinephones

But it may be over a hundred times in some of them.

I have downloaded and flashed all the popular Distro's many times,....  almost 2 years ago I got my first Brave Heart phone.

((As I have extra Pinephones for testing, I do not have to depend on those test phones for communications))

I have downloaded and tried almost every Mobian 'Nightly Release'  -- now the 'weekly release'.

>> The micro-sd card holders in all of my phones are still working fine.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#9
That happened  to me twice.

What helped in both cases was booting from an SD card and running
Code:
sudo fsck.f2fs -p /dev/mmcblk2p2

The first time it happened I was in real trouble because I was away from home and badly needed the phone. Ever since I have an SD card with the multi boot image in the phone as well (and a text file with that command in the documents directory of the mobian distro) so I can repair the eMMC if needed.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 1,853 11-22-2023, 11:46 AM
Last Post: aLoop100o
  How to check if tow-boot is installed? jojuma 3 891 09-29-2023, 11:29 PM
Last Post: tllim
  Mobian boot failed with zstd message after upgrade. Mahgue 0 611 09-01-2023, 11:29 AM
Last Post: Mahgue
  [Megapixels] Flash strobe, pictures viewer and MPCamera error 22 freelectro 1 1,092 08-30-2023, 03:59 AM
Last Post: karensather
  4G data on default startup / boot dcinoz 1 814 04-29-2023, 11:24 PM
Last Post: dcinoz
  PinePhone won't boot after software update jb2000 2 1,304 03-17-2023, 07:26 AM
Last Post: Zebulon Walton
  Boot log analyses -> GPU no regulator (mali) found freelectro 0 937 03-06-2023, 12:06 PM
Last Post: freelectro
  ModemManager debug mode? (Needed to flash modem) calinb 1 1,180 02-27-2023, 04:18 PM
Last Post: calinb
  boot gets stuck shortly after disk decryption vortex 8 3,909 02-13-2023, 02:11 AM
Last Post: sharase
  [solved] Black screen at boot time mdk 0 993 01-13-2023, 03:33 AM
Last Post: mdk

Forum Jump:


Users browsing this thread: 1 Guest(s)