Help request: upgrade failed, locked out at decryption passphrase
#1
Hi, I'm sad to introduce myself with such a bad issue Sad

I decided to upgrade my mobian pinephone to bookworm. I plugged in the charger, turned off the sleeping options, modified the source lists (mobian to bookworm)
Code:
sudo nano /etc/apt/sources.list.d/extrepo_mobian.sources
then

sudo apt update

finally

sudo apt upgrade.

After a while, upgrade was still stacked at 0% while the battery was discharging (yes, it was correctly plugged in).

My bad move was to cancel the upgrade by ctrl+z in the terminal (but I think it makes no difference, since the battery was going to die anyway) and restart the device in the hope to fix the issue.

As I mentioned in the title, now I cannot even enter the decryption passphrase.
Is there a chance to bring my pinephone back to life?
Huh
  Reply
#2
Sorry, after initial panic, I'm looking to solve this by reinstalling mobian by an SD card with mobian image. Some questions still raised in my mind: will this delete all my original files and configurations? I guess no one was in this situation, If I will move on this I'll give back a feedback.
  Reply
#3
Sorry for getting this up again, I'm moving little steps forward and keep updating the thread to make this useful to other unexperienced guys like me.
I managed to use Jumpdrive to make a backup (at least) of my home mobian directory and other folders I can copy without permissions problems.

Before starting a fresh new installation process, by flashing the eMMC pinephone, which I suppose will completely erase the disk let me loosing all configs and settings, I read on the wiki:


Quote:Jumpdrive also acts as a rescue image in case if you messed up your installation. To do so, you can telnet to 172.16.42.1, mount rootfs and fix it!


Do you think I can "easily" save all my stuff by mounting rootfs? and if so, how I can achieve this? I'm connected via Usb cable to my debian laptop.
Once I messed up my debian laptop too with a similar issue, but on laptop was much easier to restore the System and save all my stored files.

Thank you to anyone who want to give me a tip.

P.s.
Just because I missed to introduce myself before. I'm not a programmer by myself. I'm just a web designer and Open Source enthusiast. If you ask me about web design I can help, but I'm not a linux developer. I was also a researcher at University (long time ago) and I was very interested in the Open Source as a model for a new economy environment. This is why I keep interest in the Pine64 project as a community-driven company.
So my knowledge in tech is quite limited (and math is not my cup of tea), but I don't want to keep my knowledge just theoretical: I need to use and play with this stuff. Of course I do such big mistakes... Wink
  Reply
#4
One thing that's good to do once you get your eMMC installation sorted out is to use Jumpdrive to make a complete image backup of the disk. (I do this periodically.) That way if something happens that messes up your installation you can easily recover using the latest good backup. (I've already done this once, saved a lot of hassle by doing that rather than having to redo all my customizations on an out-of-the box installation.)

Some recommendations on utilities to do backups are in this thread:

https://forum.pine64.org/showthread.php?...&pid=81081
  Reply
#5
Thank you for the suggestion Zebulon Walton, I took a look at deja-dup in the past, but bad reviews discouraged me to try it: there is nothing worst than thinking you are safe when you are not. Anyway YES, you right, a backup system is absolutely needed.

Anyway, we know debian is great and mobian is in that path: I managed to recover everything because I was able to save my /home/user directory through jumpdrive, and after I reflashed the mobian installer on my Pinephone I imported the /home/user directory back to its position and everything is all right (even if I doubt it is a correct way to do a backup/recover and it's much better to regularly save an Image of a working system, but anyway it was good in an emergency situation).

Something to point out after my experience, besides my faults:

- Battery is still not working fine. I usually charge it between 20% and 80% as suggested by most producers. It's quite worrying that the battery discharge when it's plugged in. This may be related to high heal of GPU/CPU (better thing to do in this case is to power off the device). I also see some thread on the forum concerning the same issue.

- Something blocked the apt when I did the upgrade, I will double check if I edited sources in the right way.

- I have some kind of bug or misconfiguration about Keybord: during the installation and configuration progress, yesterday, I noticed some messages about it, unfortunately I can't found the related topic on debian bug tracker anymore. It was something like "keyboard settings are missing, guessing 'pc105' [...]  configuration may be incorrect". I don't know if it is related to my issue since I couldn't type anything when decryption passphrase was requested. I have installed the following keyboards: en/US, italian (italy), russian (russian federation), emoji and of course terminal.

Let's going on with Pinephone and mobian Smile
  Reply
#6
Whether you can "easily" fix it is going to depend on what got broken. I don't know what tools are available on jumpdrive once you telnet into it either - you may be better using another distro booted from uSD if jumpdrive is missing tools. If you're lucky you can mount the eMMC rootfs then chroot into it and rerun the apt upgrade or dist-upgrade to complete the process. I'm not certain what will happen if it tries updating the bootloader in this case though. There are a load of guides on chrooting for repair like the one below:
https://www.turnkeylinux.org/docs/chroot...air-system
  Reply
#7
Thanks for your additional suggestion wibble, in the previous post I forgot to mention that I tried to mount and chroot throught jumpdrive via telnet, dd the rootfs distro by pc but no luck. I'm not familiar with chroot but I think it was what I did with my debian a couple of years ago in rescue mode.
Using a flashed SD card could be a good option again.
I would mark this thread as solved, at least we found out some ways to recover a broken system.
Cheers!
  Reply
#8
as for general information. control-z is not stopping command, it just puts command into background (or foreground). commands "fg" and "bg" can be used to get back.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  GPS/location services don't work with Maps after Bookworm upgrade Anna 9 2,381 Yesterday, 03:18 AM
Last Post: biketool
  Firmware upgrade via fwupd user641 3 835 04-24-2022, 11:01 AM
Last Post: yehudac
  Epiphany browser broken after webkit packages upgrade user641 0 114 04-15-2022, 05:20 AM
Last Post: user641
  upgrade results Dinosaur1946 1 402 01-18-2022, 04:47 AM
Last Post: kqlnut
  Cant update and upgrade mobian. mode80 8 3,484 01-06-2022, 04:19 PM
Last Post: bcnaz
  Mobian kernel upgrade user641 4 1,407 11-10-2021, 01:22 PM
Last Post: user641
  scp.bin not found, can't complete apt upgrade Hiraghm 1 585 10-16-2021, 07:29 PM
Last Post: Hiraghm
  Safe to upgrade Bookworm again? nelstomlinson 2 1,074 10-12-2021, 03:45 AM
Last Post: bcnaz
  kernel upgrade user641 2 1,001 09-13-2021, 08:26 AM
Last Post: user641
  after dist-upgrade, terminal is broken nelstomlinson 9 2,204 09-09-2021, 06:47 AM
Last Post: nelstomlinson

Forum Jump:


Users browsing this thread: 1 Guest(s)