No incoming SMS. Outgoing SMS, calls and data working.
#1
As of Thursday I've suddenly not been receiving any SMS, and I can't find any errors or changed settings and I did not update anything to cause this to happen.

I am running Manjaro with Phosh, using Chatty for SMS.

From some research, I've come across a couple of similar threads.

https://forum.pine64.org/showthread.php?...&pid=92256 is recent and describes the same issue, the solution they describe is turning off the setting that allows data while roaming. I do not have that setting turned on, and the issue persists.

I've also followed the troubleshooting steps as outlined here:
https://wiki.pine64.org/wiki/PinePhone_F...eceive_SMS

sudo mmcli -m 0 --messaging-list-sms returns "No sms messages were found". My modem is also on 0 though the documentation says it should be 3 for Manjaro. Either way, that fix does not work and does not appear to be relevant.

I've adjusted to multiple configurations of the Verizon APN, all have the exact same issue with the same behavior.

I'm able to connect to the internet, send SMS, and make and receive phone calls but incoming SMS does not seem to work and there appear to be no errors logged, so I'm unsure where the issue lies.

When I use an iOS device I receive messages just fine even without iMessage so there's not an issue with the carrier.

This all happened overnight, I'm not sure what changed or what's causing this and I've tried just about everything I can think of - does anyone have any additional troubleshooting ideas that I could try? Any similar issues?
  Reply
#2
Most likely your modem is plugged with some MMS texts.

Myself I installed the App < 'Modem Manager GUI' > It is great at clearing those pesky MMS texts from the modem cache.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#3
(11-19-2021, 11:41 PM)bcnaz Wrote: Most likely your modem is plugged with some MMS texts.

Myself I installed the App    'Modem Manager GUI'    That makes it easy to clear those pesky texts.

That does not appear to be the case. Modem Manager GUI shows no Incoming Messages either, but those should have showed up with mmcli anyway. The behavior does fit that description, but I can find no record of the modem carrying any messages at all. I'm gonna deep dive into the documentation and see if mmcli is just not reading messages that are there.
  Reply
#4
I may have found a fix, based on info from this thread:
https://forum.pine64.org/showthread.php?...5#pid65065

Using atinout, I did

sudo atinout - /dev/EG25.AT out.txt << EOF
> AT+CMGD=?      #To show what's in the Modem's memory buffers
> AT+CMGD=0,4   #Iterates through the memory buffers between 0,4 and deletes each
> AT+CMDG=?      #To double check it worked.

What I got was

+CMGDSad0,1,2,3,4,5,6,7,etc...)(0-4)
OK (Which shows that the memory buffers are full, 0-4 are the relevant buffers, which I found and then deleted)
OK (Shows we completed iterating through the buffers successfully)
+CMGD: (),(0-4)
OK (Double check that it worked, and it did!)

Sent a text to my phone and it came through! Not sure why it wasn't coming up in mmcli or Modem Manager GUI, it looked like it might be Verizon system data rather than actual SMS or MMS messages? I didn't do much investigation because I'm very tired and just wanted texts working on my phone again, but if I get the chance to examine what exactly was clogging it up I may come back and share that information.

I'm going to make a chron job like in that thread to have this code run every hour or so to make sure this doesn't happen again. Hopefully this thread will help if anybody on the Verizon network has the same problem, because that seems to be a common thread.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Troubleshooting incoming SMS/MMS epiii2 5 164 05-18-2022, 11:15 AM
Last Post: epiii2
  Keyboard case stopped working on pacman update rotwang 5 352 05-07-2022, 09:17 PM
Last Post: rotwang
  Can't call or receive calls PJK2012 3 260 04-26-2022, 03:05 PM
Last Post: PJK2012
  Manjaro Plasma Beta and Cellular Data Service Fred Zyphal 7 1,356 03-17-2022, 05:50 PM
Last Post: Fred Zyphal
  Calls & SMS stopped working Schugy 3 734 12-28-2021, 05:00 AM
Last Post: Schugy
  Ctrl-O on virtual keyboard not working in nano PJK2012 3 1,117 11-11-2021, 08:47 PM
Last Post: PJK2012
  After fresh install outbound phone calls not working. tckosvic 2 844 11-10-2021, 10:45 AM
Last Post: tckosvic
  Installed Sim phone not working kmk7x 3 1,019 10-24-2021, 11:43 PM
Last Post: bcnaz
  Help Getting MMS Working on Manjaro Nightly Build 0x070 0 569 10-17-2021, 04:44 PM
Last Post: 0x070
  Issue with Calls on Phosh Barugon 4 717 10-15-2021, 05:46 AM
Last Post: Johnmash2

Forum Jump:


Users browsing this thread: 1 Guest(s)