Manjaro Plasma Beta and Cellular Data Service
#1
So, I've been playing with my PinePhone since about July of 2021, all of the different OS's, but since I use Ubuntu on my desktop and laptop, I've been happiest with Ubuntu Touch on my phone (this could all change back to Fedora at any moment).  As soon as I was able to, I ordered the PinePhone Pro which is still in transit, and since they seem to be shipping Manjaro with Plasma on the Pro, I decided to focus on that for a while.  I installed Beta5 a while back, and I was excited to see that cell phone service just always worked, it was great, way better than UT.  Eventually I upgraded to Beta10 and was very disappointed to see that it no longer worked, at all, so I put Beta5 back on just to be sure that I wasn't imagining things, and it still worked.  So I tried Beta9, and sort of accidentally discovered that cell phone service doesn't work unless you have cellular data turned on, I don't want cellular data turned on because I'm playing with my cheap Consumer Cellular SIM.  So another quick check of Beta5 confirmed that it works great with cellular data either on or off.  Sometime between Beta5 and Beta9, it broke, and I'm wondering if anyone else has seen this, and if anyone knows what happened, or more importantly does anyone know how to fix it?
***   Don't be a minion in the (i)droid army   ***
  Reply
#2
Ok, just hacking in Beta 10 here, and this is the original definition of hacking, press a bunch of random buttons until something good happens and see if it's repeatable.  I re-flashed a fresh copy Beta 10 because of issues I'm having with the Geary mail client, and at first boot I of course was registered with my service provider, because mobile data is on by default.  I used the top bar drop down menu to disable mobile data and to my surprise I was still registered with my service provider.  I hoped it would stick, but it only lasted until the next restart.  I played with the drop down menu hoping to get it back after restart, but no, it depends on the state it was in before the restart.

After playing around, a lot, I came up with the following method ... simply remembering to turn mobile data back on before you restart doesn't work, the next time around you'll lose cell service as soon as you turn mobile data off from the drop down menu.

So, do the following:
  • After a restart, use the drop down to turn mobile data on if it's not on already.
  • Open the system settings app, go to Cellular Network, provide your pass-code, then hit SIM 0, and View Modem Details ... notice that the "Disable Modem" button is available but don't touch it.
  • Now use the top bar drop down menu to disable mobile data and notice that you're no longer registered with your service provider.
  • Now back all the way out to the beginning of the settings app..
  • Then navigate all the way back through to View Modem Details and notice that "Disable" Modem has changed to "Enable" Modem.
  • Press Enable Modem and within a few seconds it will register with your service provider, without having mobile data turned on.

It's a stupid bunch of hoops to jump through, but it works, and will only last until the next re-start.

It is noteworthy to point out that Beta 8 does not have this problem ... hopefully some developer somewhere will take note here, and maybe fix it.
***   Don't be a minion in the (i)droid army   ***
  Reply
#3
Also applies to current PlaMo devel image.
Created an issue: https://gitlab.manjaro.org/manjaro-arm/i...issues/209
Could it be related to the change to networkmanager backend... ?
Edit: Seems to be an upstream issue: https://invent.kde.org/plasma/plasma-mob...issues/133
My experience with Manjaro PlaMo: https://forum.pine64.org/showthread.php?tid=15300
  Reply
#4
(02-11-2022, 05:22 AM)acrux Wrote: Also applies to current PlaMo devel image.
Created an issue: https://gitlab.manjaro.org/manjaro-arm/i...issues/209
Could it be related to the change to networkmanager backend... ?
Edit: Seems to be an upstream issue: https://invent.kde.org/plasma/plasma-mob...issues/133

WOW!  This is exactly how the system is supposed to work, and I see that the issue is already getting some attention.

Thank you so much.
***   Don't be a minion in the (i)droid army   ***
  Reply
#5
Well, there was a huge update yesterday, Feb. 14th, and for some reason when my Beta 10 got to the keyring song and dance, the update crashed. So I went to see if by chance there was a Beta 11 released, there was not, but there was a new Beta 10 dated Feb. 14th, the one I was running was dated Feb. 4th. After flashing the new version, updates went smoothly. Unfortunately the new version did not solve the mobile data issue that started this whole thread, however the workaround I outlined here (in post #2) still works. I have noticed that, sometimes, my service provider registration is lost during sleep, so I have to do the workaround again.

Since I had some time, I decided to backtrack and find out exactly when the problem started, and I learned that Beta 8 was the last version that did not have the mobile data issue. I've decided to run Beta 8 for now, since having a reliable phone connection is kind of essential to having a reliable phone, ya know? I'll keep my eye on things, keep testing the latest Beta release on an SD card, and jump back in as soon as I see the mobile data issue is fixed, but for now Beta 8 will be on my eMMC.

Never mind ... I was able to get the Geary email client running under Beta 10 but not Beta 8, so I'm back to Beta 10, and hope the modem issue will be fixed soon.

The upstream issue report says this will be fixed in 5.24.1, in the mean time there is a simpler command line workaround listed, but just like my method, you have to do it every time ... sudo mmcli -m 0 -e
***   Don't be a minion in the (i)droid army   ***
  Reply
#6
(02-15-2022, 09:00 AM)Fred Zyphal Wrote: The upstream issue report says this will be fixed in 5.24.1

So, we seem to be at 5.24.2 now, and this issue is not fixed ... how do I escalate this to the upstream people?
***   Don't be a minion in the (i)droid army   ***
  Reply
#7
Confirmed, it seems to be not fixed yet in PinePhone PlaMo. You can report your findings to above mentioned bugs Big Grin
I guess the fix is targeted to beta 11?
My experience with Manjaro PlaMo: https://forum.pine64.org/showthread.php?tid=15300
  Reply
#8
(03-01-2022, 07:15 AM)acrux Wrote: Confirmed, it seems to be not fixed yet in PinePhone PlaMo. You can report your findings to above mentioned bugs Big Grin
I guess the fix is targeted to beta 11?

Yes, it's much better in Beta 11.  Initially however, I used the drop down menu to disable mobile data, but when I went to system settings and cellular network, it disagreed, the check box that says mobile data was checked, and it said "On".  I uncheck that box as well, and it seems to be working correctly, but it's a little disconcerting to think that either the drop down menu or the system settings may be deceiving you.
***   Don't be a minion in the (i)droid army   ***
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Sad Latest Manjaro breaks Keyboard Case (Again)? hollerpots 4 232 06-17-2022, 07:48 AM
Last Post: hollerpots
  ttyescape on manjaro lolgzs 0 108 05-27-2022, 02:14 PM
Last Post: lolgzs
  double tap to wake > plasma mobile Uturn 3 446 05-19-2022, 07:55 PM
Last Post: epiii2
  auto start waydroid in plasma mobile? Uturn 2 540 04-19-2022, 03:47 AM
Last Post: dorthatapia
Lightbulb Using the fingerprint scanner w/ Manjaro danimations 0 192 04-10-2022, 07:34 PM
Last Post: danimations
Music Changing ringtone on Manjaro Phosh WebFreak 1 1,001 04-08-2022, 12:57 AM
Last Post: bellaalice
Question Help installing Snaps on Pinephone running Manjaro ARM w/ Phosh danimations 2 328 04-07-2022, 06:02 AM
Last Post: danimations
Question Running AnBox on Manjaro ARM w/ Phosh? danimations 1 314 04-07-2022, 01:13 AM
Last Post: Uturn
  Some "tricks and tips" for Manjaro Plasma Mobile acrux 1 1,460 03-10-2022, 10:38 AM
Last Post: israel
  Manjaro Phosh Issues Csanderson0313 8 2,508 03-05-2022, 08:23 AM
Last Post: Csanderson0313

Forum Jump:


Users browsing this thread: 1 Guest(s)